Question about 1993 Lincoln Town Car

1 Answer

My 93 towncar runs rough cold. it backfires up through intake i replaced plugs, wires and one coil pack, coolant sensor. i read codes 226 and 542. it runs ok warm, but can still hear misfiring, it feels like it has vacume leak

Posted by on

  • pscobell59 Mar 13, 2011

    could it be a another temp sensor telling ecm wrong info?.maybe telling computer the engine is warmed up when its not. it looks like there is a air temp sensor at air intake duct. could this be problem? the engine shows 19 inches of vacume at idle.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Lincoln Master
  • 14,036 Answers

YOU HAVE INTAKE MANIFOLD LEAK ALSO COULD HAVE BAD OR STICKING INTAKE VALVES. CODE PO 226 IDM SIGNAL NOT RECEIVED AND CODE PO 542 FUEL PUMP SECONDARY CIRCUIT.

Posted on Mar 12, 2011

  • Jonah Oneal Mar 13, 2011

    I GAVE YOU OLD CODE.CODES O226 THROTTLE POSITION SENSOR C ACCELERATOR PEDAL POSITION SENSOR C RANGE PERFORMANCE PROBLEM. CODE PO542 INTAKE AIR HEATER A CIRCUIT HIGH. A FAULTY INTAKE AIR TEMPERATURE SENSOR COULD BE THE PROBLEM. IT CONTROL FUEL SYSTEM BY MEASURING AMOUNT OF AIR ENTERING THE ENGINE.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2.2 litre 1995 gmc sonoma idles rough no trouble code. found hole i brake booster vaccum line fixed that. replaced and changed fuel filter, idle air control valve, got spark at coil packs, put new spark...


Three things you should check using a good code checker which can read sensor outputs - the throttle position sensor (TPS), the mass air flow sensor (MAF) and the EGR valve. While you are at it, replace the PCV valve.

Jul 30, 2017 | 1993 GMC Sonoma Club

1 Answer

93 talon hard to start runs rough untill it warms up. (backfires dies exetera)


I would start with checking the fuel pressure and boosting the fuel with spraying carb cleaner into the air intake hose.
It sounds like you are not getting enough gas into the cylinders.
Could be a vac leak too.

Sep 30, 2012 | Eagle Cars & Trucks

1 Answer

Still trouble with my 2001 Ford Windstar after replacing spark plugs and wires. It always starts instantly though still running a little rough. Sometimes the power doesn't kick right in to climb


I would suggest you run a compression check on this engine and also have the coolant recovery tank tested for the presence of combustion gases with a gas analyzer, any gases would indicate a leaking head gasket. Any engine cylinder that is lower than 5% of the highest reading cylinder in pounds per square inch has a problem like a scored cylinder or leaking intake or exhaust valve seat.

Jun 18, 2012 | 2001 Ford Windstar

1 Answer

VW Golf Mk4 1.4 16V AHW, backfires when cold. There were three broken wires, one goes to the EGR, one to the throttle body and one to the mass air flow. New throttle body, Coil pack and wires tested....


Aparently, a "full diagnostic" has NOT been done. If this statement were true, you would have found the cause of your problem.

With that said, backfiring is usually caused by damaged/leaking exhaust valves. Have you performed a compression test on this engine?

If the computer is "getting the wrong reading of the air/fuel mixture", then you should be getting oxygen sensor and/or fuel trim codes.

The coolant temp sensor does not cause the computer to get the wrong reading of the air/fuel mixture, it causes the computer to get the wrong reading of the engine coolant temperature. Although this will affect how much fuel the computer gives the engine, it does not cause it to get wrong readings of the mixture.

Just so you know, "diagnostics" consist of a WHOLE LOT more than hooking up a code reader and pulling codes from the engine computer.
People think that an automotive repair technician simply plugs in the "magic box" and replaces all the parts the "computer" tells him to replace...I WISH it were that simple!

Mar 18, 2012 | Volkswagen Golf Cars & Trucks

2 Answers

I have a 2008 Mercury Mariner V6 Premier 4x4. It is running very rough and makes a deep popping noise at idle. I had it connected to a computer. The computer says, misfire #4 and lean. I have changed the...


Smoke Test the intake manifold

When the Spark Plugs were replaced,
they may have over looked the intake
gaskets or damaged them

You either have a misfire on a coil that
isn't the one the code showed or you
have intake vacuum leaks & the lean
O2 Sensor Reporting.

I may have mis read what you said.

You have to replace all spark plugs,
look at O2 switching time ,then work
on the coil walking thing, with a new coil,
until you find the offender


Mar 23, 2011 | 2008 Mercury Mariner Hybrid

1 Answer

I have replaced coil pack, plugs, all three sensors, all new injectors, code is P150...idles a little rough on start up when cold only then runs perfect....help..2004 deville base Y


P0150 Oxy Sensor Circuit Bank 2, Sensor 1. P0151 Oxy Sensor Circuit Lo ...
oyur o2 sensor is bad on bank 2 is opposite from number one cylinder should be passenger side intake manifold o2 sensorfirst sensor there needs replacing

Mar 06, 2010 | 2004 Cadillac Deville

1 Answer

2000 hyundai sonata.. P0300, P0110 and P0102 codes..


Higher octane gas 93 with some good octane boost in the black can at autozone cost about 7 dollars or a bottle of 104 octane boost. Change the fuel filter. Probably only one coil pack is bad. The OBDII reader should tell you which one was a misfire.

Jul 15, 2009 | Hyundai Motor 2004 Sonata

2 Answers

I just replaced the timing belt on my 95 ranger 2.3l, i have all timing marks perfectly aligned. i have applied proper tension to the belt also, the truck still mis fires horribly but everything is working...


If the coolant temperature sensor is sending false low temperature readings to the computer, it could cause the computer to send too much fuel through the injectors causing rough running, spark plug fouling, and poor gas mileage. Replace the sensor, clean or replace the plugs, and see if it runs better.

Mar 04, 2009 | 1995 Ford Ranger Supercab

3 Answers

Engine rough in low idle


I would start by replacing your automatic air intake and throtle body sensor. Check these 2 things out and let me know.

tepfy

Feb 27, 2009 | 1992 Mercedes-Benz Mercedes Benz 300 Class

Not finding what you are looking for?
1993 Lincoln Town Car Logo

Related Topics:

530 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

78267 Answers

fordexpert

Level 3 Expert

5655 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...