Question about Mitsubishi Montero

1 Answer

Yesterday the suv was used to give a jump start to another vehicle. today everything started dimming after a few hours of driving and now it won't start. the alarm works fine, but no crank

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mitsubishi Master
  • 8,589 Answers

Hi, sounds like your alternator has packed up. Remove it and have it tested at your local parts chain. Please let me know if you have questions, and thanks for using FixYa.

Posted on Mar 12, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 jeep liberty sport will not start. It won,t even turn over. drove it yesterday no problems. after 1 hour tried to start didn,t work Can you help?


Have you tried to jump started ? If your jeep starts when giving it a jump, you may have a bad battery. Check fuses for fuel and ignition systems. If your battery is bad, could be because the alternator is not charging it. Might want to have this component tested.

Nov 20, 2016 | 2002 Jeep Liberty

1 Answer

Upon starting the SUV this squealing starts, it sounds like metal rubbing, after driving about 5-6 blocks the ABS lights come on. What is the problem?


There is a problem with the brakes, That should be check out, Before all at once they could give out on you, End the vehicle won,t stop. when you apply the (Brakes)

Nov 08, 2012 | 2004 Toyota 4Runner

2 Answers

Van woun't start. Had jumped yesterday, Replaced starter today. Still not starting


test solenoid.trace positive lead from battery.jump the two big wires at solenoid(use two screw drives.if cranks replace.other possibilites are a fusibale link its a inline fuse there is lots of them off starter.look like a little box in wire test both sides with test lite should lite at each end.

Feb 12, 2011 | 1999 Ford Econoline

1 Answer

After about an hour of driving home from work all my lights in the car dim and when I push on the gas the RPM's drop and the air bag light turns on and then the car won't start. I have replaced the...


Do you own or have access to a voltmeter? If so when car is running you should have a range of 12.6 volts to 14.8 at the battery cables.
If not jump start car and run it to local Autozone, Advance, etc parts store and the offer free testing on the car.

Also, if you've been driving for last two weeks on bad alternator, you might have damaged new battery.

Jan 04, 2011 | 1992 Oldsmobile Cutlass Ciera

1 Answer

My 06 ford expedition won't turnover. the battery appears fine. it initially had a hard time turning over in the cold, but now it won't turnover at all. it'll start if someone gives me a jump, but after a...


If you have a Battery charger, disconnect the Neg cable of the battery from the SUV and charge the battery overnight. When you get the SUV running, take it to Autozone or Oreillys for a free scan. Also ask them to do a Starter draw test and to analyze your charging system and Battery.

The Ford antitheft systems are really sensitive to low power. While your vehicle has a 12 Volt system, a fully charged battery will have 13.2 to 13.4 Volts in it. A drop of 10% in battery performance will drop the charge to 12 Volts or less. This is enough to make the anti-theft lock out the Starter.

I have seen Charging systems automatically turn off once a jumper cable is removed. You can see it on the dash gauges where the Alternator is working and remove the jumper and after several minutes a perfectly good Alternator stops working while you are driving. Then install a battery with a 13.2 Volt charge and everything starts working perfectly from then on.

I mention this because you may have felt the Battery was charging after the jump and really it was not. You have to watch the Volt meter in your dash while you drive, there will be no warning lights.

I hope I have been helpful with my solution and that you will get a scan on your SUV.

Jan 01, 2011 | 2006 Ford Expedition

3 Answers

My daughter's 1987 4 runner won't start after driving some.


bad fan relay.see if your radeater has good flow. if you keep running it like that you will lose your motor

Apr 05, 2009 | 1987 Toyota 4Runner

1 Answer

2003 expedition xlt


when you have a dead battery and jump start you half to drive the vehicle for 10 to20 miles to allow the altinator to recharge the battery. if this dont work then i would have the altinator checked to see if it is charging ,your local auto parts store will do this for free

Jul 31, 2008 | 2001 Ford Expedition

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8589 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...