Question about 1998 Ford Escort

1 Answer

When starting it runs normal but go put it in gear it stops running i thought it might be fuel filter stop up or plugs so i change both and plugs look like they was dipped in oil is that normal

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 3,640 Answers

If the oil is on the top side of the plugs, it likely you have bad valve cover gaskets. if on the bottom .thats another story, it could be numerous things. check the valve cover gaskets.

Posted on Mar 11, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

RE LK 3504 (35 hp 4 wheel drive Tractor starts, runs 5=10 minutes under load, then slowly fades away running slower and slower until it stops. Restarts in 15 min, same result


Here is an idea.
It sort of sounds like there is a blockage after a while in the gas tank.
If there were sediment in the bottom of the gas tank, it would start and run fine sitting still.
However, when driving it, it would be a matter of a few minutes until the sloshing of the fuel would cause the sediment to mix in with the fuel, and clog the filter screen in the fuel tank.
When it stops, the sediment would settle back down, and in 15 - 20 minutes, it would be clear again.
God bless your efforts.

May 08, 2017 | Cars & Trucks

1 Answer

I have a 302 in a 65 mustang that won't start. I changed plug wires points cap and even carb and still nothing. Any thoughts the car ran good then it just stopped running


Do basic tests. Spark at plugs? Correct fuel pressure? If you are running the old stock tank, check that fuel filter is not plugged with rust. Run compression test just for grins.

Aug 03, 2015 | Cars & Trucks

1 Answer

2000 Grand Vitara breaksdown, backfires and dies while driving after about 30 minutes. Starts again in about an hour. Changed fuel pressure regulator. Made no difference.


The check engine will be on if the key is on but engine not running . This is normal. If the check engine goes out when the engine starts there are no codes present . Did you check the fuel filter . Sometimes when a filter is dirty there is sedement laying in the filter canister . When the pump starts working the flow picks up the sedement and plugs any remaining open screen and stops the fuel completely . The engine stops . When the flow stops the sedement falls back allowing flow again. and the engine will run for another while . If the filter is old it should be changed anyway . Also when the engine stops check to see if there is spark at the spark plugs while cranking the engine .

Dec 28, 2013 | Suzuki Vitara Cars & Trucks

2 Answers

My 1993 buick park ave stalls when stopped at red lights


When was last "healthy" tune up? Plugs, wires, ALL filters including FUEL filter? I'd start there, and run a good fuel system cleaner w/next tank full of fuel. In winter, with fluctuating temps, condensation (water) forms in fuel tank and spark plugs don't burn fuel/water efficiently causing stumbling and premature wear on your plugs.

Feb 27, 2011 | 1999 Buick Park Avenue

1 Answer

Car idles rough in park also runs rough in overdrive


Sometimes a rough idle like that is a fuel filter. As you've already done the plugs and wires the fuel filter would be my next bet.

Mar 15, 2010 | 1993 Buick LeSabre

1 Answer

1993 F250 5.8L wont idle correctly,runs bad and smokes of fuel


check to see if the ground wire from the battery to the engine is tight if the cable is loose it will cause the injectors to flood the egine

Jul 12, 2009 | 1993 Ford F250

2 Answers

My 1995 GMC jimmy 4x4 just stopped running. Had it towed home. mechanic told me it was a fuel pump. just changed fuel pump and sending unit. Tried to start and will not fire. Put some gas in intake and...


Only one question.....was the fuel filter replaced? On a jimmy the filter is usually mounted to the rail up under the passenger door on the drivers side. Sounds like there is some sort of obstruction that is preventing fuel from making it from the fuel tank to the engine. I would have thought that the mechanic would have replaced the fuel filter first thing, so maybe it has already been done. Only you and the mechanic know the answer to that one. Good luck with your problem.

Jul 07, 2009 | 1995 GMC Jimmy

3 Answers

Was running great, quit running when in gear or given gas


sounds like you need to have fuel pressure test and check for plugged fuel filter

May 09, 2009 | 1994 Chevrolet Suburban

Not finding what you are looking for?
1998 Ford Escort Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...