Question about Ford Expedition

1 Answer

My 06 Eddie Bahuer Expy started to act weird about three days ago. It died while in the highway and was hard to start it again. Today it happen again but this time the engine light comes out. After checking the code at advance, I was told that the failure was "Fuel Rail Pressure Sensor" I try to search in line but nothing is clear about this. Any sugestions? thanks

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 249 Answers

It can also be called fuel injector pressure sensor, it has a plug that has 3 wires coming out of it. the fuel rail is mounted on top of the fuel injectors

Posted on Mar 11, 2011

Testimonial: "Thanks, I will try to find it and find out where to get it from. I guess that Ford will cut my head off . I am a handy man so I will do my best to replace it myself. I hope I can fix it. Thanks so much for your help."

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

2002 Cavalier starts then dies. Started about 1 week ago. Let sit overwrite started fine next afternoon. Ran great for several hrs. Started dying again. Replaced fuel filter, Ran great for a day. Now it...


Had a 89 cavalier did that start then die it map sensor. Also check ground wires if the become too corroded they won't start sometimes just run weird

Jan 21, 2015 | 2002 Chevrolet Cavalier

1 Answer

I have a 1988 Dodge Dynasty that acts like it's vapor locking.


yes fuel pump is dying (it's old ) it will finnaly give up the ghost some day soon then engine won't run at all

common problem pump heats up and shuts off cools off and runs again cyclic

this all assumes you have kept up on changing the fuel filter at reg intervals too

Jun 14, 2012 | 1988 Dodge Dynasty

1 Answer

My 91 Pontiac 6000 LE, V-6, 3.1 engine, will start good, go great on the highway but then when I slow down, it stalls out. Starts up but acts like it is choking out and dies again. When it does go, it...


You have a bad idle air / idle sensor. Your car believes that you are in idle at all times so when you come to a stop the engine floods. When the fuel evaporates you can drive again. Drove me crazy when it happened to me.

Sep 12, 2011 | 1991 Pontiac 6000

1 Answer

I just bought a 2003 Chevy Malibu LS I just made the first payment 10 days ago, now it won't start. It started just after making the payment, I pulled into the bank parking lot and it died; I thought...


Hello, I read your problem, and a lot of the symptoms you are describing seem like itmis possible, that you have a bad 02 sensor, this is part of your emissions, relating to the cadilac converter, it mostly acts up at lower speeds, like coming to a stop or slowing to make a corner. Sometimes also a bad fuel filter could cause this when rpms are down such as slowing or on corners. That is the two things I would check. Thanks mike

Sep 05, 2011 | 2003 Chevrolet Malibu

1 Answer

My 83 delta started acting like she was out of gas on the highway a few days ago, put bunch of gas in her she still kept acting like shewas loosing all power putt putting then she would die she would...


Hi Cathy! It sounds like your car needs a good tuneup (new sparkplugs, sparkplug wires, distributor cap, fuel filter etc). The lack of power could be related to a bad fuel filter but could also be due to bad spark plugs, a crack in the distributor cap etc. A full tuneup will address all of these areas. Best of luck!
Greg

Feb 21, 2011 | 1983 Oldsmobile Delta 88

1 Answer

Electrical problems with my 96 honda accord


This happens because the removal of the current to the computer or CPU gets de-programed. You may be able to solve the problem (if it comes up gain ) by disconnecting the negative cable with the engine off. Then renstalling it back after a minute.This will reprogram the computer.

Apr 05, 2009 | 1996 Honda Accord

1 Answer

1989 park avenue would run about 60 miles then die, could restart immediately, but would go about 4 to 10 miles then die again, could restart immediately but would repeat the 4 to 10 mile thing. A couple...


check harmonic balancer for slop back and forth,,,,these 3.8's have a crank posision sensor behind the balancer,that run off of the balancer,,,gthe rubber wears out and they start to flop around and timing gets messed up.../they cost around 100 bucks for a aftermarket,and if thats the problem,do yourself a favor and replace CPS while tour at it....good luck...Lee

Jan 10, 2009 | 1989 Buick Park Avenue

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...