Question about 1993 Volvo 940

1 Answer

I can only start the car with starting fluid when it is cold. Once the car starts it runs but every 10-15 seconds the tach drops 200-300 rpms.What could this be?

Posted by on

  • wsg411 Oct 19, 2008

    I can get my 1995 non-turbo 940 started on cool (South Texas cool, mind you) mornings only by cranking it forever -- I'll soon kill my starter at this rate. Then it runs really rough for a short while before smoothing out. I can't tell for sure if it's starved or flooded, but my suspicion is it's starved. Already replaced the air mass meter to substantial cost but no good effect.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Hello
fault IAC valve

Posted on Jan 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

F150 stalls


I'm assuming the truck runs ok once it is warmed up. Sounds like you need to make some adjustments. The cold idle speed is set too high, and the choke is opening too fast. The cold idle should be around 1500 rpm and the choke should take at least 90 seconds to open depending on air temp.

Jun 08, 2013 | Cars & Trucks

1 Answer

Astroflex 2100 autostart won't start all the time


you need to reprogram the tach as it may be a little stronger or weeker in your current van

Oct 10, 2009 | 2009 Chrysler Town and Country

1 Answer

87 ford ranger wont start without starting fluid


It sounds like you aren't getting fuel out of the cold start injector... remove the injector when engine is cold and switch on ignition... you should get a fine spray pattern for a few seconds... if not then there is probably a problem with the cold start circuit (Temp sensor fault), or the injector is faulty. pull electrical connectors one at a time and look for corrosion... Hope this helps...;-)

Apr 15, 2009 | 1987 Ford Ranger

1 Answer

Good idling speed


This all depends on when you are reading the rpms becaus ethe engine will run faster when you first start it to bring it up to operating temperature than it will drop down to about 700-800 when the engine is warm. i recommend letting your engine warm up, than read your tach and if it is still reading 1000 rpms than reduce it down to 700-800. your ECU will compensate for this when your engine is cold.

this could also be a possible bad Idle Air Control Valve because your engine speed should be regulated by the computer.

Mar 30, 2009 | 1998 Honda Civic

1 Answer

`91 Nissan D21 4 cyl MT Pickup won't idle when cold


sounds like the clutch isnt engaging properly in the situations you described. may need to check fluid levels if there ok. then may need to get serviced or checked at least

Mar 20, 2009 | 1991 Nissan Pickup

3 Answers

No Heat in 99 Taurus


Just finished fixing my daughters 1999 taurus heat. It would blow warm only when running down the road. At idle it blew cold. I started with replacing thermostat, and water pump because they are the easier fix. Still did not help. Then I replaced the heater core. A daunting job but not that hard to move the dash slighly out of the way to replace. There is a good write up at tarusclub.com. After that, heat was better but at idle, it would still blow cool sometimes. Researched and found answer. Park car on the steepest hill you can find with front of car up. Start car and take off reservoir cap. Let car warm up and keep rpms about 1500. After a while the fluid will come running out of the car and all over the place but it will bring air bubbles with it. Reduce rpm, add more fluid and repeat about 3 times. It will make a mess but after that, the heater works perfectly. We get heat long before the temp gage indicates any and it never blows cold unless you lower the temp.

Nov 21, 2008 | 1999 Ford Taurus

2 Answers

2004 jeep wrangler 2.4 litre 4 cylinder


check the ground wirea at the dipstick tube,remove them all,and bend the ends of the wire,look for weak or broken wires, i bought several 4 cyl jeep that had problems at shift, fall on their face < after the engine settled back in to place,so wires made contact> just a thot. the ground wires are small the engine moves,when shifting.

Jul 29, 2008 | 2004 Jeep Wrangler

3 Answers

"99 cherokee classic: sputtering when cold


I had the same problem with my 99 Cherokee. I was told to replace the blower motor for the carburetor, works great and gas mileage improved.

Jul 16, 2008 | 1999 Jeep Cherokee

Not finding what you are looking for?
1993 Volvo 940 Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Mark Jones

Level 2 Expert

76 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...