Question about 2003 Ford Crown Victoria

2 Answers

Car is missing power surging when hot outside runs ok when cool? ive changes fuel filter and plugs still doing it

Posted by on

  • auntpsue Sep 30, 2008

    my 2001 Ford Crown Victoria has been in the shop since this past Friday (five days now) and they cannot seem to find the problem. Diagnostic machine says "fuel injectors are not pulsing". Before I took it in, it was missing as if the spark plugs might need changing, losing power when car moving slow or at a stop, but on a couple of occasions there was a surge in power while at a stop. Can anyone help???

×

2 Answers

My crown vic was repaired by the dealership, and they replaced the #8 coil and spark plug; also, the DPFE sensor and the crankshaft sensor were replaced. no problems since then!

Posted on Oct 15, 2008

I have a 2003 with the same problem. I thought it was the alternator but after i swapped it out the problem continued. Any other ideas?

Posted on Oct 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2004 linconl aviador Have code p0301, p316 I


If you are saying everything is ok when the engine first starts but number one starts to miss when at operating temp. Sounds like the number one coil has developed a internal crack that opens up when hot or at operating temp..causing a miss.change it.but before changing the coil check the spark plug wire it may be breaking down when hot..good luck

Oct 21, 2014 | 2004 Lincoln Aviator

1 Answer

How come while driving my transmission sometime jerks?


interesting, ricky ? could b anything. fuel filter needs changed, the fuel we use today is garbage, ethanol is bad for our older engines. add some of that new dirt to tank, something360. ??? also, maybe a wire connection is loose., or bad spark plug wires? something is missing its continuity , making the engine miss, not your transmission, u hope ? start with checking your battery conn., clean, tight, etc., replace plug wires, change spark plugs, maybe ? but your plug wires could b the problem. ??? think about it, engine starts ok, its when its running does the problem come up. you have fuel, you need spark, you also need clean air .......... change air filter....... pcv valve......egr valve ?? could b sticking ......you treat yourself good, yes? treat your engine good...whens last time the transmission fluid and filter was changed ??? that could also cause a miss, a surge......yes? i hope this helps you ricky, just use common sence, it always serves me well, good luck, ken

May 14, 2014 | 1999 GMC Suburban

1 Answer

I got my 1997 mecury cougar spark plugs changed and a week later my car lost power and stopped running.ive changed a fuel filter,batterie and coil paks on it.it doesnt want to start


you'll have to see if its missing fuel,air,or spark.Fuel could be bad fuel pump,air something clogging air filter duct,spark bad coil,or coils,crank sensor.

Dec 10, 2013 | 1999 Mercury Cougar

1 Answer

Already changed coil, plugs,plug wires,distributor cap and roto, still skips when really hot outside


Check the following:
Cooling system working properly including fans.
Under hood fuel lines touching coolant or heater hoses.
Fuel lines under vehicle close to or not shielded from exhaust pipe, converter, muffler.
Fuel filter changed recently.
Fuel pump pressure.
Cheap gas.

I assume you are running the A/C. Which makes underhood temps higher. So what are your volts at the battery with everything running when this "skipping" occurs. Could be the alternator volts and/or amp output has decreased with age. This would cause the fuel pump to run a bit slower, reducing fuel pressure. Which could lead to fuel boiling somewhere in high heat areas. Do you have any other electrical loads like large stereo amps, fog/driving lights etc.

Aug 01, 2011 | Jeep Cherokee Cars & Trucks

1 Answer

1993 Buick LeSabre surges and almost dies intermittently


Check fuel rail pressure.

Add fuel to beyond 1/2 tank.

A weak fuel pump do not like to ran low on gas.


When was the last gas filter and fuel pump change?

90-120,000 miles is the typical change out.

Fuel pump like to quit on a HOT day.

Test the pressure and see is it within specification.


Good luck


Jul 08, 2009 | 1993 Buick LeSabre

1 Answer

Truck cuts off while driving down the road.


Replace the TFI module. Ford back in 1986 thur 1993 had problems like the one you wrote about. TFI module gets hot and shuts car or truck off then when it cools sometmies starts and sometimes not.

Jun 14, 2009 | 1993 Ford F150 SuperCab

3 Answers

Hi all, my vw corrado g60 is running hot all the time ive change the water pump, new head gasket,and had a new radiator and ive even taken out the thermostat and it still runs hot can any one help please.


Do a steam clean or wipe down on the engine block.

Locate ALL the freeze plugs location.

Monitor for slow coolant drip / steam / water mark on each freeze plugs.

Replace them ASAP.

Do a hydrocarbon HC dye test to rule out crack head and other minor leak(s)

=====

I will add more tips later in my Fixya TIP.

Please check out my Fixya TIP link HERE

or bookmark this Fixya link


http://www.fixya.com/cars/r3582329-how_to_inspectdiagnose_and_repair_minor_

Jun 12, 2009 | 1992 Volkswagen Corrado

1 Answer

Car problems.


Ok first you must stop allowing the fuel to get low keeit at least 1/2 tank at all times because the fuel covering the fuel pump in the tank cools it and makes it last longer remember this: its much easier to fill up the top half of the fas tank than the bottom half and cheaper too here in Wa state gas is still 4$ for reg and $4.80 for premium anyway
The fast that it starts right back up makes this problem much more broad as to what it can be. Because if it were a electronic module it would have to cool a bit before it would start. Does it Idle excessivly low now as compared to the way it used to? Theck for vacuum hoses adn caps (small plugs on the drivers side rear of the top of the engine make sure none are missing or cracked to a point where there is a hole.
Also check the air intake hose for any cracks or holes rake it off and clex it and inspect closly make sure its on completely and the clamps are tight
Does this problem happen if the fuel is half or more full if tou don't know fill it up and see and keep it more than half all the time

Aug 19, 2008 | 1999 Nissan Pathfinder

1 Answer

Crown vic trouble shooting


try changing temp sensor could be your problem

Jul 31, 2008 | 1992 Ford Crown Victoria

Not finding what you are looking for?
2003 Ford Crown Victoria Logo

212 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...