Question about 1994 Ford Explorer Limited

1 Answer

Cruise control 94 eddie bauer explorer, 4x4, 4.0, cruise control doesn't work at all???? checked fuses, vacuum lines wires, and connections. all ok???

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 372 Answers

Bet switches in steering wheel are bad...Very common. Especially if it has a air bag and the air bag light is on...I would clean the switches or if it has a air bag and the light is on replace the clock spring for the air bag and the light will go off and cruise will work again......

Posted on Jul 31, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where it's the speed module on a 03 Ford explorer Eddie Bauer


I'm guessing you're referring to the cruise control (speed control module)? I've included a pic to refer to what it looks like. depending on a v6 or v8 engine the location may differ under the hood. The wiring going into the object in the foreground is the module, with the cable on top that goes to the throttle to control speed.
25353550-40cwtduuy5ghso3oo5rkln1u-2-0.jpg

Jan 04, 2015 | 2003 Ford Explorer

1 Answer

No dashlights backup sensor or cruise control on ford explorer


have the CPU program reset using a code reader as jumping produces a surge of power that corrupts the program

Mar 10, 2014 | Ford Cars & Trucks

1 Answer

2004 Ford Explorer Eddie Bauer rear defog switch stuck on draining battery


The switch itself is probably bad. You can pop the switch out and unplug the wires to verify. You can pull the fuse to deactivate temporarily. The fuse is probably powering other items too, so find out what else is sharing the fuse.

Jan 26, 2014 | 2004 Ford Explorer Eddie Bauer

1 Answer

2007 ford expedition eddie bauer blower stuck on high


pull that switch from dash board and check the plug. make sure you have no burned or melted wires. maybe just the switch

Feb 02, 2013 | 2007 Ford Explorer Eddie Bauer

2 Answers

I have a 2000 Ford Explorer Eddied Bauer. Durning a hard rain storm my windshield leaked setting off the alarm. Now if I set the alarm the the lights flash but the horn will not work, and the curise...


could the ingress of water have got inside the control box?? or the wiring connections causing them to corrode ?' other than that i have no idea as i havent work on many of this vehicle here in spain.sorry for no instant fixya type answer

Jul 02, 2010 | 2000 Ford Explorer

1 Answer

2007 ford explorer check engine light, and aslo the fuel cap light on. Causes? I have already checked the cap several times, and filled up a few times.


the problem is in the evap system, could be a vacuum line or purge cannister,check for nay loose or cracked hoses

Nov 16, 2009 | 2007 Ford Explorer Eddie Bauer

3 Answers

2003 jeep grand cherokee cruise control not working.


Ok, the '03 Jeep Grand Cherokee uses a small vacuum line to control the servos. Since your light comes on, it's obviously getting power. 9 out of 10 times it's the vacuum hose.
Pop the hood and look on the passenger side towards the back for the engine coolant reservoir. It's most likely underneath it so you may have to remove the res. Check the vacuum hose and all vac. connections then check the electrical connections. If that's not the problem, check the cruise control connection to the throttle linkage.
If that still doesn't do it, you may need use scan tools and diagnostic procedures that are out of the scope of home mechanics.
Wish ya luck!

Jun 18, 2009 | 2003 Jeep Grand Cherokee

Not finding what you are looking for?
1994 Ford Explorer Limited Logo

393 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

71338 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22059 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...