Question about GMC Envoy XL

1 Answer

I have a false speedometer reading as well as a false oilpressure reading. The speedometer reads 30 MPH when at a dead stop! The oil pressure shows zero when driving down the highway or will be showing 60 to 80 psi. Very intermittent.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,028 Answers

I would star by checking the wires and connections for these gages. If they are good then replace the gages.

Posted on Jul 30, 2008

  • Ryan Rogers
    Ryan Rogers Jul 30, 2008

    Also, the gages are electronic, so check or replace the sending units for the gages. The speedo sending unit will be on or in the transmission, and the oil will be on the side of the engine. The sending units will be cheaper than the gages, so start there if replacement is required.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

98 ford contour 2.5l standard trans shows mph in reverse and 40 mph at appr 5 mph


I had a '94 Subaru Legacy that would, without any warning, show extremely excessive speed readings (80 -90 mph.) when I was going only 30 - 40. I never did figure it out, but eventually it totally stopped doing that. I realize this is not an answer, but I suspected the speedometer cable, although I never confirmed it. That almost surely has to be the culprit. You might try and disconnect it, wait an hour or so , reconnect it and see what happens. Good luck !!!

Jun 04, 2016 | Ford Cars & Trucks

1 Answer

My 05 Focus speedometer is wacky. All other gauges and systems work fine. The speedometer needle doesn't go to zero when vehicle stops moving.


Sounds like the speedometer is faulty. If the speed sensor were the problem, the odometer would not work correctly, the transmission would not shift correctly, and the check engine light would be on.

Nov 28, 2015 | Cars & Trucks

2 Answers

1997buick park ave won't stop d inging when driving oil light flashes...check oil and it has oil...driving me crazy


Hello Robert, you could have a bad oil sender unit. Install an auxiliary oil pressure gauge to measure the amount of oil pressure. If reading is around 15 PSI or better at idle, change the oil sender unit.

Apr 05, 2015 | Cars & Trucks

1 Answer

Oil light beep when stop at red light


It could be one or more of the following; clogged oil screen (pan must be removed), Excessive sludge or the oil pump. When the oil pump is going bad it shows at low rpms. ps it is also possible that your dipstick is giving a false reading- showing a false normal operating level. Good luck!

Mar 20, 2014 | 2006 Chrysler 300

1 Answer

Speedometer 10 mph fast


Make sure you have the correct tire size on the car. Door jam sticker should show the correct tire size.

Dec 22, 2013 | 1997 Subaru Outback

1 Answer

2000 hyundai Elantra speedometer making noise and reading wrong


sounds like speedometer cable is gone or the gears between the cable and transmission which makes the reduction for sppedometer if no cable on that year they have a sensor

Nov 28, 2012 | 2000 Hyundai Elantra

1 Answer

It is a 4x4 and I cant find the speed sensor that operates the speedometer. The speedometer sticks at 100mph at a dead stop. It also jumps around between 75 and 80 at random when I am only doing 45 mph.


On our Lincoln, the problem was the Alternator shorting and energizing the ground circuit with Positive juice. Our speedometer and odometer were both affected.

We had miles advancing and 45-50 MPH at a stop. Then inaccurate readings while the car was moving.

Car-stuff.com seems to have the best price for the actual speed sensor which is located in the differential @$11.94.

Please rate my solution and I hope I was helpful.

Nov 07, 2012 | 2001 Lincoln Navigator

3 Answers

OIL GAUGE GOES DOWN AT STOPS


I had the same problem with my 97 Wrangler 4.0..Change your antifreeze, replace with some new 50/50 mix...Also chanke your oil, replace the filter with a mopar filter and use stratght 30 weight motor oil...Solved my problem

Jun 24, 2009 | 1997 Jeep Wrangler

1 Answer

Factory oil pressure gauge maxed out at 80psi and shakes


is oil level full? oil sending unit will either be near filter or near distributor buy one look both places replace if no change get live oil pressure reading if shows better or lower than guage has short at censor in dash giving false high readings

Apr 05, 2009 | 1992 Chevrolet S-10

1 Answer

2004 Speedometer Problem


The speedometer in newer cars are electronic, so check your speed sensor.

Mar 05, 2009 | 2004 Chevrolet Tahoe

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

294 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...