Question about 1985 Mercedes-Benz 300

1 Answer

Alt wont charge - 1985 Mercedes-Benz 300

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 91 Answers

Either rebuild the alt or get a new one. But first, you should check all the wiring behind the alt, into the battery, and any associated solenoids.

Posted on Aug 01, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 hyundai tiburon wont start changed clutch cylenoed,changed alternater,changed battery .battery wont stay changed/wont charge.what else coulde it be


power TO the alt. is probably not there . turn on the key ( don't start ) check the terminals on the plug at the alt. there should be power on at least one terminal if not , you have found the problem

Feb 28, 2014 | Hyundai Motor 2000 Tiburon

1 Answer

ALTERNATOR wont charge


What is the idle speed? Are you sure the belt is routed correctly?

Apr 26, 2013 | 1993 Mazda MX-3

2 Answers

Altemator charges then wont charge


worn brushes in alt may cause this.when stops charging knock on alt if charges replce it

Feb 13, 2011 | Nissan Frontier Cars & Trucks

1 Answer

Kia sportage 2001 replaced battery and alt still wont charge


check alt.start car and remove battery cable.if car stalls replace alternator.car is running off the battery not alt.

Dec 28, 2010 | 2001 Kia Sportage

2 Answers

Light stays on . i have a new alt and new battery and new wire leading from battery to starter to alt. if i disconect the battery the car dies. the alt was bench tested and puts out 15.1 volts yet wont...


Check the drive belt tension and wiring connection at the alternator and at the battery. Check for a blown fuse in the fuse block . -hope this helps

Feb 24, 2010 | 1985 Cadillac DeVille

1 Answer

Battery light wont come on when key is turned on alt wont charge


First check the plug and wiring to the alt if ok The diode in the alt may have blow. one cause of this is removing the battery termanals while car is running.

Jan 03, 2010 | 2004 Isuzu Rodeo

1 Answer

Not charging


First tell me why you don't think it's charging.
Because of the voltage reading you are getting at the battery terminals? The range you want is between 13.6v to 14.2v. The higher the voltage the lower the amps. and true the other way, the lower the voltage the higher the amps. If you get a reading of 13.6v or lower, the alt is nearing or at max output. An alt can only run at maximum for around fifteen minutes and it will start slinging solder from overheating. It's a good indication the battery is either totally dead or junk. Charging above 14.2 the alternater is running wide open and is only putting out high volts which will cause the battery to boil , in turn destroying it. This is a bad alternater. All alternaters have integrated voltage regulater with the exception of ver few of the earlier ones. You cannot test an alternater by removing a battery cable to see if the engine keeps running without taking great risk of damaging the alt, regulator. So tell me why you feel it isn't charging. Remember an alt is not made to charge dead batteries. Their sole function is to maintain the battery charge. Without a battery, the alt won't last 10 seconds.
Hope to hear from you and good luck.

Sep 23, 2009 | 1986 Chrysler LeBaron

1 Answer

Alternator no charge changed alt with a rebuilt same problem no charge instrument cluster wont ground the voltage regulator


check the fuse on the side of the engine fuse box 125amp will not allow the alt to charge

Jul 14, 2009 | 2002 Ford Taurus

2 Answers

My 1996 nissan altima wont keep a charge ,I had the alt checked replaced the batt checked for ground (negative post) same thing batt light and loosing charge


Cables from alt to battery can be deposited/burned/oxidized. In this case battery wont get charged. Also check the alternator connections. Cable might be burned or not tight enough
Also serpentine belt might be not tight enough
Good Luck

Jan 17, 2009 | 1996 Nissan Altima

1 Answer

Short


Tour problem is in the voltage regulator inside the alt.
Replace the alt.

Oct 24, 2008 | 1993 Jeep Grand Cherokee

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

175 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

yadayada
yadayada

Level 3 Expert

70346 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...