Question about 2003 Jaguar S-Type

2 Answers

The car ran fine on a 125 mile trip. After sitting for 15 min-1/2 hour, ran rough for about 2 min and died. It will start and imediately die, or if left for a while will start run for a brief moment and die. I wonder if it could be a gas filter....

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I recently hooked up a inverter (2000w). At low RPM, the alt will keep up as long as I don't have a load pulling too much wattage. Burst loads are fine, as long as the alt has time to charge the batt. More then likely if the O2 sensor tests ok, then your battery or alternator are bad, or you have a loose battery cable.

Posted on Jul 30, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Could be the air sensor on the cat, a dealer can test this easily but would cost about £250 for the part

Posted on Jul 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 v70 new fuel pump starts runs 10 mins. dies won't start again for a few hours


sounds like a fuel filter issue is there an inline filter

Mar 19, 2017 | Cars & Trucks

3 Answers

2002 express 1500 van, will not start


remove dog house locate test port and install guage should be 45-60 psi

Mar 03, 2010 | 2002 Chevrolet Express

2 Answers

I need help with my 94 cutlass ciera V6!


I AM LEANING TOWARDS A POSSIBLE BAD CRANK POSITION SENSOR OR A POOR CONNECTION IN THE IGNITION CIRCUIT, PERHAPS A BAD IGNITION MODULE. CHECK TO SEE IF YOU HAVE POWER GOING IN THE MODULE AND GOING OUT. ALSO CHECK FOR SPARK WHEN IT IS HOT. I HOPE THIS HELPS. THANKS FOR USING FIX-YA AND FOR AN HONEST RATING. PLEASE FEEL FREE TO KEEP ME POSTED ON YOUR PROGRESS. BEST OF LUCK.

Aug 26, 2009 | 1994 Oldsmobile Cutlass Ciera

1 Answer

Car Runs and Loses Power and Quits Running


Try cleaning the fuel pump filter. Under the seat behind the driver lift the carpet and you will find a round cover with six screws remove the cover. The fuel pump is directly below unscrew the retaining round plate and remove the pump. At the base of the pump is a small filter if it is covered in black muck that's your problem. clean and replace. job takes about 10 mins good luck. please let me know how you got on!

shauunswbc@aol.com

Mar 10, 2009 | 2002 Land Rover Freelander

1 Answer

Engine intermitantly stalls


if this a fuel injected car just check to fuel pressure first.

Oct 24, 2008 | 1994 Pontiac Bonneville

2 Answers

Stalls / Dies / dead


this engine fuel pump prassurae low. it fuel pump celan. Your problem sovel

Jul 13, 2008 | 2003 Ford E150

Not finding what you are looking for?
2003 Jaguar S-Type Logo

207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jaguar Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

yadayada
yadayada

Level 3 Expert

70346 Answers

SPEEDY CAR WORK SHOP...

Level 2 Expert

447 Answers

Are you a Jaguar Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...