Question about Suzuki Sidekick

1 Answer

My 1993 sidekick jerks and skips when I try to accelerate. I have a straight shift 4X4. There is a clicking sound under the dash as if the ECM is the problem. Please help!

Posted by on

  • one4fun Oct 05, 2008

    where are the ground points located??

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 335 Answers

I have found these vehicles to be subject to a lot of ground problems check all the grounds and the ones hidden behind the rear seats

Posted on Jul 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the ecm located on a 1993 buick century. 3.3 6 cyl.


Under the dash on the passenger side. If there is a panel underneath, a sound insulator, the ecm will be visible with the panel removed. On some, the glove box has to be removed, don't know about a century, but on a Lesabre, you just remove the panel under the dash and the ecm is accessible.

Jun 28, 2014 | Cars & Trucks

1 Answer

What is wrong with my car when it jerks in drive


jerks when?

moving the shift lever. with hand?

moving car. in gear,name the gear, drive, L or reverse?

jerks from, 1 to 2nd gear, 2nd to 3? or ? (or when IT down shifts)

pretend we are blind (we are) and cant drive car,(hopeless) and

tell us exactly what works and dont work driving.

hot /cold engine, fast /slow/ accelerating/ decelerating, up hills and what gears.



if engine is hot, is your idle at 800 RPM parked, in park.

y/s

if not the idle controls are out of control and when you shift to drive

IT will jerk. this is an engine problem.

there are lots of other symptoms.

Jun 09, 2014 | 2007 Kia Sportage 4x4 V6

1 Answer

Suburban transmission shifting


Kickdown cable unhooked, attaches next to accelerator petal cable.

Apr 01, 2014 | 2003 Chevrolet Suburban 1500

1 Answer

1993 Sidekick: reset check engine light...


you know about the "Hidden switch" don't you, its a switch in the earlier model suzukis. It's located between the steering column and the speaker on the left end of the dash, just reach under the dash and feel for it, or you can take the speaker out and it's on the right side of the speaker hole.

May 18, 2010 | 1993 Suzuki Sidekick

1 Answer

Shifts hard and jerks under hard acceleration.


thottle positioning sensor? if trans has overdrive could be a lock up piece, dont remember name of it. there is a lucas oil product that might help. if it is the overdrive.

Nov 05, 2009 | 1994 Ford Taurus

1 Answer

I have Ford Ranger Supercab 2001. The 4wd does not engage.. clicking sounds from under the dash board. Please help :)


When you turn the dial to 4 wheel drive it controls a solonoid unit that then controls the electric motor that shifts the trasfer case to 4X4. The clicking sound that you are hearing is probobly the solonoid unit (4x4 control unit) engaging or trying to engage the trasfer case motor. From what I,ve heard the solonoid unit is located behind the plastic panel that is under the glove box and before the passenger side door. Moisture can build up in that area and ruin the solinoid unit over time. Check any fuses that have any thing to do with the 4x4. If the solonoid unit or fuses is not the problem, I would check the wireing to the electric transfer case motor and the motor itself. Good luck and God bless!

Oct 16, 2009 | 2000 Ford Ranger SuperCab

2 Answers

Hesitation , skipping,engine cuts out when accelerating


Bad coil they breakdown when the engine get hot. There is 3 coils total when it starts missing start pulling plu wires until you find the one that is not firing

Feb 28, 2009 | 1993 Chevrolet Lumina

1 Answer

4x4 doesn't engage


that box does engage the transfercase to 4x4,there is a small electric motor on the transfercase thats probably bad,try hitting it lightly with a hammer because just like an electric window motor it has brushes in it as well,but its possible that motor is shorting out causing it to draw alot from the charging system,at least my 1993 Ford Bronco did the same thing and thats what i replaced and now it works fine.

Oct 26, 2008 | 1993 Ford F150 SuperCab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

125 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...