Question about 1994 Pontiac Firebird

2 Answers

Every thing in the dash works except for the speedometer,it reads zero at all times and has caused the service engine light to come on when it stopped working

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

U might have to trace the wires that are in the instrument panel because I just recently had this happen with my gas gage and we had to find the wire from where the fuel pump conects to the wiring harness under the driverside back seat. In order to find the wire trace the wire from the tranny to the dash, but have the instrument panel tested first it might just be a simple problem as a bad instrument panel. good luck tracing wires are a *****....

Posted on Oct 14, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 979 Answers

Bad speed sensor, or associated cable. Trip odo not working also?

Posted on Jul 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 05 Focus speedometer is wacky. All other gauges and systems work fine. The speedometer needle doesn't go to zero when vehicle stops moving.


Sounds like the speedometer is faulty. If the speed sensor were the problem, the odometer would not work correctly, the transmission would not shift correctly, and the check engine light would be on.

Nov 28, 2015 | Cars & Trucks

2 Answers

Speedometer doesn't work


For speedometer related issues,the help links are provided below.Click the link below to go through its details :----

How to trouble shoot speedometer?

http://schematicsdiagram.blogspot.com/2011/06/speedometer-not-working.html

-----------
why speedometer not working? http://technoanswers.blogspot.com/2012/01/1996-fiat-bravo-speedometer-not-working.html

------------
Speedometer works but odometer not working? http://technoanswers.blogspot.in/2012/01/speedometer-works-but-odometer-not.html----------- Speedometer runs backward?

http://technoanswers.blogspot.com/2012/01/speedometer-runs-backward.html

---------
Warning lights on and speedometer died?

http://howtobyme.blogspot.com/2011/08/warning-lights-on-and-speedometer-died.html

--------------


ABS & Brake lights warning indicator steady on dash and speedometer not working?

http://howtobyme.blogspot.com/2011/11/abs-brake-lights-warning-indicator.html

-----------
Vehicles Cluster panel Not reading Miles?

http://schematicsdiagram.blogspot.com/2011/12/vehicles-cluster-panel-not-reading.html

---------
Odometer works properly but speedometer works intermittently? http://technoanswers.blogspot.com/2012/01/odometer-works-properly-but-speedometer.html

---------------
How odometer works in cars?

http://technoanswers.blogspot.com/2011/11/how-odometer-works-in-cars.html

--------------
Speedometer not working on Ford?

http://repairhelpcenter.blogspot.in/2012/02/speedometer-not-working-on-1993-ford.html

--------

This will help.

Thanks

Feb 14, 2012 | 1996 Plymouth Voyager

1 Answer

Speedometer not working, mileage clock goes to


Oh dear one of these problems. Sound like a loose plug or dirty connection in plug Very hard to find Start by checking battery and ignition circuit plugs and terminals Hope this helps Feel for you!

Oct 22, 2009 | 2002 Ford SVT Focus

1 Answer

My speedometer keeps jumpin to zero then it will come back to normal then it will do it again and sometimes stay on zero for a long time until service engine light comes on


The mechanic should check the speedometer because of it is malfunctioning .And also the speedometer cable . If the speedometer is worn out or destroyed then replace it but if malfunctioning and can be repaired then repair it.The speedometer cable if it is disconnected then reconnect it but if cut or destroyed replace it.The service engine light will light on because of there is a problem in the service part of the engine.

Sep 17, 2009 | 1994 Cadillac DeVille

1 Answer

OK all the other dash lights work except for the speedometer and the turn signal lights what would cause this its a 04 murano


There are little light bulbs behind the instrument cluster that will need to be changed. The cluster can come out fairly easy with just thre removal of a couple screws.

Jul 29, 2009 | 2004 Nissan Murano

3 Answers

Both speedometer & tachometer not working, both reading wrong.


There was a recent class action law suit settled with GM for this exact problem. You can google gm speedometer lawsuit and get lots of information. Unforutunately for most people I think the warranty was limited to 7 years and 70,000 miles. Which isn't a lot of miles for most people.

If you car isn't covered by the warranty there is a way to "reset" the speedometer.

You can turn the ignition slowly like you are going to start the engine. There is a very small "dead" space where you will see your guage lights go off.

What you want to do is cycle the ignition switch from off to that dead space. Each time you do it your stuck speedometer will move towards zero about 10 mph. So if its stuck on 40 you will have to cycle it at least 4 times.

At first you will probably actually hit the ignition and the engine will try to start.....just release it and try it again.

I know this because I have a 04 avalanche with 80,0000 miles and it has this problem about twice a month.

Jun 02, 2009 | 2004 Chevrolet TrailBlazer

2 Answers

Every Gauge quit working


check the ipc bfc acc fuse make sure fuses are not loose.

Apr 21, 2009 | 1999 Oldsmobile Alero

1 Answer

Speedometer not working service engine soon light on


I would guess there is a relation between the inop speedo and the service soon light being on. Push OFF and WARM on the climate control panel and hold down together for 5 sec to read codes.engine and transmission require speed input to set engine/trans parameters accordingly. The car car is safely performing in a back up mode until repairs are made

Apr 04, 2009 | 1993 Cadillac Seville

5 Answers

Both speedometer & tachometer not working, both reading wrong.


"The Fix" works...I would have not believed it untill I did it.... Start the car in reverse and about 5 times later it reset the speedometer back to zero.....wow!

Mar 25, 2009 | 2004 Chevrolet TrailBlazer

Not finding what you are looking for?
1994 Pontiac Firebird Logo

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6879 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...