Question about 1990 Toyota Cressida

Open Question

Stalls after running for 10 min, and won't start back for an hour or so. It's an 87 cressida.

Posted by on

  • ekim4900 Dec 03, 2008

    My 1986 cressida also stalls after running about 10 mins. but will
    restart right away and stay running as long as I give it a little gas.
    If I take my foot off the gas it will stall. This started after I
    changed the battery last week. Could it be a communication problem with
    the computer and Idle speed control?

    Mike Sorrenti



  • David Worth May 11, 2010

    Do you get a check engine light? Does it happen sooner or later when idling or driving? I am having a similar problem with my 90 cressida.

×

6 Suggested Answers

  • 72 Answers

SOURCE: 2000 2.0 vw shutt down after running 20 min

Replace the fuel pump relay, it's easy and cheap.

Posted on Jun 08, 2009

  • 3640 Answers

SOURCE: suburban stalls while driving

a bad crank sensor can cause this. shuts off while going down road, and will start about 10 min, later with no problems runs fine until it quits again. hope this helps,

Posted on Oct 07, 2009

Molson02536
  • 3854 Answers

SOURCE: 88 Trans-Am GTA 350 5.7 TPI fuel injected...Car

Your fuel filter may need to be replaced and the other area that needs to ab addressed would be a ICM (ignition control module) going bad. Common for ether issues to cause you the same problems.
You can have your ICM tested at Auto Zone free of charge and you can also pick up the fuel filter from there.
Thank you for using fixya and good luck

Posted on Jun 20, 2010

  • 2468 Answers

SOURCE: my 87 toyota 4-runner runs

when this happens,do you have anyway of cooling the E.C.M. unit to see if this component is heat sensitive?,or possibly the reluctor coil under the distributor tower has a thermal issue,the ignition coil that feeds the tower may also have a thermal issue,because you say after it sits a while its fine again for a time

Posted on Nov 03, 2010

  • 2 Answers

SOURCE: 1986 ford e350 rv stalling

yes electronic ignition module... 30$ fix it ...

Posted on Jul 12, 2011

  • 5370 Answers

SOURCE: car runs good, then occasionally

This rough idle is very much indication low fuel pressure and problem with iac valve.--The possibilities for this problem are low fuel pressure, or weak o2 sensor or dirty iac valve, dirty throttle body.---------

As per your problem mentioned, it indicates the problem with fuel pressure.-------- The fuel pressure is low.---------- First thing you can do is get the fuel pressure checked, this will confirm the problem. --------- If the pressure checked low that means problem is with faulty pump and clogged fuel filter.----------- If the fuel pressure is checked ok, then other possibility is faulty o2 sensor and crank sensor. The o2 sensors are before and after catalytic converter.-------Both the sensors are to be replaced.------ And as per you mentioned your problem, its quite possible that faulty o2 sensor will cause this problem.------ O2 sensor is the part which sends signal to ECM( the cars computer).It sends signal to computer about fuel / air mixture.How and when to send fuel to engine.--------- If o2 sends stops sending signal to cars computer then it will not send the fuel to engine.------- In your may be the o2 sensor is getting overheated and this is stopping the o2 sensor from sending signal to ECM.But when your car shuts off the sensor gets cool and again it starts working.------ So as per problem, get both the o2 sensors can be weak and needs to be checked and replaced.---------- Also get the crank sensor checked.------------- For stalling problem get the fuel filter cleaned, get the throttle body and IAC valve cleaned.------ The idle air control valve is also located at throttle body.Clean both throttle body and IAC valve with throttle cleaner.--------This will help.Thanks.Helpmech.

Posted on Aug 29, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Murray m2500 won't start after one day of having it


bad coil in it, i had bought a m2500 murray weedeater from walmart .did same thing i replaced the coil. bad when you buy something from wal mart and have to get it fixxed before you can use it. now it works fine

Apr 23, 2013 | Cars & Trucks

1 Answer

2003 crown victoria cranks wont start, was running fine, just cut out.never started again


As with any no-start situation, you need to know if you have spark to the plugs, fuel to the injectors, and normal compression to proceed.

Jan 28, 2013 | 2003 Ford Crown Victoria

1 Answer

1999 vw jetta turns off after 10 min of driving


It would be worth checking/replacing the ignition module ( see if you have a spark when it WON'T start) . Coil assy are plentiful and the most likely given your description. Very prone to over heating and shutting down. Good luck

Aug 26, 2012 | 1999 Volkswagen Jetta

1 Answer

Jeep will not start back up after it get heat in the block


the crank posistion sensor is bad replace it and that should do the trick prety big job

May 07, 2012 | Jeep Cherokee Cars & Trucks

1 Answer

1989 Toyota Cressida ,won't start. Battery is


Check starter, spark and fuel pressure.

Apr 13, 2012 | 1989 Toyota Cressida

2 Answers

2000 2.0 vw shutt down after running 20 min


Replace the fuel pump relay, it's easy and cheap.

Jun 08, 2009 | 2000 Volkswagen Jetta TDI

1 Answer

1987 dodge omni will not start when it is cold


Adjust choke assembly. Good mechanic, 5-10 min.

Dec 15, 2008 | 1987 Dodge Omni

Not finding what you are looking for?
1990 Toyota Cressida Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...