Question about 1998 Plymouth Grand Voyager

5 Answers

I'll start my van (sometimes it will happen as I'm driving down the road) and my instrument panel will stop working (temp gauge, speedometer and gas gauge) and idiot lights will come on. Then I hit a bump in the road and my instrument panel starts working again and the idiot lights go out. Any ideas would be appreciated.

Posted by on

  • 4 more comments 
  • sdossett Jul 26, 2008

    1997 Plymouth Voyager 3.3

  • kacy101 Aug 07, 2008

    I also own a 1997 Plymouth Grand Voyager and it just started doing the exact thing you describe!!! Sure would like to find out why, it being my only source of transportationa and i work 45 mins away from my house.

  • Anonymous Sep 16, 2008

    I have same trouble with my gages, they just stop working. I have changed wire harnesses re-soldered instrument circuit board.

    EMU -computer is next.

  • joci30 Apr 25, 2009

    I have the same issue but when mine does that the van wont start and the alarm and abs lights come on. It does however turn over but then it just turns off. Either i bang on the dash which works at times, but when it doesnt i have to sit and let the van cool. Also when the lights come on when im driving i noticed if i turn the van off in neutral the van will start the next time despite the alarm and the abs lights being on.

  • Anonymous Mar 19, 2014

    Hit pothole and gauges stopped working now van won't start

  • Anonymous Mar 22, 2014

    charging light comes on and off. when i start off, the light goes out. then it comes back on down the road. I put in reverse and tap on the gas the light gos out the comes back on while driving then sometimes goes out on its own.

×

5 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Here is a fix...I had the same problem with the instrument cluster going dead intermittently. Pound your fist on the dash and wahlah, everything worked again. It would also register an engine code of 'invalid or incorrect information or lost data', something like that. What I found was a hairline crack in a solder connection on the cluster circuit board right at the harness plug connector. Mine happened to be the ground pin for the cluster. And what do I mean by 'hairline' crack? It takes a trained eye to find cracks in solder connections. Most people don't see them, because it is a circular microscopic crack surrounding the pin where it solders to the board. It it usually caused from heating and cooling, vibrations, and other element that attack and deteriorate solder. Very intermittent, and very hard to find. So instead, just simply resolder each of the connections to be sure another one won't fail in the near future.

Posted on Oct 13, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I had this problem on my 200 Buick Lesbare and I found out I was using a replacement key and should actually be using a key that has the Buick logo on it. Maybe your problem is similar? Just and idea.

Posted on Aug 13, 2012

  • Adriennie Aug 13, 2012

    2000* (LOL)

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My 2000 voyager instrument lights go out abs light comes on alsoheater blower does same hit the dash comes back on now it is dyin on me drivin down road but starts back up instsntly any solutions

Posted on Apr 12, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Im a mechanic, and the above is right your cluster is going out. very common in grand caravans, voyagers, and so on. discontect the pos. battery termonal and reconect, this will sovle any glitches. but as far as the needing a new dash, its cheaper to by a used one from the junk yard than paying someone to solder it. good luck.

Posted on Dec 09, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Plymouth Master
  • 1,779 Answers

I have a '98 with the same problem. Check your tail lights when this happens. Mine don't work (but the brake lights do). I found out when a cop pulled me over because of no tail lights. It's a loose wire (bad ground) somewhere. Very difficult to find, because my lights go back on before I can start searching for the problem. Tail and dash lights on the same circuit, so that's where to look. Chrysler products are well known for their electrical problems. Get a manual w/ wiring diagram, check wires for dash lights, tail lights, look for bad connections, bad grounds, loose wires, chaffed wires. When lights are out is the best time, as you can see if moving different areas of wiring bring the lights back, then you are getting close. Good Luck countrycurt0

Posted on Aug 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the speedometer sensor


I have seen several neons with this issue. The instruments will stop working on ocassion or all together. I have found that the instrument cluster or wiring connector to the cluster can become slightly loose causing the speedometer to stop working. I would recommend putting slight inward pressure on the cluster when this happens to see if it has any effect. If the speedometer starts working I would advise turning your attention to the plug on the back side of the cluster to remove the slight movement that the plug mount allows.

Oct 02, 2014 | 1998 Dodge Neon

1 Answer

1999 dodge caravan gauges are all mest up


Could be different problems.
The cluster issue could be a problem in the printed circuit board inside the cluster.
The cooling fan problem could be low coolant, a blown fuse, a faulty temp sensor, fan motor, or relay.

Jul 07, 2012 | 1999 Dodge Caravan

2 Answers

My fuel gauge tach gauge speedometer heater temp gauge and driver power seat quit working


check the fuses. they are under the back seat just pull up on the lower part of the back seat and it will come out. fuse box is on the drivers side. check to see if water is getting in that could be the cause.

Feb 10, 2012 | 1996 Oldsmobile Aurora

1 Answer

I have a 1999 Plymouth Voyager mini-van - 4 cylinder, 2.4 engine. It drives good but the gauges are not work sometimes. The temperature gauge stays at zero; the odometer/speedometer either stays at zero or...


There have been several issues with the instrument clusters in the Voyagers and Caravans. The circuit board can have cold solders at the plug connection causing an intermittent failure of the instruments. The fix is to remove the trim under the dash, around the steering wheel and in front of the cluster. This can be done with just a phillips screwdriver and some patience. Once this is out of the way there are 4 screws that hold in the cluster. Remove the cluster, and with a low temp solder gun, heat the solder points where the plug connects until they are liquid and reset themselves. Reassemble the cluster and check them before you put the dash assembly back together.

Oct 18, 2010 | 1999 Plymouth Voyager

1 Answer

Our van jerks sometimes when going down the road, the gauges go up and down also. really weird! whats up?


sounds like you need the steering and suspension checked for the jerking while driving. And for the gauges i would have it checked at the dealer may need to replace the IPC (instrument panel cluster)

Mar 23, 2010 | 2000 Oldsmobile Silhouette

1 Answer

Instrument panel.


There is a bad connection at the cluster,remove the cluster,and check the plug in to the cluster,it is a bad connection.Also check the alternator to make sure there is enough volts present,with everything on,lights,ac/heater,on high,it should read at the battery,while engine running,13.65 volts,to 14.25 volts,if it is any lower,replace the alternator.

Jan 24, 2010 | 2003 Chevrolet Cavalier

1 Answer

The instrument panel works sometimes and then it doesnt.(the gas gauge,water temp,speedometer).also a leak by the oil filter


The gauge cluster usually has a plug where the wiring harness connects. If the entire cluster goes out, but comes back, it is most likely the plug.

Nov 02, 2009 | 1998 Dodge Caravan

3 Answers

Speedometer, gas gauge, odometer, rpm gauge not working


My gas guage, speed odometer and tempiture does not work
The speed odometre is reading 9999999 what should i do

Jul 29, 2009 | 1998 Nissan Frontier

1 Answer

Gauges gone crazy


Could need new instrument panel cluster but check for corrosion as the instrument panel connector

Aug 11, 2008 | 2000 Ford Windstar

Not finding what you are looking for?
1998 Plymouth Grand Voyager Logo

499 people viewed this question

Ask a Question

Usually answered in minutes!

Top Plymouth Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Plymouth Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...