Question about 2006 Mercedes-Benz ML-Class

2 Answers

The car cuts off when we take off we restart the car an have to push the gas hard then it rides ggood until we come to a light then it cuts off again ....

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Petrol or diesel?, need the codes reading first off, but would guess the fuel filter or air flow meter.
jib
www.mercanic.co.uk

Posted on Nov 24, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My ML320 2000 had same problem - mechanic said it is "mis-firing" - and this is a safety feature MB puts on car so not to damage it more - we had spark plugs replaced and runs great!

Posted on Aug 09, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bmw e36 1997 stuck in high gear and enhgine warning light on


Most likely a shift solenoid in the transmission.

Mar 28, 2013 | Cars & Trucks

1 Answer

Why can't I press down on my gas pedal?


yea check sensors and throttle body make sure nothen hitten and linkage free and clear hope helps

Oct 13, 2012 | 2005 Dodge Grand Caravan

1 Answer

My 1990 dodge power RAM v8 with a 318 runs good when its cold. But after running it for about 10min and restarting it cuts out when I push on the gas. Idles good and idles good when put in gear until I...


Start with the simple things first:
Make sure you have a clean air filter.
Change out your fuel filter.
Most of todays crappy gas is 10% alcohol and the weather is warming up.
Then if not: Sensors and computer chip upgrades may be the issue but start simple. If you have a good reliable tune up guy take it to him and have him run the diagnostics. Any lights or codes come up??
Best wishes,
TF

Jun 02, 2011 | 1990 Dodge D150

1 Answer

My 1993 Buick Century has trouble starting occasionally. After having it towed once when I wasn't able to get it started after about 30 minutes of trying, it started right up and continued to keep...


OK FIRST THING IS THE DIES AND WONT START FOR HOURS REPLACE THE IGNITION MODULE AND IGNITION COIL THAT WILL TAKE CARE OF THAT THE PLUGGED PROBLEM IS A BAD CAT CONVERTER ON THE EXHAUST SYSTEM REPLACE THAT AND YOU WILL HAVE POWER AGAIN THAT WILL MORE THAN LIKLEY TAKE CARE OF THE OTHER STALLING PROBLEM TO

Oct 18, 2010 | 1993 Buick Century

1 Answer

My 1993 cad sts keep cutting off when i ride for while then when i stop at light or stop sign for min and when i press gas to go forward the car turn off. then i start car back up and run again until i...


If you don't have any engine lights on, the first thing to replace would be the fuel filter. It is located under your car, probably about half way down. Just follow the gas line, and you'll find it.

Aug 30, 2010 | 1993 Cadillac Seville

1 Answer

Car will not run. push button light is green. car acts like it hits (starter engages and cranks and cuts off). Car has gas(put 2 gallons in to make sure gage is good. Battery is good.I Even tried to...


The 2006 has an engine imobiliser in the ignition and micro chip in the key fob. There could be a low battery in your key fob. Take your spare key or your good key and hold it right beside the push button when cranking. See if that allows the engine to fire and remain on. If so replace the battery inside the fob. You can do this by pulling the glove box (silver) key from the end of the fob and inserting the tip of the key into its slot sideways to pop open the **** shell housing and expose the internal battery.
Post back with results.

Jan 08, 2010 | 2006 Lexus Gs 300

3 Answers

96 maxima is hard to start and dies often


when my 96 nissan maxima gets hot it will cut out and almost like buck like it dose not get enough gas. i have chaged all filters and plugs and coil pack

Apr 27, 2009 | 1996 Nissan Maxima

3 Answers

I have a 96 ponitac sunfire 2.4 engine i can drive


pcv valve which is only 5 dollars at auto parts store, and oxygen sensor which is 20 dollars. I had the same problem and then i instaled them and it ran like new, for under 50$$

Mar 02, 2009 | 1996 Pontiac Sunfire

Not finding what you are looking for?
Cars & Trucks Logo

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

60867 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

164 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...