Question about 1993 Saturn SL2

1 Answer

When in gear at stop light etc, acting like it's going to stall out, when stopping and putting from drive to park it races, have replaced 3 sensors, same problem, could it be the coil packs?

Posted by on

  • 3 more comments 
  • bran888 Jul 29, 2008

    i have the same problem, only i put mine in nuetral and give it some gas then it will go.

  • Anonymous Jul 31, 2008

    i got the same problem with my saturn it will take off on its own without giving it gas, and when i put it in park or neutral it revs up to 3500 rpms then when i put it in gear it will want to stall and when i give it gas it dies, PLEASE PLEASES help me figure this out, 10 miles is a long walk to work

  • rhtfe Oct 06, 2008

    I have the same problem on my 97 SC2 5speed. When stopped at a stop light in First gear it stumbes and acts like its going to stall out, but once i move it to neutral it stops stalling and acts fine. This is an intermittent issue ... any thoughts?

    Thank you.

  • evan_casey Nov 14, 2008

    My car does exactly the same thing, only mine's a '95. Have you tried replacing the MAP sensor? I had a couple people tell me that could be the problem

  • KatheeLynn69 Nov 26, 2008

    i have a 94 SL2 and at first it would rev to high rpms and act like it was struggling to stay running at stop lights, but now a few weeks later without finding the problem it shuts down everytime i stop the car,so now I've just stopped driving it......we have found and fixed a vacuum leak changed the fuel filter and going change the fuel pump....what else might it be? can anyone give me sugestions???? thanks KatheeLynn69@aol.com

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Hey i had a problem that sounded like the one some might have. Here it was a short in my tail light that would make the car die if i had the break pressed while in drive. then i fixed it but also found that there is this male type connector in the trunk on the drivers side that if it grounded somehow to the chassie it would produce the same thing. i have a 93 sl2 not sure why this would cause the problem or even what it is. Hope this helps so check for any shorts ///

Posted on Nov 14, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My van won't start after driving a short distance, it will start again after 3 to 5 minutes but then will act like it's going to stall while I'm driving. What's wrong?


Hi Greg, I'm AL the owner of Big As Auto Repair in St Charles Mo

Greg, I read your complete message, but nowhere did I see that you replaced the Cam Sensor. The EGR will cause it to stall at stops but usually will not prevent it from restarting. I would try replacing the Cam Sensor before anything else. If you should need further assistance go to my website by clicking here: Auto Repair

Mar 19, 2015 | 1997 Dodge Caravan

2 Answers

Why does my 1995 Volvo transmission stop going into gear after it's hot?


1) How's your fluid level?

2) When did you last replace your filter?

3) When it shifted, did it go trough all the gears as you accelerate or did it just stay on one gear and never shifted?

4) How's reverse, does it slip out too after 2 - 3 min?

5) As you first able to shift into gear, you can drive it for 2 to 3 mintues and it just suddenly slip out of gear?


.... could be a number of different things. Maybe even burnt out clutche(s) inside your transmission

Sep 06, 2014 | 1995 Volvo 960

1 Answer

My truck shifts real hard and now shakes when I stop


If you have been driving the vehicle even 10 miles or more
with a transmission that acts up,slips,bangs,etc,& have not
changed the fluid every 3 years since it was new,then yes, it
most likely has to be rebuilt,could have been prevented

Jun 23, 2013 | 2003 Lincoln Navigator

1 Answer

I have an automatic 1998 Isuzu Rodeo V6 3.2L. When I put it in park the rpm's jump up to 2000, 2500 and go back when I put it in gear and at stop signs, red lights etc. It acts like I am pushing on the...


generaly clean the throttle body.carry out a full ecu relearn.disconect the battery and leave it for 10 mins.check the throtle cable etc.check that the charge rate dose not exceed 15 vlts, they are known to do this.

Dec 02, 2012 | Cars & Trucks

1 Answer

93 Lumina 6cyl 3.1 engine shaking @ overdrive gear


check your camshaft and crankshaft sensors. When defective, it may cause stalls, misfires, loss of power. Also have check the engine for vacuum leaks. Hopefully this helps!!

Apr 14, 2010 | 1993 Chevrolet Lumina

2 Answers

Idled high, replace IAC and PCV, now idles low and stalls


May be a defective IAC, or bad connection, or improperly installed, as in lost little "O" ring when putting it on. I would also be looking at TP sensor, which I would have tested in the first place. Have you tried cycling your key to retrieve problem codes yourself? ( turn key to on,(not start) then off, then on, then off, then on again, and leave on, and count flashes of check engine light. It will flash quick, then pause, then flash again. For example: 3 flashes, pause, then 3 more is code 33. 2 flashes, pause, 5 more, is code 25. When you get 5, pause 5 more, that code 55, which means end of message. Write them down, and get back to us with what you have if any.

Nov 18, 2009 | 1989 Dodge Shadow

1 Answer

Idled high, replace IAC and PCV, now idles low and stalls


On modern day cars the parts that get fitted need to be adapted to the ECM using a decent diagnostic machine. I bet that this was not done and the car is now suffering as a result.
Something to try is resetting the ECU, simply disconnect battery for 10 minutes, reconnect, then start car from cold *without touching gas pedal* and leave idling until the rad fan comes on (this resets all the base idle settings) then take it for a drive - hopefully will solve the problem

Nov 18, 2009 | 1990 Dodge Caravan

2 Answers

1993 Ford Escort 1.9L Auto Randomly Stalls


I don't have the solution, but I have the same exact problem on my 1991 Escort 1.9L with auto with 120K miles. I replaced the IAC with no difference. In fact I unplugged it, and still had the random stalling. Also disconnected the EGR vacuum line...still stalled randomly. After it stalls it always starts right back up again. Sometimes it will act as if it's going to stall, but comes back to normal idle. Park or Drive makes no difference. Acceleration and all normal driving is fine. The next thing I was going to try is hooking up a timing light and watch to see if the timing light stops flashing as it's stalling, and/or hooking up a fuel pressure gauge somehow, to the fuel rail, to see if the pressure drops when stalling....to figure out if its ignition or fuel related.

Oct 20, 2009 | 1993 Ford Escort 4 Door

1 Answer

After driving for 15 minutes truck stalls,restarts no problem ,but trans races and stalls again. if it sits idle for 2-3 days runs again no problem ,until the 15 minute drive again .the 15 minute drive...


put a OBD II code reader on it see if it has stored any codes if not replace the TPS sensor and the MAF sensor do the replacements at different times so you don't buy one or the other for nothing

Jul 03, 2009 | 1993 Ford Ranger SuperCab

1 Answer

Engine stalls at stop lights and stop signs


sounds like the torque converter lock up might not be disengaging. You might also want to check for engine vacuum leaks. Does engine idle smoothly when in park or nuetral ? if the idle is good I would suspect torque converter problem.

Aug 16, 2008 | 1993 Ford Bronco

Not finding what you are looking for?
1993 Saturn SL2 Logo

Related Topics:

154 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

63661 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21984 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...