Question about 1997 Chevrolet S-10 Pickup

1 Answer

Bad O2 sensor

I have A 97 Chevy S10 with a 150000 on it a few weeks ago I was driving to work and the check engine light came on I had it checked it was a bad O2 sensor I replaced it and it did not help the problem I cleaned the egr cleaned al the grounds new fuel pump new cap wires and drained the gas tank and feul filter and also my rotor cap makes a clicking sound

Posted by on

  • Anonymous Dec 02, 2008

    1997 s10 7 codes cleared replaced 2 o2 sensors tps sensors truck ran ok for 20 minutes then shut off started up then no power

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I'm not sure about the rotor cap, but if it is telling you you still have a bad O2 there are about three on it. One up front and two back further by the catalitic converter..

Posted on Aug 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What are codes P0133 & P1134, for a 2005 Buick Lacrosse 3.8L V6 with 94,000 miles.


i have replaced an O2 sensor and had similar failure after 1500 miles.
I removed it, chkd it, reinstalled it and it ran fine.
P0133 is related to slow response of O2 sensor. P1134 is mfg specific so google that for ur car.

Aug 11, 2014 | Cars & Trucks

1 Answer

I have a 02 3.4 chevy impala. my check engine light is on for a bank one o2 sensor. iv replaced the upper and lower o2 sensors twice this week and code is still coming up.also when im driving it feels like...


i would suggest checking fuel pressure and fuel filter could have little dirt or something clogging fuel and engine light will stay on due to too rich or too lean of fuel/air mixture

Oct 08, 2013 | Cars & Trucks

1 Answer

I just got an oil change less than 3 weeks ago and today my engine starts knocking and my oil light is on, could that be a bad O2 sensor?


No Bad o2 But Check oil Level. How old Was The oil That Came Out? Fresh oil Will Clean Out Sludge Deposits If The oil Was'nt Changed In A Timely Manor It could Have caused leaks. also Check Drain Plug Gasket for leaks And Make Sure Oil Filter Is Correct And Tight.

Apr 15, 2013 | 1997 Buick LeSabre

4 Answers

My 2001 XJ8L has had the amber "check engine"


Have you tried to get any codes off the check engine light?

Mar 06, 2011 | 2001 Jaguar XJ8

1 Answer

Just replaced O2 sensor a few weeks ago and check engine light has returned for yet a second time. Code is now reading P4020 Catalyst efficency below threshold.


Sounds like the converter is bad. There is also a service bulletin from Toyota for this problem. They have released new computers to be installed that are less strict on how well the converter is working.

Nov 11, 2010 | 2002 Toyota Sienna

2 Answers

Engine light is on, car wont stay on


check the fuses , you can have a o2 sensor fuse open, also check the wiring because o2s are close to the cats or manifoldss some time they burn and get shorted.., other thing you can do is unplug the o2s and drive it like that and see if it shuts off , if it doesn't so the problem is around that sensor...hope this help..

Aug 03, 2009 | 1999 Dodge Intrepid

1 Answer

90 chevy 5.7L k1500 failed emissions


COULD BE A VACUUM LEAK TAKE PROPANE TORCH AND LEAVE OFF PUT AROUND ALL VACUUM POINT WHERE YOU SUSPECT COULD POSSIBLY LEAK ENGINE SPEEDS UP THAT'S IT WORTH A SHOT BEFORE SPENDING MORE CASH

Nov 24, 2008 | 1990 Chevrolet K1500

2 Answers

Check Engine Light - O2 Sensor - bank 1 running lean


you should have three oxygen sensors on your car, one for each bank of three cylinders; should be towards the Y pipe on each exhaust manifold. Additionally you should have one on the exhaust pipe before the cadilitic converter.

Nov 20, 2008 | 2002 Chevrolet Monte Carlo

1 Answer

O2 sensor problem


I have a 97 gmc sierra .This truck is the same as the chevy ok.Its a 350 5.7 liter 4x4 Z71.I took it to auto zone which was my first mistake.They put it the scanner and said bad O2 sensor.Ok so which one is it i said.They dont know.Well there four (4) O2 sensors in this truck i hope you know that.I had to replace all four of them before i had to take it to a real shop.It seems the fuel pump i replaced a week earlier with an auto zone fuel pump was bad.Ive changed my feul pump 4 times now and have 235000 miles on still running.You need to get your fuel pressure checked.It should be 65 psi to start it and 55 psi to run it.If the pressures are good it could be a different O2 sensor or maybe the mass air flow senor.My last option would be the fuel pressure regulator because it seems to be a waste of time and money.I would get that fuel pressue checked first.Good luck.

Oct 30, 2008 | 1997 Chevrolet K1500

1 Answer

1997 blazer, 4.3 v6


whats the question? here?

May 31, 2008 | 1998 Chevrolet Blazer

Not finding what you are looking for?
1997 Chevrolet S-10 Pickup Logo

269 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...