Question about 1997 Chevrolet K2500

1 Answer

1990 checy 3/4 ton 350TBI---won't start- turns over fine seems like it might not be getting fuel, replaced the fuel filter still nothing. How do I check to see if my sending unit is operating? or other suggestions

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

I just went through this with my 1990 blazer with the 5.7 ltr engine. It was the fuel pump/lines inside the tank. They had rotted with age and though the pump was pushing fuel up the line, it wasn't strong enough to make 9 lbs of pressure that the injectors need. I bought a fuel pump at advance auto parts for $49.00 and the new filter screen for $8.00. It came with all the parts needed to replace the pump and reseal the tank hatch. It took 1 hour to drop the gas tank( try and do this when it's empty or close to it ) , replace the pump, lines and filter screen and then put the tank back up. If you're not automotively inclined, then I'd go to www.craigslist.org and find a cheap mobile mechanic in your area who will come to you. I had shops qouting me $500 to replace the fuel pump and mechanics on craigslist who'd do it for $175 if I bought the parts. I ended up doing it myself but $175 is still a better deal than an auto repair shop's price.

Posted on Jul 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My car wont start engine turns over but doesnt start like ist recieving no gas


Considering it ran fine after pump replacement for awhile then it is probably a fuel issue. Couple things it could be. 1. you could have a ton of sediment in gas tank and it keeps clogging up your pump. 2. you could have blocked fuel filter and or clogged injectors.

Oct 31, 2012 | Chevrolet Cars & Trucks

1 Answer

1990 Jetta stopped suddenly without warning while driving.


Other possibilities are a blown ignition module, bad coil wire, or broken cam sensor (it's attached to the distributor). There are detailed tests for these in the Bentley, but your mechanic ought to be able to troubleshoot.

This is presuming it's really a no-spark failure. Ground or power faults can disable the computer, the fuel pump circuit can be open, etc.

May 21, 2012 | 1990 Volkswagen Jetta

1 Answer

I have a 1990 ford f250 7.3 motor its hard to start no matter cold or hot most of the time it starts right off but dies instantly then i have to crank it like several times to get it to start.when it...


This issue had nothing to do with the glow plugs nor the batteries. This is most likely an issue with the fuel system. I would have to start with the fuel filter and see if that may not be plugged up.

Aug 26, 2011 | 1990 Ford F250

1 Answer

1990 corvette won't start - we changed all the fuses and had the battery checked for charge - Sears said it was good. What should we try next - we get dash lights, etc. when we turn the key, but...


Gm vehicles have had a ton of problems with the antitheft systems. When will turn the starter off when not functioning properly. http://vatspasslockpasskeysecurityhelp.yolasite.com/

Aug 04, 2011 | 1990 Chevrolet Corvette

1 Answer

1990 Ranger 2.9 runs pretty well until you shut it off and try to start it back. Smells like it is not getting fuel(real lean). Fuel pump and filter are new. What holds pressure to the fuel rail when off?...


nothing really except sometimes your fuel lines. you should have replaced the fuel filter when you replaced the pump so your pump lasts a lil longer. a clogged filter overloads the pump

Mar 21, 2010 | 1990 Ford Ranger SuperCab

1 Answer

I have 1989 chevy 3/4 ton truck i just bought for 450 dollers it has a new 350tbi but when i start it it starts to rough run and die then i start it back up it run for 20 secs then it start to rough run...


How did it run before you bought it? You did take your friend and check it out? Check the fuel pressure first and then any pressure regulator,on to fuel filter ,if things are close to what ever a sevice manual says. You do have one of them,right? At least it starts and tries to run,so you should be able to walk through all of the vehicles components one at a time,unless you have zero experience.

Feb 08, 2010 | 1989 Chevrolet C/K 3500

1 Answer

90 lumina 3.1 not starting after filter replacement


Is the filter on correctly? and if runs yes there is a filter inside the tank to. also since the prior owner did nothing to this car could be dirt inthe lines or the tank as well.
check the air filter too.

May 31, 2009 | 1990 Chevrolet Lumina

2 Answers

2001 checy Tahoe wont stay running for more then 10 seconds?


hi i have a 1997 chevy tahoe that starts but won't stay running i have changed fuel pump, fuel filter,relay ,spark plugs, and just changed rotor and dis. cap ready need some help to figure this out please.

Jan 31, 2009 | 2001 Chevrolet Tahoe

1 Answer

Not quite sure if it's a fuel intake problem or not


replace the fuel filter, if that does not work, check all of the vaccum lines going to the intake.
make sure there is no cracks, stiffness or breaks in them.

Nov 04, 2008 | 1990 Geo Prizm

2 Answers

Fuel problem?


Sounds like a clog somewhere.

Jul 21, 2008 | 1990 Ford F150

Not finding what you are looking for?

Open Questions:

0 Answers

my 91 chevy k2500 dies while driving because it keeps blowing the fusible link that carries battery power to the fuse box on the left side of the dash. Problem started a while ago when the truck suddenly died while driving down the road. Still had headlights and dash lights but nothing else. Truck wouldn't even crank over, no radio, heater etc. After troubleshooting, I ended up finding a fusible link that looked to have been repaired at one point. The wire was broken inside the insulation and there a was a **** about 1/2" long in the insulation (small gauge wire). I cut that wire out and used a jumper wire from there to the power block on the firewall to see if that would give me power at the main engine harness connector (which I was lacking before). It did. So I wired in a fuse with some 12 gauge wire using a 15A fuse (wasn't exactly sure what size wire to use and what the fusible link was suppose to be rated since it had been repaired) and hooked it to the power block on the firewall where the other fusible links are. That solved the problem of not having power to anything on the fuse panel on the dash. Drove the truck a few miles and it died again blowing the same fuse. I replaced it and only got about a mile before it did it again. Tried again and got about a 1/4 mile. One more time and only got about 50 yards. Not sure what is causing it. From what I can tell, that fusible link is providing power from the battery through the terminal block on the firewall and from there to a single pin on the main engine harness connector via fusible link to the interior. I have a diagram that shows that power going to the ignition switch and both the "stop/haz" and "acc/batt" fuses. Seems like there is something grounding out or something is breaking down under a load or when getting hot... Please help

Jan 08, 2014 | 1997 Chevrolet K2500

See all 1997 Chevrolet K2500 Questions

1997 Chevrolet K2500 Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...