Question about 2003 Suzuki Vitara

1 Answer

The SUV died in my yard

Came home from work, parked the SUV went out to take off again and the suv won't start. Just a clicking noise. can't open hood nothing works except can open drivers side door and hatch door

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Firstly, it could be a power supply issue. check the voltage on your battery. it should read about 12-13.8 volts and if you can get a cold cranking amps tester that haelps too, it should put out at least 250-300CCA. If it isn;t then yuo have either a bad battery or a bad alternator, not charging the battery sufficiently. more testing.

If these are ok then yuo may have a damaged solenoid or starter motor. the clicking spound is the solenoid, this is like a high current electronically operated switch that pushes the pinion gear on the starter into the large ring gear on your flywheel. at the sdame time as closing the circuit between battery and starter. your best bet is simply to take it to an auto-electrician if this is the problem.

Some causes: i have had bad starter motor experiences myself. recently, i had to ghave my starter replaced because i had allowed the solenoid to become creammed with mud and not washed out properly. this ceases the mechanism up

essentailly, you need to get creative in finding a way to open the hood to check things but if you can't then you can still check the battery voltage through the cigerette lighter socket being careful not to short the terminals as this will cause the annoyance of a fuse blowing. easy to fix, but annoying. good luck!

Posted on Sep 10, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 1989 dodge raider with the 3.0l v6 that dies when I turn on the lights it has a new battery and alternator what could the issue be?


1989 raider / montero wont start need help please ' Mitsubishi 4x4 ...

www.4x4wire.com/forums/showflat.php?Number=1128085
Nov 20, 2008 - I have a 1989 dodge raider / montero the thing wont start. ... If it doeslight off, I'd suspect a fuel pump problem. Regards, Eric W. '89 Dodge Raider -- 3.0L V6, MT, SWB ... It sounds like a bad ECM if it's the V6. ... Also the truck was weird i started it up ran it for a moment and it died first thing i assumed it was ... 89' Gen I Montero rough idle/misfire and stall problems ...
Jun 28, 2011
Really rough idling and shakes ' Mitsubishi 4x4 & SUV Tech ...
Dec 20, 2010
1990 montero fuel pump fuse ' Mitsubishi 4x4 & SUV Tech ...
Jul 15, 2008
Raider won't start in this artic weather ' Mitsubishi 4x4 & SUV ...
Feb 5, 2007
More results from www.4x4wire.com

1989 Dodge Raider - Fixya

www.fixya.com/cars/t1360572-1989_dodge_raider
Jan 28, 2009 - 1989 Dodge Raider A few weeks ago, I was driving home when all of a ... I'll go back an hour or so later and it will start, warm up then die. ... I have replaced the plugs, wires, distributor, brain, basically .... If you are getting power to anything else (such as the interior light) .... 1989 Dodge Raider 3.0 L V6 EFI.

Dec 28, 2015 | Dodge Cars & Trucks

1 Answer

Won t start


run the fault codes and look for faulty cam/ crank position sensor as this is indicated by the backfire/hard start and lower idle RPM. Check that battery terminals are clean and tight..

Sep 22, 2013 | Pontiac Montana Cars & Trucks

1 Answer

Starting issue


Possible IAC valve or crank sensor. have your vehicle's computer scanned at autozone, its free!! Then post the code on fixya.com, this is the only way we can find the problem. Hopefully this helps

Mar 29, 2010 | 2004 Chevrolet TrailBlazer

1 Answer

Drove home - 45 highway miles, turned suv off. 10


make sure proper grade of oil was fitted check with toyota see if special grade oil is recommended

Jan 07, 2010 | 2003 Toyota Highlander

1 Answer

2000 yukon denali will not start


I had problems with my remote button, with battery fully charged turn on key for ten second, turn key off un-hook positve side of battery, re conect turn key to on postion then try to start, it worked for me I have a 2003 denali yukon XL, the motor would fire then stop.

Jul 29, 2009 | 2000 GMC Yukon Denali

1 Answer

All electrical going on and off while suv is off.


It's the brain box that is malfunctioning. Get an expert to take a look. It might need to be worked on or replaced.

If you doubt any suggestion as regards this, go for a scan.

Good luck.

May 22, 2009 | 2003 Buick Rendezvous

1 Answer

2004 Jeep Grand Cherokee Laredo makes a noise putting into park


the fan is a clutch fan.get it checked.
without hearing the noise it is hard to see

Apr 22, 2009 | 2004 Jeep Grand Cherokee

2 Answers

SUV WONT START


check you battery and battery cables...sounds like a big voltage drop

Feb 22, 2009 | 2002 Nissan Xterra

Not finding what you are looking for?
2003 Suzuki Vitara Logo

86 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

63990 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...