Question about 2002 Dodge Neon

1 Answer

Running rough, feels like looses power when accelerating. Already changed plugs and wires

Posted by on

  • irishitalian Jan 21, 2009

    engine idles rough also car bogs on acceleration

×

1 Answer

Same thing just happened to me. I get up to 4th gear and the thing loses power - just won't go without really pushing it.

Posted on Aug 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2003 f-150 running verry rough won't accelerate replaced fuel pump and filter New coil pack


Did you check your plugs? When you replace them, change the wire plugs too.

Feb 04, 2016 | Cars & Trucks

3 Answers

Why would engine run rough after tunr up?


Are plug wires connected in the right firing order to the plugs? Also are the spark plugs gap correct? Was vehicle running rough before tune up or only after?

Jul 05, 2014 | 1998 Ford Escort

1 Answer

Running rough and jerking on acceleration


Depending on what kind of truck you have it may be the distributer. I have a 72 ford pk and same problem. Changed points and same problem. Changed distributer and fixed problem.

Jun 19, 2012 | Cars & Trucks

1 Answer

91 Explorer 6cyl XLT standard is super hard to start, the engine sounds muffled when starting and while running, quickly overheated once it was running, looses power when pressing accelerator.


Could be a clogged catalytic converter. It could also be a bad head gasket allowing some coolant to enter the cylinders. Check for milky grey oil.

Dec 18, 2011 | 1991 Ford Explorer

1 Answer

My 96 kia sportage is running rough on idle, already changed spark plugs has new timing belt but cant geto smooth out


on the coil packs that sit on top of plugs #2 and #4 cylinders are attached plug wires.separate coil from wire look inside wires there are two (one in each) little and loose cylinder shaped pieces of metal ( looks and is about the size of a valve stem core) that carry your spark make sure they are intact and did not fall out.

Sep 09, 2010 | 1996 Kia Sportage

1 Answer

2000 blazer runs rough and surges


Faulty idle air control valve or timing chain has jumped. So after you changed plugs it got worse? Better double check to see if the wires are right. You should also look for more damaged loose or cracked vacuum lines. Wiggle them all around with the engine running.

Jun 21, 2009 | 2001 Chevrolet Blazer

1 Answer

Emissions light on


I wouldn't rule out plugs or wires bad again. May be time for a change.

Apr 15, 2009 | 2001 Ford Taurus

1 Answer

Running "rough"


I had the same issue with my venture. It turned out to be the number 5 plug wire, backside of engine ended up breaking out of the plug carrier and burning in half on the manifold. Your best bet is to trace all the wires to start off with and change the plugs. If that doesn't help, it may be internal. Good luck

May 15, 2008 | 2001 Chevrolet Venture

Not finding what you are looking for?
2002 Dodge Neon Logo

Related Topics:

258 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...