Question about Toyota Camry

1 Answer

1999 Toyota Camry V-6. No Start. Checked coil packs, enstalled new plugs. Checked timing, mass air flow, cam sensor and crank sensor, fuel injectors, ignitor. everything seems to work but will not start. If I do get it to start 15 seconds at best. It will back fire which leads me back to timing. Put timing light on it and even checked timing marks on crank and cams Any suggestion. Thank You

Posted by on

  • ToyotaPhil Jan 25, 2009

    1992 Camry V6 XLE Starts for about 10-15 seconds and then dies. Fuel pump has been replaced. Could this be the circuit opening relay because I can hear it clicking if I keep giving it more gas?

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 84 Answers

When starting push gas, if runs
idle valve (IAC) stuck,replace or disassemble and clean the burrs
has two time this promblem

Posted on Mar 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My vauxhall zafira 2.0 tdi will not start when cold,have changed battery and glow plugs but still same problem. have been told to disconnect coolant temperature sensor but do not know where to locate?


My Vauxhall (Opel) Zafira 2004 1.8 liter 16V Petrol Auto
had COLD START problem; cold engine does not start no
matter what! I have changed the following parts, one after
another:
1. New Coil pack
2. New Spark plugs
3. New Battery
4. New Mass Air flow oxygen meter
5. Air filter
6. Oil filter
7. Engine oil
8. Fuel filter
9. Premium Petrol
10. Engine coolent water sensor
Still the same problem. Then changed 'Crank sensor'. And
now the car starts fine without any issue!!
Faizur Rahman <captfaiz@yahoo.com>

Nov 11, 2012 | Cars & Trucks

3 Answers

My 1990 toyota camry has been running poor. It seems to be missing and jumps and jerks. Off the line it just crawls until it hits 3,000 RPM then it runs fine. I have to downshift on any hill because it...


The mass air flow often goes bad on them. Did you have the vehicle scanned. Try unplugging the mass air flow and driving it. It is built into the air intake hose. If that does not change things, check the fuel pressure, and the throttle position sensor.

Hope this helped

Nov 21, 2009 | 1990 Toyota Camry

1 Answer

98 dodge intrepid 3.2 engine. engine serges at 3,000 rpm and will not get above 3,000 rpm. also will not start with cam sensor plugged in. new sensor


first symptom sounds like mass air flow sensor,cam angle sensor may be moving the timing out of startble range,,check timing belt for condition and verify timing marks on cams and crank at top dead center,may have jumped a tooth,

Oct 05, 2009 | 1999 Dodge Intrepid

1 Answer

1994 Toyota Camry Won't start.


you should check 3 things. AIr, Fuel, and "spark"
your cars could have many problems. Ignition module, fuel injectors, Mass Airflow Sensor.
You should check into all of these 3 things.
a crank-no start could be many things.
it could even be a cam positions sensors resistance going up when the engine heats up. Cracnk- no start means testing. n like i said
The motor is getting Air, There is Fuel being put into the cylinders, and the Spark plugs are firing.

Mar 17, 2009 | 1994 Toyota Camry

2 Answers

1999 pontiac grand prix . will not run


If you unplug the MAF sensor it should run using the default mapping. I'm having the same problem, but I want to figure out why it won't run with the sensor connected.

Jul 03, 2008 | 1999 Pontiac Grand Prix

4 Answers

Won't start


Is this a 4 cyl. or a 6 ?
It's possable the EGR valve is stuck wide open also causing it to dump fuel. Are the plugs wet after cranking for a while?
Talk to ya soon, Dan

May 25, 2008 | 1994 Toyota Camry

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

352 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

74192 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22082 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7194 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...