Question about 1986 Oldsmobile Delta 88

1 Answer

Brake Problem I just bought this car...it has been sitting for almost 2 years. It seems to run GREAT...the only immediate problem I have found are the brakes. Initially, the brake light was not on...now it is. But since the begining, I noticed that it seemed as if the brakes were somewhat locked up!! For instance, when I would let off of the gas to come to a stop, i didn't really even have to use the brake... I don't have the money to take it to a shop, and I want to begin troubleshooting...but where should I begin? I have changed brake pads before, but I still am not sure as what to look for first. Perhaps the calpiers are froze-up? Or is there a 'bigger' problem I should look at first? (Master cylinder?? etc.) My email is steven.zambron@yahoo.com

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 321 Answers

If it's going to be daily transportation and you NEED reliability,i would rebuild the entire brake system.New master cylinder,and front calipers,and rear wheel cylinders if drum brakes,and new pads and shoes all the way around.Do it once,be done with it for good.The brake rotors are probably heavily rusted from sitting two years.Replace them.Rubber seals also dry out from just sitting.That's why i recommend rebuilding the system correctly from the start,that way you're not messing with or troubleshooting the brakes every or every other weekend.

Posted on Jul 19, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Runs good for couple hours the quits.starts immediately then quits.let it sit a day runs great then quits.it always starts immediately


Year/make/model/engine size??? Important info for any assistance. Sounds as if an electrical component is heating up and causing this issue. Possible ignition coil/ignition module/crank sensor. It could be a lot of other things causing this problem, however, these are the most common sources to cause this issue

Oct 10, 2015 | Cars & Trucks

1 Answer

1986 Ford Ranger w/39,000 actual miles stalls when going around corners, changing lanes but normally restarts immediately. Otherwise runs great, but wouldn't restart yesterday after sitting for a


at that year, it could have moisture in the line or fuel filter. back then fuel filters where small and see thru usually in the engine compartment.

Jul 22, 2012 | Ford Cars & Trucks

1 Answer

My 1990 hyundai excel has been sitting for 3 years. It started fine, but the hydrolic clutch pedal seems to be stuck in the up position. I don't recall having problems with the clutch when I was...


Add brake fluid to the reservoir and try pumping the pedal by hand it may get stuck to the floor, then look for any leaks in the line to the tranny, if it is stuck up try starting it in gear and shut it off immediately! Cuz it will try and take off be sure to block the wheels and set the brake, this may help free the slave cylinder from the shaft please rate

Jul 31, 2011 | Hyundai Excel Cars & Trucks

1 Answer

Clutch seems to be seized because bike has been sitting for years


Is the clutch lever sized or is the plates sized?
Usually the plates inside sizes, all you have to do is select gear 2 or 3 without starting the bike's engine,operate the clutch lever and push the bike,it should release, the rear wheel should now rotate freely with clutch lever in operation and in gear.
Hope this helps!

Nov 28, 2009 | Yamaha YZ 250 Motorcycles

1 Answer

Car wont star anti-theft light keep commin on


2000 FORD TAURUS. JUST BOUGHT WAS RUNNING GREAT. IT HAS BEEN SITTING FOR ABOUT 4 YEARS STRAIGT. HOW DO I GET KEY RE-CODED? JUST REPLACED CATAY.CONV. NOW THIS PROBLEM

Jun 02, 2009 | 1997 Honda Accord

1 Answer

The 2000 mountianeer starts and runs fine but shuts off


CHECK THE COLD START ENRICHMENT VALVE AND OR THE IDLE CONTROL VALVE. I AM ASSUMING THAT YOUR VEHICLE IS FUEL INJECTED. ONE OF THOSE HAVE GONE BAD.

Jan 24, 2009 | 2000 Mercury Mountaineer

3 Answers

1997 dodge avenger engine problems V6 2.5


Check your EGR valve. It may be stuck open. I had a similar problem 2 years ago on my 97 avenger w/ 2.5L V6. Engine idled rough and would die when I stopped at a stop sign unless I feathered the gas pedal as I coasted to a stop. Replaced EGR valve, problem solved.

Jan 17, 2009 | 1997 Dodge Avenger

Not finding what you are looking for?
Cars & Trucks Logo

126 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...