Question about 1990 Chevrolet Camaro

1 Answer

Transmission when cranking first thing in the morning. when you put in in reverse it just sits and sometimes when you give it some gas it will grab and then back up same as in drive. could it be the linkage? i have replaced the filter and had a repair shop put it on a transmission machine to replace all the old fluid and now it seems to be worse than before what can i do to fix that problem?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 26 Answers

On the passenger side of the tranny is a vac modulator try replacing it. it will cause it to do this.

Posted on Jan 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1998 Mazda Millenia.I've had the car about 2 months and everytime i crank up in the morning or after being parked about 9-10 hours white looking smoke comes out the tailpipe.My check engine light...


The white smoke in the morning is condensation heat attracts moisture, Now for a 1998 you may have to add Mazda transmission fluid in it. That siren noise is the underdrive of the transmission they have alot of issue Make sure underneath the transmission area there is no red fluid other than that you will be needing a transmission ,

Apr 21, 2011 | 1998 Mazda 626

1 Answer

96 Chevy Cavalier, auto, 2.2ltr When I shift from park into reverse it doesn't grab until I give it some gas and then 'clunks' into gear; and when I try to put it into drive it does the same thing. It is...


sounds like it might be a little low on trans fluid,and if i remember correctly these vehicles dont have a trans dipstick to check fluid level,but i could be wrong..if it does check it with the car running on a level surface and in park,hope this helps

Nov 12, 2010 | 1997 Chevrolet Cavalier

1 Answer

When im driving my 02 tahoe, sometimes when i stop and make a left turn pressing the accelerator to give it gas to speed up to like 5 or 10 miles per hr and when i let the gas goes reaching to that speed....


slip and grab in your transmission put some lucas transmission slip-stop in and run in park position at 3000 rpms for 5 min then change into reverse and see what happens

Jul 29, 2010 | Chevrolet Tahoe Cars & Trucks

2 Answers

Inconsistent 2003 Dodge Stratus Transmission Issues


Just check the transmission oil levels first, if they are low this will stop it from engaging into gear.

Feb 04, 2010 | 2003 Dodge Stratus

1 Answer

2004 silverado, duramax and allison transmission, upon cranking got note on speedometer view that cannot engage in gear. would not go in reverse.....put in drive rolled forward and then went into reverse....


What kinda batteries do you got? Are the cables any good? Sounds to me like a power/ground issuse. Either that or you have to small of batteries to crank over a high compession enigne when it's cold, with the glow plugs, and heater grid pulling all of the power from the batteries.
And check the trans fluid level for your problem with the trans.
And you're gonna need to be a little more specific on the thunping noise.

Dec 09, 2009 | 2004 Chevrolet Silverado 2500HD

2 Answers

Doesn't always start , has problems in the morning, after it sits for awhile. somestimes it starts alright sometimes it doesn't,acts like it may be out of gas, cranks over and acts like it wants to start,...


May have a fuel pump going bad or a fuel filter clogged. When the fuel pumps go bad they tend to not hold fuel in the line and it leaks back to the tank. That could be causing your hard start sometimes and not others.

Oct 10, 2009 | 1997 Pontiac Sunfire

3 Answers

2001 jeep grand cherokee 2 wheel drive no reverse


If perf. is O K in forward, will have to be emergency brake problems,adjustersor or cable mabe

Jan 02, 2009 | 1991 Chevrolet S-10 Blazer

1 Answer

Jumps when I pull away first thing in the morning, no problem when warm (1999 Jetta GL)


the same thing happend to my 1996 jetta trek. when u put it in reverse to start off anywhere its perfectly fine. but when u put it into drive it stalls for a few seconds than jumps.
The transmission is going to go out on you anyday.
mine blew on me about a month when this started happening to me.
i was driving and the car just randomly went into neutral, tried all the gears and all i had was reverse.
BLOWN!

took it to 2 different places to get it fixed, 1st place asked $3500, 2nd place asked $2500.
too much money so we had a family friend put a rebuilt tranny in for $1600.

Nov 03, 2008 | 1996 Volkswagen Jetta

Not finding what you are looking for?
1990 Chevrolet Camaro Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...