Question about 1996 Mercedes-Benz C-Class

1 Answer

C220 - 1996

I bought a C220 - 1996 and I am facing some problems with my car:
1 - In the morning is not easy to start the car and the engine goes down and I have to accelerate to avoid it
2 - Some times when a start the car there is a noise form the sunroof command button. That noise stops by it self after 4-5 minutes;
3 - I don’t have the manual and I need to replace batteries of my remote;
4 - Before the remote was not working properly and even to open the door was a problem.

Please help.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

1. Mechanic needs to check cold start relay
2. Check switch, it is probably stuck
3. Panasonic CR 2032 3V
4. Mechanic needs to check IR security system

Posted on Jul 28, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

At time of starting when car (chevrolet optra LS 2005) temperature is cool RPM goes down and car is off


cars have 2 things.
engine coolant temp
and HVAC temp
can tell what you are talking.

car is off state?
do you mean the engine stalls.?
try to talk in terms of what system in car is failing
HVAC (heating or cooling of passengers)
engine issues, stalls , misfire, lost power.
transmission issues, wont shift or slips or messes up some of 100 ways. as a/t love to do.?


Jun 11, 2014 | 2007 Chevrolet Optra 1.6

1 Answer

1999 mercury couger engine loops at idle


i had the same problem on my car. it was the idle air control motor (stepper motor) it helps control the amount of air flow. when it goes bad it sticks making the idle go up and down. its an easy fix.you will bolted to the intake manifold . it took me 10 min and 1 wrench

Jan 12, 2014 | Mercury Cougar Cars & Trucks

1 Answer

Overheating


Could be a number of things,
Do you have heat from the heaters?
Do you have any coolant loss?
If so i'd get a Cylinder leakage test done (compression test) as it could be a head gasket problem.
Owen.

Jan 11, 2013 | Cars & Trucks

1 Answer

I have a c200 cdi mercedes from 2006 (w203 model). in cold mornings (0-2 C) don't want to start. everything works, lights are on, dash is on but engine don't start. i have replaced the battery


Hi
It sounds to me like it could be a glow plug fault !
The glow plugs heat the diesel before it combusts. An easy way to diagnose this is check your exhaust after cranking on a cold morning if you have thick white smoke then you've probably got a glow plug down on 1 of your cylinders or maybe more
Hope this helps Nick

Nov 18, 2017 | Mercedes-Benz C-Class Cars & Trucks

1 Answer

Car engine going off while first start in the morning


It sounds like your automatic choke is not working You need to hold the ecalerator down just a little bit until the motor warms up. Cheers

Jun 20, 2012 | Toyota Cars & Trucks

2 Answers

Ford focus won't turn over ,was fine this morning parked up now won't start getting whinning sound from side of engine


If the temperature is low, then the engine might have struck up. You need to give heat and then try starting. If you still face the problem, then open the front and check if any wires have been cut off or else call or an mechanic to solve the problem,

Thanks

Apr 01, 2012 | Ford Focus Cars & Trucks

1 Answer

Starts but dies when engine warms up


Ok, i have a 93 mitsubishi eclipse, so same motor as mine. I had a similar problem after replacing my battery. In removing the intake tube, it split for about 3 inches on the underside of the tube, allowing air to bypass the air intake sensor ( the place where the tube connects to the filter housing). Check this and let me know :)

Apr 30, 2009 | 1992 Eagle Talon

Not finding what you are looking for?
1996 Mercedes-Benz C-Class Logo

357 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

yadayada
yadayada

Level 3 Expert

79865 Answers

Joseph Prosser

Level 3 Expert

772 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...