Question about 1993 Mitsubishi 3000GT

1 Answer

With the ignition on and car running I loose power.

The guages will quit working along with the power windows and turn signals.  When I am driving the car the dash lights will come on like when you turn the key on and everything works..then quits again.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,066 Answers

Sounds like a failing main wiring harness.

Posted on Dec 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On a 89 f150 all of a sudden I had no power to guages, turn sig, dash, replaced starte switch and still nothing. I'm lost need help to locate problem.


look in the positive battery connection. it splits in two, one goes directly to the starter and the other goes to the instruments and ignition, for the description of the problem. I'd say that's where the problem is.

Dec 26, 2014 | 1989 Ford F 150

2 Answers

1997 f150 will not crank - oil pressure light is on with fresh oil in the truck


take the distributor cap off and see if the rotor is spinning while cranking. your oil pump is driven by the distributor which is spun by a gear on the camshaft. sometimes the gears get shaved off the distributor shaft. if it's not spinning then either the drive gear is shaved or the timing chain has snapped.

Feb 27, 2013 | Cars & Trucks

1 Answer

With car running i loose my power windows,locks, a.c., radio ,and gas gage


sounds like an ignition switch issue with car running check your fuses that control these circuits if they are dead check power coming out of the ignition side of the switch if you have power when the key is in the on position and loose it after it's started this may be the issue

Jun 28, 2012 | 1999 Cadillac Seville

1 Answer

I turned key and car did nothing. second attempt car started. I started driving and realized that all the "dummy lights" were lit up. the power to the radio faded in and out and then the int....


I would suspect a faulty ignition switch causing all the electrical issues. There are 3 distinct circuits running from the ignition switch, it sounds like one of them are faulty and not allowing power to certain circuits. Best to have it diagnosed at a reliable auto shop.

Apr 09, 2011 | 2000 Buick LeSabre

1 Answer

I have a 99 chevrolet blazer LS it was running fine the drivers side window rolled down but rolled back up extremely slow when i shut it off it wouldnt re-start the battery was dead so i jumped it and it...


that is one grimlin that is pretty well cornered your ignition switch is command central for all you listed that was not working properly inside the barrel of your ignition are the contact pins that supplies power to everything that requires power that why when you turn ignition off everything shut down so your battery does not die out .i would say that there is a 99% chance that your ignition is shot.

Apr 08, 2011 | 1999 Chevrolet Blazer

1 Answer

99 Dodge Ram 1500 quits running. Guages go to


Sounds like a bad ignition switch.

Jul 25, 2010 | 1999 Dodge Ram

1 Answer

Truck turns over alot then starts and runs fine


Faulty idle control system/ sensor. Vacuum leaks, loose or damaged wires in the ignition system. Check all wires and connections.

Jun 08, 2009 | 1994 GMC Sierra

1 Answer

Ga sguage pulsing.


You have a loose instrument cluster ground somewhere in the system, that is the only thing that can cause these kinds of weird problems.

Oct 08, 2008 | 1997 Chevrolet S-10 Pickup

Not finding what you are looking for?
1993 Mitsubishi 3000GT Logo

Related Topics:

121 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

63990 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...