Question about 1995 Ford Bronco

1 Answer

Runs fine for a few

I just put tons of money in my 95 351 new pump and fuel filter and plugs cap roter wires and its running like pooh i had the pump tested is was fine im driving and starts to bog down losing power like running out of gas tank is full with the gas to the floor it wont go passed 2 grand then she stalls out wait a few mins then she starts rite back up again does the thing i dont no what this could be i checked all the lines and they are feel plzplz help me cant fix it help

Posted by on

  • Anonymous Oct 31, 2008

    while im driving alone it just quit like its out of gas and a few later it starts rite up

×

1 Answer

It might be the fuel pressure regulator, i have a similar problem with my 95 302. but mine just dies but starts right back up. i was told fuel may be evaporating out of the fuel lines, when it doesnt start the first try i pump the gas pedal 2-3 times and it starts right up.

Posted on Aug 02, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

What would cause 93 chevy c1500 rough idle smells of excess gas at exhaust


Does the truck seem fine when you first start it & then acts up when it reaches operating temp?
That would lead me to look at my oxygen sensor, a bad sensor can cause the truck to run "rich" which would explain the fuel smell in the exhaust.

Jun 28, 2014 | 1993 Chevrolet K1500

1 Answer

1991 olds cutlass supreme


Could be fuel pump. Check for fluctuating pressure.

Sep 02, 2012 | Oldsmobile Cutlass Supreme Cars & Trucks

1 Answer

My 2005 dodge is running rough had change the plugs and check the coils


it could be bad distributor cap and roter bad plug wires or even a fuel filter may be clogged. Or fuel pump is getting ready to take a dump on ya!

Sep 13, 2010 | 2005 Dodge Ram 1500

2 Answers

Nissan 300ZX shakes


check items in your fuel lines first, filter, pressure regulator....could be anything running down that line, don't waste your money on a fuel pump until it's the last option

Jun 03, 2009 | 1990 Nissan 300ZX

1 Answer

Rough running 86 4runner after e85 put in!


very likely the fuel injectors are damaged, replace them, the fuel pressure regulator and all rubber fuel lines, also pull the gas tank and replace the short rubber hose at the electric fuel pump, I know this is expensive but even a few miles of running would have wrecked havoc on the rubber components, that rubber debris will flow through the fuel system and will plug the injector's, E85 melts it and skin for that matter.

May 05, 2009 | 1986 Toyota 4Runner

1 Answer

94 chevy 5.7 2 wheel drive


computer wiring could be bad /computer bad..should be spitting codes....tired motor / internal damage ? timing chain/gear set up improper?

Nov 09, 2008 | 1988 Chevrolet K1500

Not finding what you are looking for?
1995 Ford Bronco Logo

367 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...