Question about 2001 Pontiac Aztek

1 Answer

Pontia Aztek 2001 acceleration problem

I am having a problem with my 2001 Aztek. it seems to automatically accelerate, with out my foot touching the pedal. it will gradually accelerate until it gets up around 45. anyone have this problem?

Posted by on

  • Aztekgal Sep 10, 2008

    Hi thanks for the info. My mechanic finally got it to act up. first they replace the idle control motor, but that did not do it. then they figured out it was the throttle position switch (TPS) and when they replaced that, the problem disappeared!

  • Anonymous Mar 27, 2014

    2000 tundra shakes when on the gas. Gets worse around 2000 rpms. Shaking doesn't seem to be in the wheel or the pedals. Seems to clunk when first stepping onto the gas pedal. Anyone have similar problems? suggestions?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Not sure if it'd be the same thing but i used to have a 93 thunderbird & it did the same thing. in park the rpms would be SOOOO high & it'd be loud & then in drive it'd hit 50+ with no gas pedal @ all. i found out it was what is called an "idle control valve" i went to autozone, bought it & replaced it & TA-DA!!! back to normal she went. i'd check into that to see if it could be the same thing. good luck

Posted on Aug 17, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2005 Pontiac aztek and if barely touch the gas it runs good then when I accelerate it bogs down on me


Must have a check engine light on. Need a code 2 go further. 1st place 2start.

Jun 19, 2016 | 2005 Pontiac Aztek

1 Answer

Automaticity passat will not accelerate when foot right down on peddle


Check your automatic transmission fluid. If low, change fluid. Transmission is slipping

Apr 21, 2014 | 2004 Volkswagen Passat 1.9

1 Answer

When i step on accelerator the car makes a very noisy sound. When i take my foot of the accelerator then no noise


I DO NOT KNOW WHAT NOISE IT DOES BUT I SAY THAT WHEN ACCELERATING YOU ARE GIVING HIGH REVS SO THE NOISE YOU MIGHT HAVE IS EITHER ANY BELT (S) ALTERNATOR,AIR CONDITIONING OR POWER STEERING. MIGHT NEED RENEWING THE BELTS OR ARE LOOSE AND NEED TIGHTENING. ALSO THERE IS ANOTHER POSSIBILITY : MIGHT AN ENGINE MOUNTING BROKEN AND ON ACCELERATING THE ENGINE MOVES ON THE MOUNTING AND POSSIBLE TOUCHING SOME METAL PART.

Nov 02, 2013 | 2001 Dodge Grand Caravan

1 Answer

X5 2001 4.4i - rough on low down acceleration at medium pedal press. idle at accelerate is fine, only under acceleration. At higher speeds is fine and no spluttering. When I put in drive, put foot on...


Sounds like lack of preventative maintenance

Spark Plugs every 3 years or 30 to 40,000 miles

You may have ignition coils failing

Clean MAF Sensor

Replace any O2 Sensors over 100,000 miles

Gas filter every 3 years

Sep 30, 2012 | 2001 BMW 5 Series

1 Answer

Accelerating problem with my 1.6 ford escort automatic


I have the same car,,i think your automatic transmission is slipping,(check fluid),or if its a manual transmission,then your clutch is worn out.(replace)

Jan 19, 2009 | 1996 Ford Escort 4 Door

Not finding what you are looking for?
2001 Pontiac Aztek Logo

Related Topics:

438 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...