Question about 2007 Toyota Yaris

1 Answer

The Car is very slow on take offs like I stop at traffic lights and it has no power to move off. I've had to have a camshaft sensor replaced that got the car going again but the engine symbol is still on and there is also a intermitted miss fire while driving

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

This seems to be a misfire problem due to poor A/F ratio, affecting camshaft sensing, try to clean up the intake manifold while engine is idling, use a combination of a good carburator cleaner plus a penetrating agent, remember, spray this combination into the throtle body during engine running state while vacuum is created into the intake system.

I hope your problem is solved this way, regards.

Posted on Jul 26, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 2009 Sedona Kia loose power when I slow down or stop at a corner or traffic light?


It could be the Electronic Stability Control (ESC) is inappropriately kicking in. Another possibility is the throttle position sensor. In any case, have it checked out soon so you don't ending up stopping with traffic behind/across that isn't going to stop!

Oct 06, 2014 | Cars & Trucks

1 Answer

Tcs light flashes and p0340 code


P0340 code means "Something" is wrong in the timing...
from CMP (Camshaft Position sensor) to the crankshaft bolt.

Very first thing, verify connectors are clean and shiny.
clear all codes, even hard codes.

57f2e883-ce32-4061-b04b-ae0890f2c653.gif
612c4a6c-208f-43b8-8645-8318e85f9e48.gif
9e0c3051-1208-49b3-95d5-de3ff545fd3a.gif

Nov 23, 2013 | 2005 Mazda 6

1 Answer

After long drive 30,40 km when car stops on traffic lights loose power 2010 outlader


is your check engine light on it could be anything from fuel to emissions

Aug 01, 2012 | 2010 Mitsubishi Outlander

1 Answer

After driving my car 2006 chevy impala for about 20 miles the dashboard warning light oil pressure low stop engine and the oil warning light appears, but if step on break or slow down it goes out..wha


Verify that the engine has the proper amount of oil. The inertia from accelerating may be moving the oil in the oil pan away from the sensor and causing it to send a signal, then when you slow the oil levels out and the sensor go's off. I've had this happen alot with a taurus that I owned. The simple solution was to top off the oil to the correct level and the sensor did not come on again (until it ran low again, had a leaky oil plug on oil pan).

Jun 08, 2012 | Cars & Trucks

2 Answers

325i BMW, 2003 (Automatic) Fuel Pump/Filter or fuel pressure regulator problem? 3 weeks ago car would stall when shifted in Drive mode. After a couple of retries it would pull away. 500 feet later would...


put your BMW on a diagnostic machine,it will be cheaper in the long run.Believe me I own one and would not have any other car.My 98 just had a problem I parked it the next day it would start but not run,I had it put on a diagnostic machine found out the MAF sensor was bad,got one from the junk yard for $125 and the car runs fine again.

Jul 25, 2009 | 1996 BMW 318

2 Answers

Hyundai Grandeur stops at lights or when moving slow


What guy?... the Hyundai Technician?... Take it back to them and tell them to FIX it! The problem didn't start until you had THEM do a TUNE UP!... You do still have the receipt.. right?

Jun 23, 2009 | 2001 Hyundai XG300

1 Answer

1999 Mazda Protege - Over the last week or so the "emergency brake applied" light has been going on and off intermittantly. Yesterday, when I started up the car there was a plastic burning smell...


I had a similar problem once. I would take it to AutoZone or Advance Auto Parts and get them to scan it for codes, they will usually do it for free. It could be the speed sensor, at least that was the problem for me. Hope this helps.

Dec 10, 2008 | Mazda Protege Cars & Trucks

1 Answer

Sensor "A" Error Messages


I would suggest replacement of your camshaft sensor as the first line of action, of course check your wiring and connectors first by unplugging them and plugging them back in.I will be glad to help you further if this doesn't solve your problem!

Oct 13, 2008 | 2003 Dodge Durango

1 Answer

BMW 320iSE E46 2001


The 3 series suffer badly from camshaft sensors and on your vehicle crankshaft too. Replace all three sensors and your problems are gone. You will notice that the old sensors have a step in them while the new modified ones dont, good luck

Aug 23, 2008 | 1999 BMW 318 ti

Not finding what you are looking for?
2007 Toyota Yaris Logo

Related Topics:

334 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

64286 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...