Question about 1986 Ford Ranger 2WD

1 Answer

1986 ford 2.3

1986 ford ranger 2.3 it has a problem it runs good when it is cold but when it gets warmed up it want run it miss real bad

Posted by on

  • jorgensonrap Jan 09, 2009

    when its worm it dies. then I try to start it and it wont for three trys

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 21,932 Answers

Try changing the condenser

Posted on Dec 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1990 ford ranger 2.9l wont idle and misfires when warm but runs fine when cold


Ok I'm back here is what u need to do to figure this out 1st have u ever replaced the coil pack ?? Plugs and wires if so how many miles do u have on them get back to me with awnsers and we will get to the bottom of this issue thanx Chris

Jun 22, 2014 | 1986 Ford Ranger 2WD

1 Answer

My 88 ford ranger with 2.9 electronic fuel injection is missing real bad and backfiring and dont even have enough power to climb my drive way i adjusted the timing changed fuel pumps and distributer a


Check that you have the plug leads on the distributor cap the right way around and that the cap and rotor are in good condition and secured properly.

Nov 06, 2012 | 1988 Ford Ranger

1 Answer

I have a 1986 ford ranger 2wd runs good untell warmed up then it spits and sputter andback fires have replaced fue filters and pump on the rail


sounds like water getting into cylinders by head or cracked head or cylinders , run compression check .

Mar 22, 2012 | Chrysler Cars & Trucks

2 Answers

86 Ranger 4X4 2.9 fuel inj runs rough when warmed up


1988 ranger 2.9 runs great cold then after a few minutes when warmed up hesitates with intermittent black smoke from the tail pipe until i hit the the throttle then clears and will repeat this behavior...

Jan 26, 2010 | 1986 Ford Ranger 2WD

1 Answer

1986 ford ranger that is running very rich


If you have fuel in your oil, your piston rings are bad. Get a compression tester from your local auto parts store and do a compression test on each piston. If compression drops, then my theory is confirmed. The only repair is rebuilding the engine, or buying a new engine. Replacing rings is very intensive work. It's easier to simply purchase a crate motor.

Jan 02, 2010 | 1986 Ford Ranger 2WD

2 Answers

My 1990 ford ranger when the motor is cold it runs fine but when it warms up it spits and sputters so bad it barley runs


Check the egr valve. Then the O2 sensor(s). When it warms up it goes into "closed loop" using the O2 sensors..if bad it will run lean or rich or hunt for both.

Oct 07, 2009 | 1990 Ford Ranger SuperCab

1 Answer

Vehicle cuts out and even backfires (blacksmoke) when driving down road does not die just does not run smooth. Changed oil twice oil is black, fluids to help clean, pluggs are good, wires are good when it...


If it seems to run better when it's first started (cold) and gets worse as it warms up. You can try disconnecting the coolant temp sensor and jumper the terminals in the connector (wire side) with a paper clip. The coolant temp sensor is either in the intake manifold or the thermostat housing and has a 2 wire connector. Jumping the connector will make the computer think that the engine is hot (warmed up) and will not richen the system. If doing this helps then replace the coolant temp sensor. Hope this is helpful.

Apr 28, 2009 | 1987 Ford Ranger

1 Answer

Have a 86 ford ranger 2.3 l 4cy in mornings


its your fule filter theres 2 of them i the 86 ford ranger you need to change them the location of the fule filters are on google just tipe in fule filter 1986 ford ranger location it should pop up there about 8 dollors a peace easy fix and your truck is like new also get a new battey if you havent k have a good day. oh i know this because i own one had the same problem

Apr 02, 2009 | 1986 Ford Ranger 2WD

1 Answer

My 1988 Ford Ranger misses while warming up.


COOLANT temp sensor

is bad not allowing engine to run enriched fuel

engine heats up enriched fuel is not needed

proof can be found in fault memory

Mar 02, 2009 | 1993 Ford Ranger SuperCab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

156 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...