Question about Mercury Cougar

1 Answer

The backlight on the clock/odmoeter no longer functions. The one for the temp still works properly.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 48 Answers

Bulb may have burnt out. need to take the gauge cluster apart and replace the bulb

Posted on Jul 16, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer and odmoeter don,t work


Either the cable got disconnected somehow behind the dash, the cable broke, or the plastic gears wore out. If yours is digital check fuses.

Apr 24, 2012 | 1991 Mazda Protege

2 Answers

There is no problem only the service engine soon light is on and the car failed the emission test. The diagnostic trouble codes is po43


A code P0430 may mean that one or more of the following has happened:
  • The catalytic converter is no longer functioning properly
  • An oxygen sensor is not reading (functioning) properly
  • There is an exhaust leak
If the Ox sensor has never been replaced I would do that.. Its a lot cheaper than the CAT. The one that needs to be replaced is AFTER the Catalytic Converter.

A good shop should be able to tell if this is your issue or not though.

May 07, 2011 | Infiniti QX56 Cars & Trucks

1 Answer

The steering wheel controls ie. cruise/radio/temp dont work as well as the horn doesnt function


In most cases this problem is caused by the rotating ribbon circuit contact under the steering wheel having a broken filament, the part is known as a clock spring contact, u will need to properly disarm the airbag and remove the steering wheel to access the part. WARNING: Failure to follow factory Airbag disarming protocol can result in an unexpected Airbag deployment and possible serious personnel injury or death.

Nov 19, 2009 | 1998 Lincoln Town Car

2 Answers

How do you set the clock in a 2007 hhr


It will tell you how to do it in the owners manual, just look in the back in the index under clock

Nov 03, 2009 | 2007 Chevrolet HHR Panel LT New Cars

1 Answer

The electronic numbers on my dashboard are not working. such as my clock and mileage. But the thermometer does work. What could the problem be?


There are 3 backlighting bulbs that illuminate the display for your clock,odometer and temp.(outside). Take a towel and cover up the cluster and see if you can barely see the reading. If you can than the display is o.k.. Next you must slide the cluster out and replace the backlighting bulbs. I beleive ther are 2,one amber and one clear for each display. So there would be 6. There is a tool called a combi hook that allows you to grab the cluster and slide it out. Hopefully I have been helpful.

Aug 04, 2009 | 2000 Mercedes-Benz C-Class

1 Answer

1999 VW Beetle outside temp display not working


For general awareness, the outside air temperature sensor is located above the inside mirror.
Try to reset the temperature measurement unit: 1. Switch engine on. 2. Press and hold clock minute (min) and hour (h) buttons simultaneoutly longer than 3 seconds. The display will show new temperature measurement unit. 

Apr 03, 2009 | 2000 Volkswagen Beetle

1 Answer

Radio and cigarette lighter outlet not working on 2003 matrix


There are 2 fuses that powers the radio, cigar lighter, etc.
They are: the 10 amp "GAUGE" and the 15 amp "CIG".
Look under the dash, on the driver side. The "CIG" fuse is the one that you need to replace.
It is in the middle of the fusebox, bottom row. again, a 15 amp fuse.
Please advise if you need additional information.

Hope this helps, and Thanks for choosing FixYa.

Nov 16, 2008 | 2003 Toyota Matrix

1 Answer

VW temperature display


The sensor for the temp display in located in front of the radiator under the hood, it is round and has 2 wires going to it, plug and unplug it a few times and recheck to see if the display works, if not replace the sensor.

Nov 11, 2008 | 2001 Volkswagen Beetle

2 Answers

Lighting


I think you'll find that the switch is the problem. I've seen this problem before and the switch was the trouble 95%of the time.

Oct 21, 2008 | 2003 Chevrolet Impala

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...