Question about 1997 BMW 328

1 Answer

Instrument Cluster BMW E36 328i. While driving the tacho, speedo, gas and temp needles go to zero. After 30 seconds or so, they come back on. When they come back on, i see 4 icons displayed (the yellow transmission icon, the disk pad worn icon, the next icon [circle surrounded by dots, ABS?], and the park break icon), and i hear a small ping from a speaker. After about 3 seconds the icons go off, everything is ok. The stereo is uninterrupted and driving lights stay on etc, car doesnt lose power. The check engine light does not illuminate. I tried the instrument cluster test, and it went ok (hold the odo reset done).

Posted by on

  • 1 more comment 
  • mikeowen Aug 03, 2008

    got the same problem with a 97 e36 328i convertible,warning lights work but non of the gauges and where the mileage display is normally,now shows code 2 anyone knows what it means?

  • HELP28802 Dec 12, 2008

    all of my warning lights are on...anyone know how i can reset em to go off????? will this change my mileage? thanks

  • Anonymous Mar 15, 2014

    when starting the car the cluster goes off after 5 seconds



1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.


    An expert that got 20 achievements.


    An expert that got 10 achievements.

  • BMW Master
  • 77,932 Answers

It sounds like you may have a poor connection in the ignition switch. When this occurs move the key a little and see if problems clear.

Posted on Jul 28, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I've repaired the instrument cluster on my 2004 Silverado bulbs and stepper motors. Is there a particular re-start sequence?

Not too sure what you mean by 're-start sequence', but once you have cluster (IPC) put back together minus lens, you can rotate each needle counter-clockwise to just below lowest mark (zero on tach & speedo) for each gauge. (Note: do not rotate needles while IPC is connected). After initial setting of needles, plug in IPC. Let IPC power up a few seconds. Needles will settle. If adjustment of a needle pointing to lowest mark is needed, just unplug IPC and adjust needle more or less as necessary. Re-plug and check needle position again. If everything looks good, then unplug one last time to install lens, then re-install cluster, bezel, etc. Good luck.

Nov 18, 2016 | Chevrolet Silverado Cars & Trucks

1 Answer

Low fuel warning light where is it ?

Which vehicle??? Normally the low fuel warning light is on the instrument cluster, there should be an icon of a fuel bowser (gas pump) on the instrument panel, either on the speedo or the tacho face plate. When the fuel gets low, this icon will light up.

Feb 03, 2015 | 2010 Kia Forte

2 Answers

How do i fix the tachometer?

you have an in cluster factory engine tachometer (RPM)?
the tacho is meter in the cluster and does not use speedo parts or its cable.
its just a meter that needs power, ground and spark tacho signals
if all 3 are good, the meter is bad. period.
the tacho signal goes to the ignition coil minus lug, and will good, as engine runs. so... wires bad, to tacho or tacho bad.
ever price a new one? or even used? $100 used?
you willing to pay that much for just a factory tacho?

there is NO speedo cable. this old 93 is electronic, (rare on most 93 cars made, toy is advanced)
here is the proof, amazing how books dont lie....
there is a speed sensor.
the tacho and speedo use the same power and ground
leaving just one wire,r-g red-green RPM sig. pin 5 of cluster
an is SPARK primary sig. so if only tacho is dead.
then the tacho is bad, or that pin 5 wire is dead.
got you to just 2 possibles.


Jan 26, 2015 | 1993 Toyota Corolla

1 Answer

2003 Satria, Tacho and Fuel gauge dont work . Fuel gauge comes up now & again low fuel light works. Tacho works now & again. But speedo and temp do work all the time.

It may be that the speedo and temp are mechanical, whereas the tach and fuel are electrical. Check fuse for inst. cluster for clean and tight fitment. Check electrical connection at back of inst. cluster.

Dec 09, 2014 | Cars & Trucks

1 Answer

1997 Saturn SC2 speedometer is stuck at 40mph. Replaced Speed Sensor and is still stuck. I even tapped on the cluster and got the needle back to zero but after driving it got stuck at 35mph. What else...

The mechanism or needle in the actual speedo display is sticking, is the needle hitting the glass? It is likely that you will have to change the instrument cluster.

Mar 15, 2011 | 1997 Saturn SL

1 Answer

Speedometer needle bounce when turn signal is on.

The speedometer sensor - VSS - vehicle speed sensor is a input to the PCM - powertrain control module -engine computer . The signal from the PCM to the instrument cluster for speed info. is sent on a serial data communication network (class 2 ) I would think it would be an instrument cluster problem . Get a used one from a auto salvage yard 15 - 20 bucks an see if it fixes it . If it does ,send your's out an have it repaired .

Nov 07, 2017 | Buick Regal Cars & Trucks

1 Answer

99 lancer,speedo tacho n gauge problem.

probably burnt or cracked circuit board on back of gauge cluster

Jun 21, 2009 | 2002 Mitsubishi Lancer

1 Answer

Gauges gone crazy

Could need new instrument panel cluster but check for corrosion as the instrument panel connector

Aug 11, 2008 | 2000 Ford Windstar

3 Answers

1997 CE Lancer speedometer

i had the same problem on my g/f's 2000 lancer GLXi, (with tacho),
i fixed the problem by putting a jump wire on the back of the instrument cluster,
the fault was in the wiring to the tacho part & i drew up my own wiring diagrams for the cluster unit,
then traced the fault,
looking @ the back of the cluster unit, the top right hand screw for the speedometer,,, follow the track on the circuit-board, there is a link wire UNDER the board (there is a dotted line on top where it goes, i think its the left 1,,, there is 2) this track then goes to the bottom left screw on the tacho,,,
i soldered a small gauge wire from the bottom of the link solder joint (MAKE SURE ITS THE CORRECT LINK, THERE IS 2 SIDE BY SIDE) to the bottom right track on the vertical plug socket (its common pos for the warning lights) this is where the "MIRAGE" & other "CE LANCER" (without tacho) gets its speedometer & gauges power from,

kind regards waz
if anyone needs a photo i will pull out the dash again lol its only 6 screws

Jul 17, 2008 | 2003 Mitsubishi Lancer

Not finding what you are looking for?
1997 BMW 328 Logo

848 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Anthony Jones
Anthony Jones

Level 2 Expert

128 Answers


Level 2 Expert

254 Answers


Level 2 Expert

281 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides