Question about Chevrolet S 10

1 Answer

82 s-10 that runs great cold, but bad when its hot...

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 702 Answers

Replace the ECT (engine coolant temp.) sensor. The computer thinks it's 40 below still even though the car is warmed up.

Posted on Jul 15, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kia carens 2008 crdi not starting when hot, turning over easy, new battery fitted, any ideas greatly appreciated, starts fine when cold.


run the fault codes
not starting hot indicates an electronic component problem when hot
could be faulty cam/ crank position sensors, immobilizer or ECM

Jun 16, 2016 | Kia Cars & Trucks

1 Answer

I keep losing spark on my 86 toyota, hot or cold


Sounds like a bad coil. But a sensor like a module or an aging distributor cap and rotor are the most suspect. Take off the distributor cap and see if a white powdery substance is building up scrape it clean with a sharp knife... it may run for a few months best to replace the rotor and distributor cap

Oct 15, 2013 | Toyota 4Runner Cars & Trucks

1 Answer

95 Jeep Grand Cherokee....I have no hot air. of course I assumed heater core at first but there is no puddle on the floor board and both hoses going to and from the heater core are hot at normal running...


Your heater core could be plugged with dust if this problem came up slowly I would suspect that. Another thing that cold be wrong is a trap door is not opening these are operated by cables vacuum or stepper motors. Confirm that something happens when you move from cold to hot on the control.

Nov 25, 2010 | 1995 Jeep Grand Cherokee

2 Answers

Once the car gets warmed up it doesnt want to run right, it is sluggish, mostly does it when im accelerating. but runs great when its cold


#1 dirty or bad egr valve #2 bad throttle position sensor or #3 control module in the distributor is bad they get hot and lose connection #4 could also be dirty catalytic converter my bet is on #1 or 3

Oct 11, 2009 | 1993 Chevrolet Camaro

2 Answers

1976 f350 with 1978 ford 460 dies or runs really bad when hot


sounds like its vapor locking,try a vented gas cap,or a clothes pin on your fuel line close to the carb.

Jul 22, 2009 | 1982 Ford F 250

1 Answer

1991chevrolet lumina will not start when hot has


could be bad coils,that are over heating.

Jun 18, 2009 | 1991 Chevrolet Lumina

2 Answers

1996 cavilier runs great until it warms up


It may be the ignition module. You will need to check to see if you have spark to the plugs when
it stalls. If not the module may be the problem. You will need to remove the module and take it to
a auto parts store that has a tester that can check it.

Dec 08, 2008 | 1987 Chevrolet Cavalier 4 Door

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...