Question about 1997 Ford Crown Victoria

1 Answer

97 crown was not skipping until i changed plugs.tried another set of plugs and then wires still skip

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 77 Answers

Did you replace the old plugs with the same type of plugs? Also, you may need to check the gap on your spark plugs. An alternative to this would be to purchase the platinum laser plugs, which require no gaping and have a limited lifetime warranty.

Posted on Jan 04, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I changed the plugs and wires and now its skipping


if it wasnt skipping before change than recheck the wire connections and plug gap --also new doesnt mean free from defect also check the connections around where you were working for possible accidental wire or hose disconnect

Jun 05, 2016 | Cars & Trucks

1 Answer

97 nissan pickup p0605


Code 605 is for a problem with the engine computer.
You could have a problem with one of the injectors or one of the plug wires may not be firing at the right time.

Mar 04, 2013 | Cars & Trucks

1 Answer

2003 monte carlo 3.4 130,000 skips on start up


I'd suspect a sticking injector--car should have set the check engine light. Read the code(s) to progress further. If the coil pack were a problem, it would not be likely to fix itself. If the codes indicate an injector problem, try an injector cleaner in the fuel--worst case, replace the bad injector. The codes should indicate which cylinder to change the injector.

Sep 09, 2012 | 2003 Chevrolet Monte Carlo

1 Answer

Skipping 97 dodge ram 5.2


Timing advance possibly or timing off if u have distributor u can check the timing by pulling plug #1 and bring it to top dead center and lift the cap and make sure the rotor is hitting #1 becareful if you set the timing not to get it 180degrees off . If you have a timining light it's the easiest way to check you can rent 1from most auto parts store .

May 15, 2012 | Dodge Ram 1500 Cars & Trucks

1 Answer

97 ford expedition cutting off at idle . it was skipping and hesitating under strain . had it checked by a computer and it said egr valve and number 6 cylinder misfire . i changed egr valve , plugs, wires...


pull wire off # 2 see if idle changes if not there s no spark... test coil....test all vacuum lines for leaks also. if all good then idle speed sensor.

Mar 20, 2011 | 1997 Ford Expedition

2 Answers

How do I find the spark plugs and plug wires so I can replace all on my 02 Ford Crown Vic (I have a skip under load)


I THINK I UNDERSTAND THE SKIP UNDER LOAD,LOL,BUT THIS CAR DOES NOT HAVE WIRES,IT HAS BOOTS,UNDER THE COIL PACKS,AND I HATE TO TELL YOU THIS,BUT,IF IT IS A 4.6 LITER,THEN,FUEL RAIL HAS TO BE LIFTED,GOOD LUCK

Apr 05, 2010 | 2002 Ford Crown Victoria

1 Answer

1992 crown vic with 78K miles. Started skipping


Replace you Maf sensor and have a nice day. lol does the hesitation go away when you let off the gas. does it buck hesitate and misfire under load? most common problem is the maf sesnor.
easy to change. don't buy a used part it may develop the same problem after a little while. you can try cleaning the wire inside with brake cleaner (not intake cleaner). it may or may not help.

Jun 26, 2009 | 1992 Ford Crown Victoria

1 Answer

Engine is skipping when accelerating


You only have 4 so better just do a tune up and change the plug and wires, but one at a time so you don't get them crossed when re-installing the new plugs and wire.
Use Platinum plugs since there good for 100,000 miles which mean less maintenance, and double check that the spark plug boots set to the plugs when re-installed.
Run some fuel injector cleaner through the gas tank for about a week to to clean out your fuel system and hope fully the skipping stops.
If your going to get all the goodys at Auto Zone, have them scan the car for any DTC codes since it's free and see if there are other issues that is causing the skipping like a bad signal from the MAP sensor ECT.
Good luck and keep me posted.

May 26, 2009 | 1997 Saturn SL

1 Answer

Skipping


it sounds like a secondary ignition problem if it only skips under load it is probably plugs and or plug wires

Oct 13, 2008 | 2001 Oldsmobile Alero

Not finding what you are looking for?
1997 Ford Crown Victoria Logo

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...