Question about 1998 Mercedes-Benz C-Class

1 Answer

Iv been having problems starting my car. Especially when the engine is cold. It take a few starts before its able to idle. When Im driving it doesnt have any power and cant get the revs above 3000 and the fuel consumption looks like its increased. Is this a problem with the fuel system or could it be electonical, wiring or anything?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Mercedes-Benz Master
  • 1,348 Answers

The mass air flow sensor is probably the issue.if the check engine light is on,have it scanned by mercedes or a shop that knows the car well.The newer ones have a electronic gas pedal,and when it goes,the car loses power,but it will set off the check engine light.The idle air control valve can cause idle issues,but will not usually affect top end power.

Posted on Jan 03, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Stalls after start up, Stalls when braking, then runs fine after a few minutes


Check the ECU engine temperature sensor. If it thinks the engine is hot, it will struggle to run when cold.

Mar 06, 2014 | Volkswagen Beetle Cars & Trucks

1 Answer

Rough idle when engine is cold and harsh shift from first to second gear.


It could be many sensors, before you do anything check it with a good scanner

Mar 26, 2013 | Cars & Trucks

1 Answer

My 96 olds does not like to start when it gets hot. seems to start ok when it cools down. Any ideas? It doesnt start real easy when its cold. have to rev a let idle a little before moving. idles pretty...


Hello, I have 1996 Ciera with rebuilt engine pretty new, also fuel filter and fuel pump replaced but I have a problem, the car starts and runs well cold but once car has been running for a few hours, either stopping or coming to a stop it starts to idle roughly and has come to a stop at different occasions. Check engine light does come on and off occasionally. Can you help?

Nov 05, 2010 | 1996 Oldsmobile Cutlass Ciera

2 Answers

I have a cold air intake on my mazda 6 car. At the top of where the tube meets engine area there is a noise. It's not a constant noise, almost only when the car is first started. I don't know the name of...


without seeing where you are taling about im guessing it to be noise from air going past the idle ait solenoid at the throttle body, since it will be open farther when cold. if that doesnt make sense, try explaining hte noise a little better. i really dont think its anything to worry abotu if it only does it when cold.

Oct 03, 2009 | 2003 Mazda Mazda6

1 Answer

My 300zx got smoke issue but im not sure.smoke come both sides when i start the car.it got little oil leak from turbos.but once engine got hot the smoke goes away.when driving it doesnt smoke.but it...


It sounds like you may need valve seals.
The oil sits in the head after the engine is cut off and leaks around the seals into the cylinder.
When you start the engine it burns the oil and sends the smoke out of the tailpipes.
It does not hurt anything much if it is not to bad.

Jun 04, 2009 | 1990 Nissan 300ZX

1 Answer

No high idle at cold start


i had same problem check the OVP fuse located behind the battery that were mine is i have a 1990 check were yours is at if the fuse is burnt all the electronics that help you engine run are inactive check it before anything the overload protection relay

Mar 09, 2009 | 1986 Mercedes-Benz 300

2 Answers

Engine running cold ?


check thermostat it can be stuck open

Dec 11, 2008 | 1995 Subaru Impreza

1 Answer

Nissan sentra 2006 GS automatic


IM HAVIN THE SAME PROBLEM...I THINK ITS THE MASS AIR SENSOR

Aug 07, 2008 | 2006 Nissan Sentra

Not finding what you are looking for?
1998 Mercedes-Benz C-Class Logo

223 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...