Question about 2003 Nissan Altima

1 Answer

2004 Nissan Altima 2.5S - Did a tune up, replaced spark plugs, checked gaps, started running rough as if there was a misfire. Every now and then the car jerks and has trouble accelerating. I changed the single coil ignition modules, one at a time, and even bought a spare spark plug, gapped it, and changed it around. It is idling rough, I'm thinking maybe an O2 sensor problem but can be a costly repair, any other suggestions

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 109 Answers

Suggest try replacing the plugs with the old once.quite posssible faulty plug.

Posted on Jan 02, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Was driving my 2010 nissan altima and it just stated running rough and wouldn't go fast, it hesitates and runs very rough. Sound like something grinding and missing. What can be wrong with it?


Is the check engine light on/flashing? If so, possible misfire causing the problem. Have the codes scanned for problem areas. You may have a defective spark plug or ignition coil

Feb 23, 2016 | Nissan Cars & Trucks

1 Answer

Car starts hard then idles roughly for 2-3min then stalls and dies


It sounds like some thing you have done if the fault started after the tune , did you check the gap on the new plugs, check the firing order as it may be messed up . 4 cylinder 1342 6 cylinder 153624 in direction of rotation.

Dec 03, 2015 | 1996 Nissan Altima

3 Answers

Why would engine run rough after tunr up?


Are plug wires connected in the right firing order to the plugs? Also are the spark plugs gap correct? Was vehicle running rough before tune up or only after?

Jul 05, 2014 | 1998 Ford Escort

2 Answers

How do i fix code PO300 on my 2000 Nissan Altima


That's a multiple / random misfire. Lot's of ways to go on this.. bad plug, wire, coil pack, etc. Then there's this one:
fixed my PO300 code MY350Z COM Forums

May 23, 2014 | 2000 Nissan Altima

2 Answers

What is the spark plug gap for a 2007 Nissan Altima


HERE'S THE LINK FOR THE 2.5 ENGINE,HERE/S THE 3.5 ENGINE.

Dec 23, 2013 | 2003 Nissan Altima

1 Answer

2006 Altima service engine light on, code 725


Check the SPARK plug condition, and AIR gap.
Regards,DT

Aug 26, 2009 | Nissan Altima Cars & Trucks

1 Answer

Misfire


you may need to have your spark plugs checked especially if they were just done (a recent tune up) misthreading can easily happen, or they may need to be replaced a car can run minus on plug. 

Dec 09, 2008 | 1996 Nissan Altima

Not finding what you are looking for?
2003 Nissan Altima Logo

1,334 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...