Question about 2003 Toyota Tundra

1 Answer

Just changed spark plugs, around 150 miles later noticed a sputter or mis-fire between 45-60 mph. pulled the plugs when i got home, no obvious issues with the plugs. problem continues to persist and the truck is progressively running worse. the check engine light just now came on. runs rough at idle and all the way through highway speeds. removed all the 10mm bolts to the coil packs and pulled each out one by one. even swapping the packs that were thought to be bad. getting an intermittent spark from the pack, but not consistent. im at a loss, do i replace the coil packs? or is it a idfferent problem. truck is a 2003 toyota tundra 4.7l v8. i have replaced the fuel filter, ran injector cleaner and fuel dryer also.all without any improvement

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 7,768 Answers

Hi, I recommend you get a free scan at your local parts chain and write down the trouble code. I suspect you have a bad crankshaft sensor, but the scan will confirm. Send us the trouble code if you would like further assistance, and thanks for using FixYa.

Posted on Jan 02, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sputtering engine while in passing gear


At 150000 miles the plugs start to fail under hard acceleration the higher compression blows out the spark before it ignites the fuel. Random cylinder misfire causes the check engine light to come on. change the plugs!

Jan 14, 2014 | 2008 Ford F-150

5 Answers

My spark plugs, when should I change them?


100,000 miles.
I hope that this help you! If so PLEASE click 4 thumbs up! Thanks for using Fixya.com Have a GREAT DAY!

Jan 13, 2011 | 2005 Ford F-150

1 Answer

Wont Start - No Spark


Older VW's and Audi's are notarious for this type of behavior. You actaully need a Vag or good diagnostic tester to tell you which plugs are mis-firing. You will need to replace a coil-pac or two. VW's issued a recall notice about 3 months ago about this issue and intends to re-imburse owners on certain models and years for coil-pac repalcement. After market coil-pacs should cost less than $50.00 each. Hope this helps.

Jul 05, 2010 | 2001 Volkswagen Passat

2 Answers

Oil around spark plug and car mis fires


The oil around the plug may be a sign that the valve-cover needs a new gasket. Oil on the plugs can cause a misfire but it is important that you check everything over. The misfire could be due to defective wires, boots, coils, spark-plug/s, injector/s, and so much more. Take a look at the cars maintenance history, Maybe it is over due for a complete tune-up or oil change. The car is 11years old, how many miles are on it? How was it running before this?

Apr 29, 2010 | 1999 Lincoln Town Car

1 Answer

I have an 89 ford bronco 2 with a 2.9 liter it sat around for 2 years without being started. I replaced the plugs, rotor, cap, ran fuel injector cleaner through it several times, checked cylider...


check the spark plug wires are attached all the way till it snaps, pull each spark plugs, any black deposits on any plug means it isn't firing(faulty plug,or wire) last of all take off each injector wire and notice if there is a change in idle speed (plugged injector)

Mar 21, 2010 | 1989 Ford Bronco II

2 Answers

My 2000 Town car with 47K miles, all spark plugs & fuel filter have been replaced. At 35 - 40 mph the motor feels like it is missing or there is water in the fuel. I have added fuel conditioner w/...


I had a Lincoln LS that had similar problem. It had a bad coil pack. You need a diagnostic computer to tell which one it is. Dealer fixed mine for around $150 with part included.

Jan 12, 2010 | 2000 Lincoln Town Car

1 Answer

1998 Pontiac Bonneville SE 3.8L Backfires/ Sputters


sounds like the ignition module is going bad.

Aug 04, 2009 | 1998 Pontiac Bonneville

1 Answer

Bonneville that sputters with acceleration


my pal jojo had this problem just 3weeks ago and his fix was plugs and wires.hope this helps.

Mar 21, 2009 | 1995 Pontiac Bonneville

Not finding what you are looking for?
2003 Toyota Tundra Logo

416 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...