Question about 2000 Mazda MPV

3 Answers

2000 mazda mpv

My minivan sputters when trying to accelerate it has 85,000 miles. What could caise this issue I was told it could ne the throttle, plugs or air filter which was recently changed. HELP

Posted by on

  • 1 more comment 
  • dunbec Jul 10, 2008

    I have a similar problem with my Mazda MPV 2000 which is more evident when climbing. My MPV has 200,000km and plugs and leads changed 50,000km previously..air filter just changed...heading for fuel filter next

  • Anonymous Nov 10, 2008

    wants to die when i asop

  • Jim  K
    Jim K May 11, 2010

    Did you change the fuel filter too?

×

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

My 2001 was just doing the same thing. Upon inspection, I found a vacuum hose broken. Taped it up with duct tape until the replacement came in. Under $20 for hose and new clamp. I also checked the routing of my plug wires and breakage. While replacing wires and plugs, I noticed the wires were plugged in incorrectly. Found the proper routing online and everything run great now. Slight whistling sound though, probably throttle body needs to be cleaned. Otherwise, no hesitation on idle or acceleration.

Posted on Jun 30, 2012

Ad
  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 41 Answers

You could try a seafoam engine cleaning, this process can remedia many problems and restore power

Posted on Nov 24, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

Have you had a compression test to see if the head gasket is leaking?

Posted on Jul 22, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Just changed everything plugs plug wires caps fuel filter and my 2005 Chevy impala 3.4L act's like it has power but still sputtering when I smash the accelerator what is going on I'm going crazy


Clean the throttle body on the inside, especially where the plate sets and the back side of the plate. Also clean the MAF sensor between the throttle and air filter. Use brake clean and a toothbrush, just spray down the MAF sensor. It'll take a second or two to start, then spray some down the throttle as you rev it up. This should take care of the sputter.

May 30, 2015 | Cars & Trucks

1 Answer

Acceleration problem


Could be a clogged fuel filter, could also be a slight crack in the throttle body gasket. get a spray bottle with water in it, set it to mist, while the vehicle idles, spray around the base of the throttle body, if it bogs down replace the throttle body gasket. Just curious, was it doing it before you changed the plugs and wires? If not make sure you have the firing order correct.

Dec 24, 2013 | 1997 Nissan Pickup

2 Answers

Jeep cherokee sport coughs when accelerating


Throttle issue or lambda sensor issue also ignition coils and crank sensor. can also be caused by leaks in air intake system or vacuum pipes.

Feb 07, 2013 | Cars & Trucks

1 Answer

1997 ford escort with 85,000 miles new plugs and


assuming there are no other performance issues after warm up...Pull any OBD II codes and go from there., Possible IAC - Idle Air Control circuit problem, injectors stuck or leaking, dirty throttle body, Poor Gas. Change to a different fuel station- possibly getting water in fuel tank after fill up. Good Luck!

Mar 16, 2010 | 1997 Ford Escort

1 Answer

2000 beetle turbo diesel looses power on hills


MAF -Mass Air Flow Sensor might be the issue.
www.tdiclub.com has ALL your answers!

Jun 25, 2009 | 2000 Volkswagen Beetle

1 Answer

A4 Sputtering/skipping when accelerating from stop


sounds like a spark plug or wherte the plug goes into

Mar 30, 2009 | 2003 Audi A4 Cabriolet

1 Answer

Sputtering between 1000-2000 rpms


adjust your throttle position sensor

Jan 03, 2009 | 1994 Nissan Maxima

1 Answer

2007 cobalt engine hesitating during acceleration


any ck engin lights could be bad gas or spark plug or coil pack braking down

Dec 18, 2008 | 2007 Chevrolet Cobalt Coupe

Not finding what you are looking for?
2000 Mazda MPV Logo

Related Topics:

449 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8826 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...