Question about Mercedes-Benz S-Class

1 Answer

I am planning to purchase 2002 S280 W220. i have been given 1 week to test the car and have taken it for a spin. it runs well. although i feel the engine seems loud. the SRS light is lit all the time and the SRS indicator light next to the Gear shaft is also lit all the time. the mileage is at 115700 km todate are there any issues other than this that i would have to be concerned about.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 541 Answers

Have it inspected at your local garage. it's cheap and you will avoid buying something that will end up costing you more than a new car

Posted on Jan 02, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why am I experiencing intermittent vibration when I drive my new car.


A/C compressor kicks on and off, Engine cooling fans do to. This could be the vibration you feel. This is normal.

Mar 24, 2016 | Cars & Trucks

1 Answer

I own a 2002 Isuzu axiom xs 4wd, my suv was running kinda sluggish 2months after purchasing it and would bog down while idling at times then jump up to high idle and while driving would sometimes jerk....


The test you haven't mentioned is the fault codes and should have been the first test before any thing as the codes will tell you what has happened . So run the fault codes .

Oct 30, 2013 | 2003 Isuzu Axiom

1 Answer

Mercedes s280


You'll need someone to scan the computer for trouble codes to proceed with testing.

Jul 29, 2013 | Cars & Trucks

1 Answer

I am planning to purchase a 2003 taurus wagon with 107k miles The car runs good actually very good The only problem I see is it the gear selector although it selects the gear properly has a lot of slack...


My 97 Mountaineer did the same thing and it was 2 screws that needed tightening . Take it to a dealer BEFORE you buy it and get them to look at it to make sure that it's not anything more serious than that.

Jan 26, 2011 | 2001 Ford Taurus

1 Answer

Unable to pass smog test, what to do


You just have to drive it . If you have more than 3/4 of a tank of fuel in it so the evap will run. All the others will run after is has fully warmed up.

Sep 20, 2009 | 2001 Chevrolet Cavalier

1 Answer

I bought a used saturn LW300 wagon, 6 cylinder. 94K miles. I have the complete service record from the time it left the showroom floor to when I bought it. It has had excellent maintenance. Since purchase...


I took the car into the dealer again to have the coolant topped off. They did the computer hookup again, as they have done each time...this time, when they pressure tested the coolant system, it failed the test. From there they found out that the coolant in leakin inside of the engine and leaks into the fuel injectors...they told me the problem is not fixable...except by replacing the engine.

Jun 05, 2009 | 2002 Saturn L-Series

1 Answer

Abs light and brack light flash wen u drive it


ABS sensor fault. This can be tested with a multimeter. There is a pick up sensor at each wheel on the car, usually reading off a castlated ring. Find the plugs for the sensor and set your multimeter to AC (the wiggly symbol) Use your test probes into the wires on the sensor side, and spin the wheel as fast as you can. The multimeter should read 0.2-2.0 volts ac. If nothing, then thats a faulty sensor.
Although i have given you a guide to doing this, it is better taken to a reputable garage with correct tools to have this test carried out.

TL

Jan 25, 2009 | 1999 Audi A6

1 Answer

1991 F150 front axle not locking in.


Front hubs need to be taken off and inspected for damage,
Replace as necessary.

Jan 12, 2009 | 1989 Ford F 150

1 Answer

Check engine light on and O/D OFF light flashing


before i waste my time will this message go through? (sorry first visit)

Jan 07, 2009 | 2002 Kia Spectra

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

185 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...