Question about 2003 Oldsmobile Alero

1 Answer

2003 Alero Oldsmoblie - It starts fine but runs rough in idle. Seems to want to take off while idling and sometimes in park. Sometimes it is worse when the engine is cold. We have replaced the spark plugs. A year ago the 02 sensors were replaced as well as the catalytic converter was replaced. The engine is a 2.2 liter automatic.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 8,755 Answers

Please see my tip at http://www.fixya.com/cars/r7427423-fix_poor_idle_high_idle_stalling_fuel . These are generic instructions. If you get stuck or need specific instructions for your car, please get back to me with model, year and engine info.

Posted on Jan 01, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Rough idle after engine is warm


Dirty air filter, dirty throttle body...try 2 bottles of gas line fuel injector cleaner...has your car been parked for awhile? Heet gas additive will work on any low gas tank sludge that you may have. Hope this helps.

Mar 24, 2014 | 1999 Mazda 626

2 Answers

Idles roughly, then low when stopped or in park, then dies. Decreasing gas mileage. Slow to accelerate


Sometimes that's caused by a vacuum leak near the manifold area.

Sometimes air in the coolant will cause an idle problem. Air will keep the air temp sensor from sending proper info.
Hope this helps.

Jan 03, 2014 | 2004 Ford Taurus

1 Answer

Still Rough Idle After Battery Disconnect


The first thing to do is not set up the idle speed, but to set the Idle mixture screw to lean best idle setting. First, turn in the mixture screw until the engine dies or runs worse, then back out the screw (recommend turning ¼ to ½ turn at a time). The engine should pick up speed and begin to smooth out.

The battery has nothing to do with the idle speed

Apr 09, 2017 | 2004 Mazda 6

1 Answer

2004 freelander hse erratic idle in park, fine in drive


Do you know what engine scan data is ? Disconnecting sensors is not the way to find a problem ! What is the computer seeing as data input signals . Is the vehicle in closed loop fuel control , is the EGR opening when it shouldn't be , Is the PCM controlling the idle air control valve or is the vehicle drive by wire (electronic throttle control ?
005 Idle Speed Problems Idle Air Control Test
007 Idle Speed Problems Scan Data for Idle

Jun 18, 2017 | Land Rover Freelander Cars & Trucks

1 Answer

Car idles rough in park also runs rough in overdrive


Sometimes a rough idle like that is a fuel filter. As you've already done the plugs and wires the fuel filter would be my next bet.

Mar 15, 2010 | 1993 Buick LeSabre

1 Answer

1992 4runner idels rough sometimes


Check the intake hose to make sure that it doesn't have a whole in it also check the air box that the filter goes in also. Mine was idling rough also and we found a whole in the filter box and the intake hose had a whole in it. Hope this helps.

Feb 23, 2010 | 1992 Toyota 4Runner

1 Answer

Rough idle, sputtering like its outta gas but it aint.


Could be a vacuum leak as it falls off under acceleration and does not play a part then. Check for broken or cracked hoses.....

Feb 13, 2010 | 2004 Dodge Neon

1 Answer

Battery died, gauge cluster bulbs on dimly, now rough idle result


How much have you driven vehicle? You need to drive long enough for computer to reset refrence points onboard. If that does not work, you have a bad voltage limiter on your instrument cluster board!

Jan 19, 2010 | 2003 Chevrolet Silverado 1500

1 Answer

Engine won't keep idle speed intermittently


check the idle control valve they sometimes get dirty

Sep 29, 2009 | 2001 Ford Explorer

1 Answer

Rough idel when cold start


if u have a damaged plug it can be running on 1 less cylinder ,it will idle very rough,change it!

Mar 26, 2009 | 1993 GMC Safari

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

529 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

77202 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8755 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...