Question about 1999 Ford F150 Regular Cab

1 Answer

Just bought a 1999 f150 pick up. the guy said he was having a charging problem and replaced the battery and altonator. He had a big sterio in it and removed that so right now it has no sterio. He had it put in professionally, so it does have the clips not just cut wires, but we were wondering if this might be a place to start the hunt, or if there is maybe something else that might cause this issue. He did say that the amp was hooked up directly to the battery, which has been removed.( well the amp is removed, the wires are still there) ... any suggestions?? THanks

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 984 Answers

Start with having the alternator tested ( out of the truck, not just a meter test like Autozone would do ) and have the battery load tested.

Could be the alternator field fuse is blown, this is the 20A fuse in the same block as the mega fuses on the firewall.
Also check the connector at the alternator to make sure it is in good shape, some times the connector will get gummed up.

Posted on Jan 05, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have bought c200 1995 second hand car, after replacing its battery i'm not able to use its sterio system. Any soluton?


go to benz dealer and they will run radio number on some older models the audio unit must be removed to get the numbers to get code info, or go and get aftermarket unit installed.

Jul 31, 2012 | 1995 Mercedes-Benz C-Class

1 Answer

1999 ford f-150. replaced alt. charged battery started truck 11.5 volts and dropping. within minuets the bat was dead. had new alt checked it was fine. coult the fusable link be bad


I doubt it is the link. The only way to kill a battery that fast is a huge short. Your wires should be smoking. Is the alternator wire shorted? I have some short troubleshooting tips, but I'm not sure they would work on such a big short--it really should be almost obvious. The tips are here: http://www.fixya.com/cars/r5925550-dead_battery_troubleshooting . These are generic instructions. Let me know if you have more questions.

Oct 02, 2010 | 1999 Ford F150 Regular Cab

2 Answers

Charging system alt does not chareg in truck. Bench tested O.K.


Measure the voltage at the big wire on the altenator engine off, do you have power? Check in your distribution box under hood, find the two rows of fuses located inside the box on the outer edge, look at the outside row from front to rear the 4th fuse (# 11/ 20 AMP fuse), is for the altenator field, make sure this fuse is not blown, if it is good and you have battery power on the big wire at the altenator, then replace the altenator. Hope this helps, let me know.

Dec 11, 2009 | 1999 Ford F150 Regular Cab

1 Answer

1984 Dodge D150 Pickup Truck V8 Electrical Problem, altonator is not putting out to keep the Battery charge. The altonator and senors have been replaced. Thanks Ken. kmkmbm@yahoo.com


Have your battery load tested. Be sure belt is not slipping . Abnornal battery draw (aftermarket accessories) or parasitic battery draw when shut off. Chrysler sells a high amp alt. for you truck.

Nov 28, 2009 | 1984 Dodge D150

3 Answers

Charging sytem in my 1999 f-150


replace battery cables if they are very old .check alternator wires fuse and fuse link.also check belt.

May 14, 2009 | 1999 Ford F150 Regular Cab

1 Answer

How do you check if altenator is charging battery,


Most vehicles if you get the car running and unhook the positive battery cable it will stay running that is because it is running off the alternator. if it dies like your talking about I would most definitely say your alternator needs to be replaced. Most likely when you jumped your father in laws pick up there was a bad ground somewhere and your alternator got a surge of electricity and it fried it. Hope this helps.

Mar 09, 2009 | 2005 Ford F-150

Not finding what you are looking for?
1999 Ford F150 Regular Cab Logo

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5520 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...