Question about Toyota Yaris

1 Answer

My car problem is when I full-up the petrol tank and it becoming hard-start it doesn't matter cold or hot, but when the tank is 1/4 up to the halfway there is no problem

Posted by on

  • 2 more comments 
  • funaki_malak Jan 01, 2011

    so, what should I do

  • funaki_malak Jan 01, 2011

    what about the evaporative systems

  • funaki_malak Jan 01, 2011

    is there anythings that you want me to consider in relation to my problem

  • funaki_malak Jan 01, 2011

    thanks alot for your help

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 6,826 Answers

Maybe the charcoal canister is saturated with gasoline or the evaporative system is defective.
That should point you in the right direction.

Posted on Jan 01, 2011

  • 3 more comments 
  • Duane Wong
    Duane Wong Jan 01, 2011

    You may want to check the fuel pressure regulator as well. Check the fuel pressure to see if it is within specifications.

  • Duane Wong
    Duane Wong Jan 01, 2011

    Also, check the fuel pressure when the car is hard starting vs. normal starting.

  • Duane Wong
    Duane Wong Jan 01, 2011

    If there is a significant difference in fuel pressure, between 1/4 to half tank and half tank to full tank, then there's a problem with the fuel pump.

  • Duane Wong
    Duane Wong Jan 01, 2011

    There are hoses that lead to the canister for the charcoal, that if you remove one, should not be full of gas. If you see too much gas in this area, or smell it, then the charcoal canister is full, and it may be flooding the carburetor or throttle body.

  • Duane Wong
    Duane Wong Jan 01, 2011

    A common problem with evaporative systems and charcoal canisters is if the automobile's gas tank is 'topped' off too frequently at the gas station, it can overfill the evaporative system.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My car is deprived of fuel when she gets to 1/4tank of petrol(45L full tank). did clean tank replaced fuel pump and fuel filter what can be wrong?


can only guess but would suspect the fuel guage is off by that much . keep it filled before it gets to 1/4

Apr 06, 2016 | Cars & Trucks

1 Answer

Where do I put water in for radiator ?


When engine is cool, take off radiator cap, and fill radiator. Then fill the coolant recovery container to halfway between the full cold mark and the full hot mark. Start engine (with radiator cap still off) and wait for the thermostat to open (upper radiator hose will get hot). Shut off engine, top up radiator, and put the radiator cap on. Fill the coolant recovery tank to the full hot mark.
You should mix the water and anti-freeze in a 50/50 mix before putting it in the car, you know. Cheers.

May 14, 2012 | 2001 Citroen Xsara Picasso

1 Answer

I have a Citi Golf and its cutting out. Its driving fine and just if you go a long way it will do that...it don't want to start and let you drive. It seems that it doesn't get petrol. They said I...


Hi i need help my mk1 golf carb starts and idle fine but as the car idle and enjin is getting hot then she just jerk and cut out then start it again it starts fine but idle for aboutfew sec then cut out again..i unplug the temp sensor problem remain petrol filter new new plugs and plug wires new boch distributor...plus 1/2 tank of feul...what els can i try any help..can this be electrical problem or what all my fuses checked and is fine any help pls

Mar 27, 2012 | 2007 Volkswagen Citi 1.8i

2 Answers

I have a ford focus 1.8 diesel x reg 1999 girlfreind put petrol in it about 3weeks ago we have drained it all re fueled it and it started and run but now it wount start


poss the fuel filter has petrol in it,replace filter,turn engine over with fuel line unattached to clear lines then fire up,should be fine.you may hve a hot start problem for awhile but fill up with diesel at 1/2 tank to dilute any petrol left.in 32 years in the trade i have put petrol in so many diesel cars,and as long as it starts,keep it running,and start only when cold ish.

Apr 24, 2010 | 2000 Ford Focus

1 Answer

2001 vw golf gt tdi is struggling to start when cold and sometimes hot..when started it struggles 2 stay ticking over at 900 revs...what can i do??please help


golfs coldstart system works when you open door/shut door/put key in hole and turn on (in that order)if you delay puting belt on for longer than say 30 secs the coils go cold,hence poor starting.if engine labours after cold start try using (really)one gallon of petrol in tank to clean injectors.
british army put petrol (30%)in diesel tanks of challenger tanks in arctic
to stop fuel freezing.....most parts replacement jockeys in garages will say if you put diesel in tank it will have to flushed out.lot of bollocks.
trust me.have put petrol in by mistake loads of times,only get hot start
problems if you put in too much.

Feb 05, 2010 | Volkswagen Golf Cars & Trucks

2 Answers

Need to change glow plugs on a mercedes C220D 1998


dont bother too much with thebullshit recipe .mercedesbenz were built in a cold country and have the cold start tecnique off pat .you need to establish if all the glow plugs are working .,if the engine misses and runs rough when it does start then the glow plugs are not all working but you need to test them with a test light and i would be inclined to think you will need to replace them. do them all as the ones that do work will stop soon.they all seem to go around the same time------------"youdoit "

Oct 15, 2009 | 1998 Mercedes-Benz C-Class

1 Answer

Nissan 300ZX engine rocking problem


Get to a Nissan repair shop ASAP!

Jun 05, 2009 | 1990 Nissan 300ZX

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...