Question about 1993 Chevrolet S-10 Blazer

Open Question

1993 s10 4.3 stalls out when you give it gas changed aic valve ,map sensor ,tps, and ecm, seems to be rich and no change in performance

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: 1989 Cavalier Z24 3.1 rough idle and hesitation

its just white cuz i too the cat off..

cuz i thought my proble could have been to do with the cat...

cuz i lost power driving up hills and on highways now it just will start the die right away

or start and idle really bad...

any ideas???

i was thinking crank sensor.. or injectors

Posted on Oct 01, 2008

tbirdfan1
  • 3051 Answers

SOURCE: I have a 1997 plymouth

hi there
I would call autozone and see what the codes are refering to they will be able to tell you .. the fuel filter may be starting to clog or the fuel pump is starting to malfunction or a egr or pcv valve is malfunctioning //

Posted on Mar 03, 2009

csmock132
  • 4669 Answers

SOURCE: My 1993 chevy 1500 Silverado truck suddenly quits

Check fuel pressure. Sounds like a bad pump.

Posted on Mar 08, 2009

suterman
  • 158 Answers

SOURCE: truck stalls when I give it gas

It sounds like they have got the distributor out of time. You will need to adjust the distributor. That is what it sounds like.

Posted on Jul 03, 2009

r_mcalhoun
  • 166 Answers

SOURCE: start hard runs rich

hi all the injectors and reg is inside the intake and are good about going bad. the top of the intake got to come off.

Posted on Jul 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why does my 2001 Hyundai accent stall? Auto Zone ran a check and these are the numbers they came up with P0108,P0300,P1123,P0304,P0303, P0302, P0301 They say AIC does not come up as bad. What do I do?


that autozone sales person should have asked when is the last time it had a tune up... ie, spark plugs etc...

reset the ecu/ecm and clear the codes... see if the same codes come back to verify

look for vacuum leaks first if you already done a tune up by changing those worn spark plugs, etc
P1123 Hyundai Long Term Fuel Trim Error System Rich

P0108 MAP Pressure Circuit High Input

and the 0300's have something to do with your ignition components; i'll let you google those since i googled the first 2 for you

Mar 28, 2015 | 2001 Hyundai Accent

1 Answer

Car stalls while going 55 mph What could be causing this?


Have to have a scan tool put on it to look at data & check
all sensors,not just for codes but that they work correctly

Fuel Pump
TPS Sensor
AIC Valve--if applic

Nov 23, 2012 | 2000 Pontiac Grand Prix

2 Answers

1993 Buick Skylark Custom 2.3 4 cy runs extremely rich and rpm surges at midrange?


not sure if the 93 has a mass airflow sensor, i know it has a air charge temp sensor that can cause the issue you are describing.

Oct 25, 2012 | 1993 Buick Skylark

2 Answers

1993 Lexus Ls400 loss of power at 2500-3000rpm


Check your MAF and MAP sensor. The first 80% of your throttle signal from the TPS works with the O2 sensor to try to keep the air fuel ratio to 14.7 to 1 with the ECM controlling the fuel injector spray time and timing the ignition. After the 80% to WOT the ECM puts the O2 sensor in to an open loop and takes the Reading form the MAF and MAP sensor to run the engine richer so there will not be any Detonation to the engine and burning holes in the valves for running too lean. That is why it always feel like you get a little more when you ease off on the gas peddle from WOT. Recap check the TPS, MAF,and MAP sensor and wires to those sensors, if you can get the car scanned that would be great and you may find out which sensor may have gone bad, the other thing to is the fuel pressure regulator may be going bad and at WOT the pressure may be to high causing it to run to rich causing the loss of power. Good luck and hope this helps. 

Jul 04, 2009 | 1991 Lexus LS 400

3 Answers

'90 3.1 lumina euro idles ok but tries to stall when accelerated.


If the cat is red then it is probably plugged if the motor can't exhale it wont run at high rpm

Apr 11, 2009 | 1990 Chevrolet Lumina

2 Answers

1991 s15 4.3 TBI jimmy will not idle


Might just be the timing is off a bit, turn your distributor or if it has a carburator, the choke might need to be turned up.

Mar 18, 2009 | GMC S-15 Cars & Trucks

4 Answers

My 1993 chevy 1500 Silverado truck suddenly quits


I put a new fuel pump, fuel filter, and a fuel pump relay and the fuel pump is still not coming on. I am not getting any fuel. Can you please tell me what it might be.

Mar 08, 2009 | 1993 Chevrolet C1500

3 Answers

1997 Ram 5.9L Stalling Problem


it may be the IAC valve. The Idle control valve. You can clean this valve by spraying cleaner into the fuel system side. Remove the duct work from the air cleaning system. Look inside the hole of the fuel clylinder walls. you will see a couple of holes. That is the IAC. With the engine running at about 1200 RPMs spray cleaner aiming at the valve holes. Get a good 10 seconds of spray in there. Turn off the engine and let it soak into the valve. Then repeat the procedure. If it still does not clear up, remove the valve from the outside. Clean it. If it still does not work. Replace the IAC. it could also be the egr valve, fuel pressure regulator , etc. just as you mentioned. But try the above procedure out. Since you mentioned that if you cleaned the carb body. I thought about the IAC valve.

Feb 08, 2009 | 1997 Dodge Ram 1500 Club Cab

1 Answer

1993 ford f150 w/ l6 engine won't idle/accelorate rite


unplug the engine coolant temp sensor. 1 for the ecm, not the gauge. It may be way off and causing engine to run very rich, thinking it's cold all the time. At highway speed, you're using enough to get by. If not the answer, uplug MAP sensor and try that. It could think you're in outer space or way below see level. It's black rectangle with vac hose going to it. boo switch and o/d cancel switch errors were likely you not actuating them during koeo test. Others could have been cause by other previous.

Nov 03, 2008 | 1993 Ford F150 SuperCab

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...