Question about Mazda 626

1 Answer

Started running bad suddenly. Had to feather the gas to keep it running and get home. Started it the next day and let it warm up for about 8 minutes. It died and won't start. Acts like it's not getting gas, but when I loosen the line after the fuel filter, gas comes out. When I crank it with this line loose, gas shoots out. Checked for spark using old school screwdriver in the wire. Getting spark on all four cylinders. Any ideas? Thanks, Kanaka

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 297 Answers

Take out the spark plugs again, put a little bit of oil down each cylinder, see if that helps. If it does, you might get a compression tester to check to see if one of the cylinders has lost compression (EG, a head gasket blew, etc ...)

Posted on Dec 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Symptoms bad fuel filter


could be a clogged catalytic converter, also check that your air filters are clean.

May 23, 2017 | Toyota Cars & Trucks

1 Answer

1991 F350 w/460 cu starts but runs rough until warm.


sounds like auto matic choke problem try a manual choke

Jan 02, 2014 | Cars & Trucks

1 Answer

2011 v6 camaro engine suddenly missing.


I think you got hold of a batch of stale gasoline, have seen it many times. This happens this time of year because they are using up all the winter blend gas so they can switch to the summer blend..

Apr 23, 2017 | 2011 Chevrolet Camaro

2 Answers

2011 Camaro engine miss-firing


Very hard to diagnose without trouble codes, but sounds like a fuel problem - bad gas, fuel filter plugging, fuel pressure regulator acting up, etc. I would certainly check fuel pressure at the engine with key on but not started, and then while trying to start.

Apr 18, 2017 | 2011 Chevrolet Camaro

2 Answers

2000 gmc serria wont stay running unless you feather the gas pedal after a minute or so it will be fine after it warms up it runs great


you have a bad idle air control valve and also a thottle position sensor. both sensors are located on the throttle body

Nov 25, 2012 | 2000 GMC Sierra

2 Answers

96 Dodge Ram suddenly had low bat power - hard start - runs poor


Any time the computer loses power it has to go threw a set of things to Learn how to run the car, it must go threw relearning process sometimes they never set all flags because you don't drive in conditions to set a flag, for example if you are in the desert and never drive up a hill like in Colorado then you would never meet that flag requirement, as for the low voltage it seems that the ASD shorts out on these rigs and sets the codes so you have to do a pin out of the computer to see if you have a bad ground a bad asd or asd relay and you would have to charge your battery to full capacity and do a voltage test and a load test on the battery and then see if the alternator is putting out.. Check the battery and charging system first.

Jun 29, 2009 | 1996 Dodge Ram

1 Answer

I have a 1999 Chevy Tahoe and yesterday while on freeway it just shut off so I sat for about 2 hours and then it started whent for about 10 minutes and it shut off again. Sat for about 30 minutes and it...


Probably your coil pack. That's usually how they act. They'll give you one extra chance to get home, and that's it. If it's not that then it's probably the fuel pump or filter, but the fact that it started again leads me to believe it's your coil pack.

May 13, 2009 | 1999 Chevrolet Tahoe

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...