Question about 1999 Chevrolet K2500

2 Answers

My 99 K2500 won't 4 wheel drive wont engage. When I press the button it flashes on 4 hi or lo then goes back to 2 hi. I've replaced the actuator and the transfer case motor. I can hear the motor running. I can also hear what I assume is the transfer case control module clicking.

Posted by on

  • 1 more comment 
  • jeffnobleone Dec 31, 2010

    The actuator I replaced was the one on the front differetial. I cannot test the power on the power switch on the top in 4 wheel drive, because it won't go into 4 wheel drive. I have checked the fuses, 2 and 24. Last year it did the same thing and I unhooked the leads to the transfer case motor and the front diff actuator, and it worked again for 10 months or so.

  • jeffnobleone Dec 31, 2010

    Also, for the past couple of months it would go into 4 lo but not 4 hi.

  • jeffnobleone Jan 01, 2011

    I tried what you said and I don't think I was doing it right. I unhooked the front differential actuator and tried metering it, I didn't get a reading that made sense to me. I only got mV readings, maybe I ' not on the right setting. I also tried to meter the switch on the top of the transfer case, same result. But, now my drive will only try to activate when in neutral. It will go into 4 lo though. Previously I did replace the actuator on the front differential.

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Expert
  • 4,070 Answers

Hi and welcome to FixYa!

Have you tried replacing the transmission fluid? If not, then as a first course of action please replace the fluid. When the fluid is burnt, the transmission can act unususal. A smooth performance and shifting will be noticeable after the procedure.

Hope this helps and thank you for using FixYa! Have a good one!

Posted on Jan 01, 2011

  • dj_relly999
    dj_relly999 Jan 01, 2011

    Hi! How's the car going? Any update please?

  • dj_relly999
    dj_relly999 Jan 01, 2011

    Hi! May I know any update on the car please... Thanks!

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 17,970 Answers

Have you checked the power at the switch on top of the transfer case switch? The brown wire has power on it all the time, and feeds power to the transfer case switch. Check to make sure there is power on both sides of the switch when in 4 wd.

Could be the switch, transfer case shift motor, wiring, etc. Also, I suggtes check the fuse box (I think that is in the fuse position 24). Likely there is an actuator on the front differential, it might be steel or it might be plastic , depending on if it has been replaced before, thats whats wrong with your 4x4 if it lights up but dont engage. This work on them all the time.

The two outside terminals of the transfer case switch ( A , and C) Gray/black, and black wires. The brown wire on this vehicle comes off the 4wd fuse in fuse panel directly to terminal C of the actuator. Terminal B of the actuator is gray/black and goes to the transfer case switch. The transfer case switch connects this wire to ground on this year model.( it is different than previous models, wear the switch supplied power to the actuator)

If you ground the gray and black wire the actuator should move. If it does then check wiring to the transfercfase switch and the switch itself:
- The wire from the tranfercase ground to the same location as terminal E of the actuator.
- Connect a test lamp to battery positive voltage and touch terminal E of the actuator. It should light.
- Do the same for terminal B at the actuator, when in 4wd. It should light the test lamp( gry/blk wire)
- If it doesn't light, the transfer case switch is most likely open, poor connection or broken wire.
- If it does light on terminal B when connected to battery positive, Inspect the terminal in the plug for being too loose and not making connection to the actuator terminal.

Hope this helps

Posted on Dec 31, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2006 trailblazer indicates 4 lo but is in 2 wheel drive


Switch may be bad. Change switch should fix it.

Mar 13, 2014 | 2006 Chevrolet Trailblazer

1 Answer

Stuck in 4 wheel lo, how do i get it back to 2 wheel hi ?


On these issue, there are few solved help links for troubleshooting the issue easily.-------

Click the link below: ---

No 4x4 light on dash?

http://repairhelpcenter.blogspot.com/2011/12/no-4x4-light-on-dash.html

-----------

4X4 Truck makes roaring noise in the front end?

http://schematicsdiagram.blogspot.com/2012/01/4x4-truck-makes-roaring-noise-in-front.html

-------------

Car will not go into 4WD high or 4WD low?


http://schematicsdiagram.blogspot.com/2011/12/car-will-not-go-into-4wd-high-or-4wd.html

--------------

No 4x4 light on dash?

http://repairhelpcenter.blogspot.com/2011/12/no-4x4-light-on-dash.html

------------

4 wheel drive system will not disengage?

http://technoanswers.blogspot.com/2012/01/4-wheel-drive-system-will-not-disengage.html

----------

4WD light is flashing and beeping? NO 4WD high?

http://schematicsdiagram.blogspot.in/2012/02/4wd-light-is-flashing-and-beeping-no.html

----------

2002 Jeep Wrangler: 4WD Idiot Light is ON?

http://technoanswers.blogspot.in/2012/06/2002-jeep-wrangler-4wd-idiot-light-is.html

----------

Traction control switch will not engage on 4WD High or Low

http://whoisbyme.blogspot.com/2012/10/traction-control-switch-will-not-engage.html

-----------

4WD light flashing and 4WD will engage after few minutes

http://repairhelpcenter.blogspot.com/2012/10/4wd-light-flashing-and-4wd-will-engage.html

------------

2008 Toyota Tundra: 4x4 Wheel Drive Light is Flashing?

http://technoanswers.blogspot.in/2012/05/2008-toyota-tundra-4x4-wheel-drive.html

----------

4x4 front differential will not engage the axle on ford?

http://technoanswers.blogspot.in/2012/02/4x4-front-differential-will-not-engage.html

-------

4x4 will not engage on Ford F150?

http://technoanswers.blogspot.in/2012/02/4x4-will-not-engage-on-ford-f150.html

-------------

Dodge Ram 4x4 light keeps flashing

4X4 LOW LIGHT IS FLASHING ON DASH

http://technoanswers.blogspot.in/2012/09/dodge-ram-4x4-light-keeps-flashing.html

----------

Ford 4x4 front wheels will not engage?

http://technoanswers.blogspot.in/2012/02/ford-4x4-front-wheels-will-not-engage.html

-------------

These details will help.

Thanks.

Dec 09, 2012 | 1999 Chevrolet Blazer

1 Answer

Chevy blazer 2005 zr2 will not go into the 4X4 option either hi / lo or auto 4X4 press the button into each one and all it does is keep blinking and will not engage into 4 wheel drive


under your batt tray needs removed youll find a rubber hose goin to a vacume canastersee that it aint cracked or got a hole

Oct 27, 2012 | Cars & Trucks

1 Answer

1998 Chevy Blazer 4x4, $ wheel drive won't work (both 4hi & 4lo )


Reset the computer by disconnecting the battery. This should solve this. nutetral is for the four lo only to engage.

Mike

Jan 26, 2009 | 1997 Chevrolet Blazer

2 Answers

Can't engage 4X4 wheel drive or disengaging


Check the actuator (located under the battery plate). Remove the battery, then the plate, and you'll see something that looks like a horn attached to hoses. One side is soft, and may have a hole in it. This will cause the vacuum not to work, hence, your 4WD won't. Good luck!

Dec 23, 2008 | 1996 Chevrolet Blazer

1 Answer

97 ford expedtion 4 wheel drive problem


check the wires on the switch. pop off the middle dash panel. ( the one that goes over the radio and climate controls. the switch will be in the left side. check the wires to make shure they are not loose or corroded. Most likely your problem is the actuator needs replaceing. One way to see would be to turn on switch to 4hi and lightly tap on the actuator arm. do not hit it hard enough to break anything!!!

Dec 19, 2008 | 1999 Ford Expedition

Not finding what you are looking for?
Cars & Trucks Logo

183 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...