Question about 1991 Chevrolet S-10 Blazer

1 Answer

It starts hopping and shaking when i accelerate. Gets worse as it warms up. It's idle is very inconsistent. It turned itself off while i was backing into a parking spot. we've replaced the fuel filter, but that didn't help.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,548 Answers

A friend of mine with this model says the EGR valve is prone to carbon clogging. This can cause rough running and stalling. His fix was to remove the valve, scrape out the grosser carbon deposits, soak it in carburetor cleaner and get the rest of it clean, then replace the EGR gasket with an aftermarket product that has a screen to keep the junk out.

Other things to check are the vacuum hoses and fittings, the fuel injectors, spark plugs and cables to make sure it's firing on all cylinders.

Do you get a "Check Engine" light? If so, go to a car parts store and ask them to read out the error code for you. This will help narrow down the problem. There are several sensor problems that could contribute to rough running or stalling under load, especially in "closed loop" mode (the engine runs "open loop" until it warms up).

Posted on Dec 30, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

06 dakota 4.7. P0300 replaced plugs,injectors,coils,o2 sensors & all other sensors,intake cleaned.bad ecm? cats show same temp both sides of cat, bad cat? Or??


Have you checked for vacuum leaks? Poor idling when cold that gets better when the engine warms up, or at higher RPMs are symptoms of vacuum leaks. Check all hoses and connectors. If it's a manifold gasket, you will want to use a smoke machine (check when the engine is cold).

Apr 03, 2017 | Dodge Dakota Cars & Trucks

1 Answer

2007. Check Engine light is off. When I Accelerate to 40 mph to 60mph, why does the engine start to shake?


Bad motor mount? Sure that the shake is not coming from an unbalanced wheel with a corresponding shaking in steering wheel?

Sep 05, 2015 | Ford Expedition Cars & Trucks

1 Answer

What to do with sputtering and lack of acceleration


Scan for codes stored ion the OBD computer. Many auto parts stores can do this for you at no charge. Based on the results - a complete tune up may be in order.

Good luck!

Apr 14, 2015 | 2002 Ford Taurus

1 Answer

Audi a6 2.5tdi shaking on idle


what it does when you attempt to accelerate? still on shake and gets worse? if is that what is happening possible injector's fault. Try to use a scanner to give you any fault code.

Sep 09, 2012 | 2005 Peugeot 405

1 Answer

Acceleration problem


possibly camshaft position sensor in the distributor, or weak fuel fump starts acting up when warm, or throttle position sensor. heat has a effect on sensors and electrical components in some weird and hard to find ways.

Jun 11, 2012 | 1994 Toyota Tercel

1 Answer

When I start my car there is gas smell and it has poor acceleration. The acceleration gets better as the car warms up... The car also idles rough.I recently had an oil change I also changed the spark plugs...


the gas smell makes me think EGRS (Exhaust Gas Recirculation System) check all your Vacuum hoses, start at your charcoal canister and work backwards.

A vacuum problem explains your conditions at least...

Sep 25, 2009 | 1995 Nissan Maxima

1 Answer

1994 uick lesabre barely runs when pushing gas ped


also with request of pcv valve check does car shake or vibrate when trying to accelerate? if that is to be the case more than likely bad pcv valve.

Mar 30, 2009 | 1994 Buick LeSabre

1 Answer

Why is my 1994 Chevy S10 Blazer lugging? motor shakes and lugs.


Could be vacuum leak or bad ignition wire(s).

I had a similar problem on my "93 Ford probe. The engine idled pretty rough with shakes, Turned out to be a head gasket leaking engine coolant into the cylinder during low rpm's. At fast rpm's it was fine becuase the internal cylinder pressure was greater than the hot coolant pressure & would prevent the coolant from leaking in.

A friend has the same problem with his "94 Blazer 4.3 L, throttle body injection, manual tranny. He hasn't fixed it yet, It started a few weeks ago & is getting worse. His gets a fast idle with hiccups which causes the engine shake. He already checked the EGR valve. He also has a severe exhaust problem, Not oilly but very gray & terrible smelly, but only when the fast idle problem happens. THis fast idle hiccup problem starts when the engine is warmed up.

Nov 19, 2008 | 1994 Chevrolet S-10 Blazer

1 Answer

Engine idling varies depending on light or aircon is on/off


dude its normal for first start or cold start that the idle is ok but it must high than normal... its normal because the engine is warming up it self... when it gets warm, the idle speed will return normal idle... your engine is 1200cc, it has not much HP for a great load... and i know its a carburatored engine and its an old engine, your head lyt and a/c fan and aux fan and all the electrical system on your car, uses the HP of you engine and its a lot of load to the alternator driven by the engine to generate an electricity they need and thats why the engine rpm speed lowering down to dead and its shake. thats why when you use your lyts or all electrical, you engine is weakening... the best remede is adjusting you idle speed... its located behind the carburator.. its a small black knob.. just make a twist each eighter way and you'll find out if your idle rpm speed ts incresing or decresing.. just increase it and try opening your lyts and other electrical, if its still shaking then adjust it a little more

Aug 26, 2008 | 1994 Honda Civic

Not finding what you are looking for?
1991 Chevrolet S-10 Blazer Logo

152 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...