Question about 1995 Eagle Talon

1 Answer

I put a thermostat in it and after we got it in. it started missing.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,114 Answers

Hello did you half unplug a wire by mistake perhaps a ignition wire or coil??look closely

Posted on Dec 30, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 dodge intrepid overheating even after New thermostat put in,what could be causing this


several reasons
if it has a viscous fan hub( clutch) replace it
blocked radiator cores
fins missing from radiator cores, timing, air /fuel ratio to lean
faulty head gasket /cracked head ( needs a compression test)
air lock in the cooling system
if electric fan check fuses and relay to start the fan

Jul 20, 2015 | Dodge Cars & Trucks

2 Answers

1994 Toyota Camry,New water pump,new radiator,but car is over heating and missing,it smokes from the radiator when I stop....


Did you replace the thermostat? How long does it take to overheat? Is there water coming out of the tailpipe? Do you have to keep adding water to the radiator?

Sounds like a blown head gasket from the engine miss. Pull the spark plugs, if any of them are kind of a bleached white on the electrode then you've got water in that cylinder and either a blown head gasket, cracked head/block, or a combination of those.

Good Luck!

Sep 01, 2014 | Cars & Trucks

1 Answer

No power/ engine missing


ANY HEAD PROBLEM WILL OVER HEAT THE ENGINE IN LESS THAT 2 MIN. MAY BE A SET OF PLUGS AND WIRES CAP AND ROTOR WOULD BE A GOOD START. DONT FOR GET THE FUEL FILTER.

Feb 14, 2013 | Cars & Trucks

1 Answer

Heating problem with a 1.6 liter engine (1985 Chevy chevette).


could be a sensor problem...have it scanned.....good luck..

Aug 22, 2012 | Chevrolet Chevette Cars & Trucks

1 Answer

2002 buick lesabre custom has had issues lately with at speed 50-55 it kinda misses and just yesterday overheated and has no heat, i put a new thermostat in did not fix the problem but the radiator was...


if your radiator has a cap remove it and start the motor turn the heater on high and put it on defrost watch the coolant when the bubbles stop coming out and the fluid is at a full level there should be no more air in the system. a miss fire is caused by bad plugs or plug wires and i would back flush the heater core remover the hoses going to the firewall and flush the heater core with water from your garden hose. to check the water pump start the motor and watch the pump to see if any fluid comes from it.

Dec 16, 2010 | 2002 Buick LeSabre

1 Answer

1998 corvette c5 has miss at idle. I've changed plugs and put in a new throttle positioning sensor. Put products in gas for water. Still misses.


Try cleaning your Mass air flow sensor. When the MAF sensor gets dirty, it can cause your engine to run slightly lean and make sure your engine is running at normal operating temperature with a good thermostat.
At idle, if the MAF is slightly dirty and giving the wrong signal to the PCM. There is a good chance that your engine have a lean condition enough to cause it to have a miss. It's may just be in the perimeters that it will not set a check "service engine light" on, but will cause it to miss.
Start with that and post us back, be glad to help and thank you for using fixya.

Jul 19, 2010 | 1998 Chevrolet Corvette

1 Answer

Estima missing and overheating


Hi!

I think you missed checking a couple of things more.

1.- Water Pump
2.- Temp. Sensor
3.- Radiator Fan
4.- Timing
5.- Spark Plugs
6.- Spark Plug Wires
7.- Vacumm Leaks
8.- Fuel system (Pump pressure, injectors, leaks)
9.- Electrical System
10.- Check for even compression on all cilinders.

I hope this help you find your problem
Good Luck.

Mar 10, 2010 | 1996 Toyota Previa

1 Answer

Heater issues.


did you mount the thermostat properly... sounds like it is reversed

here is a picture of the proper orientation

ec6a918.jpg

Jan 26, 2009 | 1989 Nissan Maxima

Not finding what you are looking for?
1995 Eagle Talon Logo

Related Topics:

30 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eagle Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Stewart Dibbs

Level 2 Expert

305 Answers

Are you an Eagle Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...