Question about 1997 Cadillac Seville

1 Answer

Charging is not charging right. I have had the alt. rebuilt twice and a new alt put on. Two weeks ago I put a new heavy duty battery on it. Every time I have it worked on it will put out 14 or more volts for about two weeks then it starts dropping to as low as 11.8 volts. When it drops below 12.3 the shifting indicator lights will flash and the temp gauge stops working and the anti theft system problem will show. After I turn it off and let it set for a few minutes and restart the volts will return back to 13.5 or better. Turning on the headlights on seems to have a major affect. Please help!!

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,044 Answers

You have a faulty Voltage Regulator or relay in the power Distribution box under the hood.

Posted on Dec 29, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Tips to troubleshoot battery (seeking) Receiving "Battery not charging" message from computer.


Take it to Auto Zone or O`riellys and they will test it for you at no charge.They can check your charging and starting system also.Hope this helps.Good luck.

Nov 13, 2011 | 2003 Chevrolet Silverado 1500

2 Answers

99 aurora, change alt 2 months ago now its over charging 16.7


That's fine this happens i have gotten from 30 minutes to a week out of rebuilt alternators up to 10 years 2 months ago you should have warranty on it contact supplier.

Jan 05, 2011 | 1997 Oldsmobile Aurora

1 Answer

Problems with starting up battery is fully charged glow plugs was new in december 09 will sometimes start with jump starter also brand new heavey duty battery last week and still wont start on occasions


Hi my name is Tom and I am here to help.

You are on the right track with a heavy duty battery. You have a diesel engine. It has a high compression. If you replace your starter with a heavy duty one, that should clear up your problem.

If I can be of further help let me know.

TomE twenslin@aol.com

Jun 23, 2010 | Cars & Trucks

1 Answer

Alt not chaging properley had it rebuilt twice


you have a dirty earth some were maybe on the engine to body or battery to body look for all the earth straps and take them off to scrub them clean with a wire brush then smear them with petroleum jelly do both battery leads as well every earth must be very clean it wont hert to smear some petroleum jelly in the alternator plug it keeps the road dirt out of it and it all helps at the end of the day,,,

Jun 05, 2010 | 1993 Isuzu Trooper

1 Answer

I put in a new battery and altanotor but there is no charge what do i do


i guess you are saying your alt. is not charging....did you check all fuses....and if a rebuilt alt from advance or auto zone they have bad rep for alt and starters

Oct 15, 2009 | 1994 Oldsmobile Silhouette

3 Answers

02 trailblazer power problems


the alt variation is normal. When under load or not under load, the amps will fluctuate. If anything else, the voltage regulator is faulty. Or, there is a faulty relay somwhere

Sep 04, 2009 | 2002 Chevrolet TrailBlazer

2 Answers

1985 mercedes-benz 190D, 202, automatic, i just bought a starter 3 weeks ago. Sometimes when i go to start the car. it just click when i turn the key and then i waite and it may click again when i turn the...


The starters on the Diesels are pretty heavy duty so unless the bolts or a wire is coming loose I would rule out "going bad already" Other issue would be if you put in a used one 3 weeks ago.
Take note how the ignition feels when you turn the key, if you wiggle it and turn it slowly just right does it help ? The contacts in the back of the switch may be wearing out.
I hope this helps
Sam

May 13, 2009 | 1985 Mercedes-Benz 190

1 Answer

1994 grand cherokee ltd. charging problem


Yes that little thing on the alt is the regulator. It tells the alt when to charge and when not to and yes its pcm controlled. You can bypass the pcm but I would not reccomend it. I would say alt is probably bad...Cause that pcm wire dosnt usually cause any issues. Youu can have the alt tested at autozone. They can test it in the car or out although out of the car is a much more thurough test. I would again say al is bad....rebuilt stuff is usually rebuilt with good parts from old units meaning most all the parts are used...

Jul 22, 2008 | 1994 Jeep Grand Cherokee

Not finding what you are looking for?
1997 Cadillac Seville Logo

149 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8499 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...