Question about Chevrolet Suburban 1500

1 Answer

When I stop to fill up on gas and I go to restart my 2006 Suburban it is hard to get it to crank. Once it cranks it runs fine until the next fill up. The check engine light came on and I had my friend to check the code. It showed PO460. What the heck is going on. I am affraid one day it will not start back at all.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,098 Answers

( P0460 ) - Fuel level sensor circuit malfunction

Not sure it has anything to do with the starting though, sounds like 2 faults you have there. Is the battery good? is it cold lately where you are?

Regards
Dan

Posted on Dec 29, 2010

  • coachmcguire Dec 29, 2010

    Very Cold but it is a brand new battery. It turns over good but sounds like it is not getting fuel

  • Dan Doherty
    Dan Doherty Dec 29, 2010

    Get the fuel relay for the pump checked it may be sticking internally or not making a good contact with the wiring. Also check the earth leads "black ones" to and from the battery, the main one from the battery to the car body, ensure this has a good contact with the car body / metal work.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 2003 pontiac sunfire lose all power while driving


That can be the symptom of a bad Ignition Control Module, or also a bad crank position sensor. The ICM can be taken off and tested for free at any parts store. The crank sensor circuit can be tested on the car with a multi-meter. Also small motors (like a fuel pump motor) that are starting to fail can sometimes work until they get hot and then stop working until they cool down again.

Next time the car shuts down and won't restart, check for spark on a spark plug wire with the engine cranking over. If you have no spark, suspect the ignition control module or the crank position sensor. If you still have spark, but won't start, check if the fuel pump is putting gas up to the engine.

Sep 12, 2014 | 2003 Pontiac Sunfire

1 Answer

Gmc Arcadia runs fine until I put gas in it. It is hard to start I have to disconnect the vacuum line from crank case. Then it will start put it back together and is fine until I get gas again. The vacuum...


there must be a blockage in the crank case vent /pipe, probably, you could try tightening the fuel tank cap a bit more after filling up , i know this sounds a bit dodgy but you could have a weak seal and the EVAP system is recording emission to atmosphere , otherwise get the OBD CODES READ TO SEE IF THERE IS A FAULTY SENSOR/SWITCH

Jun 27, 2014 | Cars & Trucks

1 Answer

When hot will randomly not start unless gas pedal is pressed all the way down. on a 2001 honda crv. replaced fule pump,fuel relay,fuel filter, dist. cap, rotor, coil,plugs, wires, and ignition control


If you hold the pedal to the floor it puts the fuel system into Clear Flood Mode. This prevents the injectors from firing and lets the already present fuel burn out. Now if this has to be done on every short trip you probably have a leaking injector.

Does the vehicle seem to crank slowly or stop and then crank when this happens?

Mar 23, 2014 | 2001 Honda CR-V

1 Answer

My 1997 gmc 1500 suburban will not run but it pulls no dtc codes on the cpu


My 97 Suburban had a similar problem. Would not crank on a regular basis. Replaced spark plug wires, plugs and rotor cap. Vehicle cranked and ran just fine, plugs were in poor shape. Checked fuel pressure, above 55psi with engine running or just the switch turned on. Immediately after switching engine off the pressure would bleed off to "0" PSI. Otherwise everything OK. Problem solved, so I thought. A couple days latter I had to make a road trip from Mobile, Al to Fort Meyers, Fl when cranking problem re-occurred after approx. 100 miles into trip. I stopped at parts houses on the way to ask questions and to obtain their best ideas, at times it would take 30 minutes before engine would again crank after making a stop. I replaced almost all of the sensors. Finally made it to Fort Meyers that night. Next morning vehicle was dead would not crank no matter what I tried. Fuel pressure OK. Only thing left to replace, Fuel Injector spider system. Problem solved.

Jul 19, 2012 | 1997 GMC Suburban

1 Answer

My 2006 g6 sometimes will crank but not start. does it when cold and warm. sometimes you can try again and it will start other times it takes a few tries


tons of reasons.... depends on your troubleshooting feedback fouled plugs (change em) crappy gas (put a pint of gas cleaner in the tank at next fillup before you fill it) low fuel pressure (breach in fuel delivery?)
I assume you are not pumping the gas pedal at all, but if you are, do not do that. Leave your foot off ! If you do pump it, it will most easily flood it with gas and prevent ignition until the gas is cleared (you can clear a flooded system by pressing and keeping the gas pedal to the floor (once) and try to crank. Release the pedal immediately upon successful ignition revolutions.

Feb 08, 2011 | 2006 Pontiac G6

1 Answer

Ford Explorer ED SUV won't start after filling up the gas tank. Immediately after putting gas into the car, the car won't restart. I've been stuck several times next to the gas pump. After a while, and...


Its not a gas issue. Its more than likely just coincidence that it doesnt start when you turn your car off to fill up.

Check the battery connections under your hood. If the posts (the positive and Negative leads) are corroded then you need to clean them so your cables have better connection to draw a spark for your ignition.

Clean the posts with a solution of 1 part baking soda, 1 part warm water. Use an old toothbrush to scrub the corrosion away. The solution will fizzle when you mix it with the corrosion, this is normal and fine. Just scrub it clean.

Once clean, tighten the connection with a socket wrench.

You may also be having battery issues. If its been a long time since a new battery or youve never replaced it, I would. Paying 70 bucks up front for a brand new battery is much better than getting stranded and a tow

. Autozone can help you with the battery replacement. Hope this helps. good luck.

Sep 16, 2010 | 2006 Ford Explorer

1 Answer

2006 Nissan Titan alternating misfiring and running fine until !


My truck is doing the exact same thing. I have been told it is the Intelligent Power Distribution Module or IPDM. The Nissan Dealership that is working on my truck says $400.00 parts and labor to fix.

Jul 19, 2010 | 2006 Nissan Titan

1 Answer

Motor starts and runs for less than a minute then cuts off and WILL NOT CRANK OVER again for 15 to 20 minutes. then it cranks over, starts, runs less than a minute and cuts off again. it has been fine...


It sound more like a plugged catalytic converter. When you start the engine the pressure starts to build until the engine sufficates then after you let it set the pressure bleeds off and lets the engine restart.

Jun 23, 2010 | 1989 Chevrolet Suburban

1 Answer

2003 Tiburon GT starting problem


try blowing out the fuel filler cap vent hole.possibly blocked.

Mar 25, 2010 | 2003 Hyundai Tiburon

1 Answer

Wont start after setting


Remove air cleaner Spray carb with carburetor cleaner inside and out let dry try to start..

Probable cause dirty carb or air cleaner choke not set properly or needs adjustment
and cleaned>>Charg battery ans check fluid level fill only with distilled water

Jan 30, 2009 | 1997 Chevrolet Suburban

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

318 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...