Question about Mercury Villager

1 Answer

Turned on wipers to clear off snow both worked for a minute then the drivers side stop working and seems to move freely by hand as if linkage is broken

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Mercury Master
  • 715 Answers

It probibly stripped the insert, if you get a screw driver and pop the cover up, there is a hex nut, remove it, the wiper arm should pop right off, either replace it, switch it to the right side (not recommended unless emergency, big blind spot on right side of winshield) I have cut a piece of a can (aluminum) and placed it between the shaft and the wiper arm, replace the nut and adjust before tighting, it will hold for awhile, Good luck

Posted on Dec 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Passenger Side Windshield Wiper Broken


Hi Jill,
The first thing to check is a 13mm nut that holds the wiper arm in place.See if you can move the wiper arm freely back and forth.There is a nut at the base of that wiper arm,Lift up a cover that is hiding the nut. If it comes loose from being froze from ice or snow. Put the wiper in its rest position and tighten the nut back up.

Feb 06, 2014 | 2004 Chevrolet Cavalier

1 Answer

2005 Dodge Magnum RT. Drivers side windshield wiper wants to work, but does not. Had a heavy snow and remotely started the car. Forgot the wipers were on. When I noticed it, the Driver side was off the...


You will need to find where in the linkage the problem is. I would start taking it apart to see what is and what isn't working correctly. Autozone website has free repair manuals available online.

Apr 24, 2013 | Cars & Trucks

1 Answer

Heavy snow sliding off my vehicleroof may have damaged the linkage of the front wipers. Passengerside wiper does not wipe-driverside works. How can I get acess to the linkage to find the problem ? 2005...


Please check if the wiper arm of the driver side that fits into the knurlings have worn out due to the fact that snow would have exerted pressure on the wiper arm. You need to remove the wiper blade assembly and see if the knurlings have tapered off. If so remove and tighten the fittings as this might be moving freely.
If the arms are moved it must be move up and down which can indicate either that links are damaged or jumped off the joints.

Apr 15, 2011 | 2011 Infiniti QX56

2 Answers

Driver's side windshield wiper stopped working duing a heavy rain. I can move it by hand easily. Has the linkage come loose?


Hello, I would say that is exactly what has happened. If you can move the wipers with no resistance it's likely one of the bolts has come loose. Both wiper arms are linked to one wiper motor.

Mar 07, 2010 | 2004 Chevrolet Cavalier

2 Answers

My driver side wiper is not moving but the passenger side is. It is a 1993 Mazda MX6 LS. Any ideas?


it seems the motor is working ok so it only leaves your linkage or the actual wiperarm mounting to fault.remove the retaining nut on the drivers side wiper arm usually a 12 or 13 mm spanner.once removed turn wipers on and keep hands clear, look at the drivers side spindle,if it turns when the other wiper moves your linkage is ok and you need a new arm, if it dosn't move then its your linkage,hope this helps!

Feb 17, 2010 | 1993 Mazda MX-6

2 Answers

Wipers worked one turn then stopped


may have broken bushing in one of the arms in the wiper linkage, remove the cowl and take a look. most part stores sell replacement bushings start there good luck.

Jan 07, 2010 | Mitsubishi Colt Cars & Trucks

2 Answers

Passenger and driver windshield wipers won't work. i can hear the motor running. i tried to use the wipers to clear off a bunch of snow. it started to go but then stopped. i cleared the rest of the snow by...


see if the transmission arms for the wiper motor are moving when the wiper motor is on. The bolts that hold the arms to the motor may be loose or stripped out from the heavy know. The threads for these bolts are thin and don't take much to strip.

Jan 01, 2010 | Subaru Outback Cars & Trucks

1 Answer

Wiper Linkage


yes the wipers pull off and you need to get the linkage from the dealer the parts just snap on

Mar 10, 2009 | 1997 Nissan.5 Altima

1 Answer

Wiper Linkage


Take off both of the wiper arms and try to use wipers if they are moving you didn't install the arms correctly. If thats the case with the arms off and the wipers running turn them off with the wiper switch and wait for them to "park", then tun off the ignition and reinstall the arms in their proper location. Also when the linkage falls off you should replace it with a new one. It is a ball and socket fitting and when it fails it spreads the plastic socket and loosens it up. It is also reccommended when you are inside there you should always replace the linkages in pairs and also check the pivots (the knurled studs that the wiper arms bolt to) for play and if necessary replace these as well. Good luck.

Jul 11, 2008 | 2001 Nissan Altima

1 Answer

My wiper linkage has siezed i have removed the linkage and motor and found that the driver side spindle end is completely siezed and icant move it,the passenger side spindle end moves/seems fine also the...


it might be the motor has siezed. disconnect the linkage from the motor and turn wipers on if works then linkage at fault, if not then motor needs replacing.

Jun 03, 2008 | 2005 Ford Mustang

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

fordexpert

Level 3 Expert

5470 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...