Question about 1994 Buick Skylark

1 Answer

Trouble took a trip up to chicago from arkansas but before that the car ran well all but some times when i started it up, it would ide it self high and then later ide down about 30 seconds. the car has over 250,000 miles. i started noticing the high ide problem around the time i drove the car up from chicago to arkansas about 10 mouths ago. now this time when i took the car back to chicago and back home to arkansas it got about 50 miles from home and lost power and stopped. after trying to start it again it started right up but as soon as i touched the gas it cut off. after trying it again i was able to hold the gas down and the car would pull off fast but not as fast as it would have in times past after driving about a mile the car lost power again and stopped. now while driving at top speed and releasing to stay at speed limit i was only able to drive the car that way. if i tryed to drive normal it would not give speed to the car, just as a bald out stage. i pulled over and let the car cool off looking under the hood and calling for a tow, while waiting i tryed the car again and it stated slugish, i pumped the gas and tryed to keep it running and was able to move about a half block before it died at that time i notice the whole exhust was red hot, so i started thinking that the catlye converter was pulled but then i thought it is only about 2 years old, and that maybe because i was pumping the gas while tring to drive it caused the egr valve to off set and made the exhust piping turn red. after waiting on my towing service to find a tow truck service near me i tryed it again and this time it started and i put it in drive and it rolled at ide about 15mils per hour, for abot 20 miles i did not touch the gas in fear it would cut off, after climbing many hills it finally stopped at one. at this time my wife came and we left the car til the next day. on the next day i was about to pull the car home on a dolly but tryed it and it started and drove home, slugish but it made it. it set in the yard about a week when i i decided to try to work on it, it would not start, and when it did it was sluggish big time touch the gas and it go dead. now before i took the car to chicago a 12 hour trip i had chaged the front three pulgs and was going to change the back three on the next day but never got back to it. my guess is that the fuel regulater is bad, or the way i did the plug change off set the power after that long trip, i was going to change the last three, and still will have to but wanted to know what do you all think is wrong.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 674 Answers

First of all thanks for all the information too many times you dont get enough info to correctly identify the problem so kudos.
i realy think your right one your fuel pressure. but you need to check the pressure dont just replace parts. it could be a bad fuel pump or fuel filter . you didnt say what the plugs looked like . were they black( a sign of over fueling and a bad regulator) or bright white (from lean burn) you could also hace an intake gasket leaking that would cause the lean burn,

Posted on Aug 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 pt cruiser wont stay running without conking out


Has anyone checked the timing? Are the cam and crank sensors I synch? Fuel preassure? Any DTCs(diagnostic trouble codes)? Last time timing belt was replaced?

Jul 07, 2014 | 2001 Chrysler PT Cruiser

1 Answer

Engine was idling then just stopped appears to have siezed what would cause this


Lack of antifreeze and water (coolant) flowing into the engine. Water pump failure or not enough coolant in the system. Lack of motor oil flowing in the engine. Very low amount of motor oil in your car or oil pump failure.

Jul 03, 2014 | 2005 Lincoln Navigator

1 Answer

I have cylinder 123 misfire new plugs wires and coil pack


Darlene, we were out of town on a trip, and my wife's 1998 Exployer (V8) had carbon buildup in the intake system that suddenly showed up and car was running terrible.

A Garage in Prairie Grove, Arkansas took apart the top of the intake and cleaned it ($75 if my memory serves correctly).

My Son's 2006 Exployer had random misfires that plugs and wires did not solve. I took the car to a garage (Able Auto Service, 7th and Osage, Kansas City, Kansas) that had a carbon cleaning system where they opened the fuel line and ran a chemical thru with the fuel as the car was running in the shop.

Cleaning the carbon from the intake system solved the problem with both cars. I can't remember what the name of the system & procedure was. They Charged around $150 for the procedure.

I would recommend calling Able Auto Service (7th & Osage Ave, Kansas City, Kansas) (913) 321-1030) and they can tell you the name of the procedure. Maybe you could find a local auto service garage that does the same procedure.

Apr 26, 2014 | 2002 Ford Explorer

1 Answer

Car wont start. took a fuel injector out and put the same one right back in and it ran for 2 days fine now wont start again, what is the problem?


A possible fuel pump pressure issue. You will need to have a garage check the fuel line pressure. The engine requires more fuel on cold start and a failing pump may not be able to cope with supply. This may also be apparent at high revs, but not as apparent as cold start.

Oct 30, 2012 | 1996 Chrysler LHS

1 Answer

My 2003 chevy malibu cranks but wont start. battery is good and altenator is good


To clarify - - if the engine cranks the battery and starter are ok.
The alternator does not come into play until the engine is running.
If it cranks but won't start, you have to figure out if you are missing fuel to the injectors or spark to the plugs to proceed.
A mechanic would check that and if there are any trouble codes stored in the computer.

Jul 22, 2012 | 2003 Chevrolet Malibu

1 Answer

1992 dodge w-250, took her in for a service...bleed fuel lines...


It sounds like you are talking about a diesel engine as gas engines are self priming. Lift pump or primer pump may be defective. Check for loose fittings or lines and damaged o-rings at filter housing. Sounds like you are sucking air somewhere.

Jan 30, 2010 | 1992 Dodge Ram 250

1 Answer

Car ran fine then on a long trip developed some loss of power now


does the engine get over heated if so check the radiator system, also check oil level.

Sep 22, 2009 | 1991 Cadillac DeVille

1 Answer

2000 mazda MX-5 1.8l


Have you checked that you have power to the coil on cranking?You may also want to check wether you have a good strong spark at the spark plug.It could be an ignition module breaking down.If you have no power to the coil you may need to change the ignition relay.Its close to the battery.

Oct 26, 2008 | 2000 Mazda MX-5 Miata

1 Answer

Truck won't start


the ignition baril that contain the chip for the theft system is defectif just change the baril our trouble gonna be gone cheers pierre

Jun 28, 2008 | 2003 GMC Sierra 2500HD

Not finding what you are looking for?
1994 Buick Skylark Logo

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...